# No login with 'elastic' user after upgrading from 7.17.1 to 8.3.2

**URL:** https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515
**Category:** Kibana
**Tags:** elastic-stack-security
**Created:** [September 15, 2022, 1:38pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515 "2022-09-15T13:38:14Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![gerib](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gerib/32/106584_2.png) [@gerib](https://discuss.elastic.co/u/gerib)
#### Post date: [September 15, 2022, 1:38pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/1 "2022-09-15T13:38:14Z")

</div>

![grafik](https://us1.discourse-cdn.com/elastic/original/3X/4/e/4eba2cb068993438c1845ddfc7fe1e3228affb78.png)

Our Cerebro shows the cluster in green, all of our 9 nodes are there with **ES: 8.3.2**.

There are no `[ERROR]`s in Kibana's log, just `[INFO]`s and `[WARN]`s.

This appeared in the process of upgrading our dev cluster and we will not upgrade our prod cluster unless this works properly there. ATM we have 2,732 indices, 5,465 shards, 3,826,484,223 docs, 2.21 TB in our prod cluster, so we want to be absolutely sure that everything works before upgrading it.

---

<div class="post-metadata">

### Author: ![Yang\_Wang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yang_wang/32/48857_2.png) [@Yang\_Wang](https://discuss.elastic.co/u/Yang_Wang)
#### Post date: [September 19, 2022, 12:51am UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/2 "2022-09-19T00:51:03Z")

</div>

You need grab logs from the Elasticsearch node that handles the Kibana login to see the underlying issue.

Also, are you able to login with any other users? Is the problem just with the `elastic` user?

---

<div class="post-metadata">

### Author: ![gerib](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gerib/32/106584_2.png) [@gerib](https://discuss.elastic.co/u/gerib)
#### Post date: [September 19, 2022, 12:18pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/3 "2022-09-19T12:18:02Z")

</div>

I checked the log of the current master node (Is this the one that handles Kibana logins?). The only lines with "error" are:

```auto
Line 1: 2022-09-19 10:08:38,122 main INFO Cannot initialize scripting support because this JRE does not support it. java.lang.NoClassDefFoundError: javax/script/ScriptEngineManager
Line 291: at org.elasticsearch.indices.recovery.RecoverySourceHandler$OperationBatchSender.handleError(RecoverySourceHandler.java:1209) ~[elasticsearch-8.3.2.jar:?]
Line 292: at org.elasticsearch.indices.recovery.RecoverySourceHandler$OperationBatchSender.handleError(RecoverySourceHandler.java:1126) ~[elasticsearch-8.3.2.jar:?]

```

The msg on line 1 appears also in the logs of our other two master nodes.

`users_roles` contains:

```auto
...
admin:cerebro
kibana_system:kibanaserver
...

```

Trying:  
 ![grafik](https://us1.discourse-cdn.com/elastic/original/3X/e/e/eedbebd9998ef9acd2891563a631e833f946d11e.png)  
 ![grafik](https://us1.discourse-cdn.com/elastic/original/3X/c/f/cfbc372b53c26ae853f26d5c980764d533093cc5.png)

both lead to:

![grafik](https://us1.discourse-cdn.com/elastic/original/3X/b/5/b5f649962427c3bc83881d5ca42a9903424b9823.png)

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [September 19, 2022, 1:07pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/4 "2022-09-19T13:07:51Z")

</div>

can you connect to cluster via curl

curl -u elastic:password -XGET hostname:9200/\_cluster/health?pretty

---

<div class="post-metadata">

### Author: ![gerib](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gerib/32/106584_2.png) [@gerib](https://discuss.elastic.co/u/gerib)
#### Post date: [September 19, 2022, 1:28pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/5 "2022-09-19T13:28:23Z")

</div>

> curl -u elastic:password -XGET hostname:9200/\_cluster/health?pretty

```auto
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
  0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (52) Empty reply from server

```

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [September 19, 2022, 1:44pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/6 "2022-09-19T13:44:51Z")

</div>

did you replace password and hostname with your value?

---

<div class="post-metadata">

### Author: ![gerib](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gerib/32/106584_2.png) [@gerib](https://discuss.elastic.co/u/gerib)
#### Post date: [September 19, 2022, 1:45pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/7 "2022-09-19T13:45:38Z")

</div>

Of course.

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [September 19, 2022, 2:09pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/8 "2022-09-19T14:09:30Z")

</div>

this tells me you are able to connect because if you are not then you get error like this

Check cluster log and Kibana log closely.

```auto
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "unable to authenticate user [elastic] for REST request [/_cluster/health?pretty]",
        "header" : {
          "WWW-Authenticate" : "Basic realm=\"security\" charset=\"UTF-8\""
        }
      }
    ],
    "type" : "security_exception",
    "reason" : "unable to authenticate user [elastic] for REST request [/_cluster/health?pretty]",
    "header" : {
      "WWW-Authenticate" : "Basic realm=\"security\" charset=\"UTF-8\""
    }
  },
  "status" : 401
}

```

---

<div class="post-metadata">

### Author: ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)
#### Post date: [September 19, 2022, 2:17pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/9 "2022-09-19T14:17:07Z")

</div>

> [@gerib](#):
>
> `curl: (52) Empty reply from server`

This often means that you are trying to connect to an HTTPS endpoint over HTTP

Try this

`curl -k -u elastic:password -XGET https://hostname:9200/_cluster/health?pretty`

---

<div class="post-metadata">

### Author: ![Justin\_Cranford](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/justin_cranford/32/85302_2.png) [@Justin\_Cranford](https://discuss.elastic.co/u/Justin_Cranford)
#### Post date: [September 19, 2022, 4:10pm UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/10 "2022-09-19T16:10:20Z")

</div>

W.R.T. the `kibanaserver` and `cerebro` errors in Kibana UI:

1. The role `kibana_system` is only for background administration on an Elasticsearch cluster. That role contains internal-only privileges, no user-level permissions to access the UI. You will need to use a different role for Kibana UI login.

2. The role `admin` sounds like it might be custom. Check if it has the appropriate privileges as mentioned in Kibana 8.3.2 docs. Privileges may have changed between 7.17.1 and 8.3.2.

---

<div class="post-metadata">

### Author: ![Yang\_Wang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yang_wang/32/48857_2.png) [@Yang\_Wang](https://discuss.elastic.co/u/Yang_Wang)
#### Post date: [September 20, 2022, 1:32am UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/11 "2022-09-20T01:32:16Z")

</div>

Given the permission error you are having when logging into Kibana, it is likely Elasticsearch authentication/authorization system is working fine. To solve your original problem, you can give user `cerebro` the `superuser` role temporarily. Login with it and change the password for the `elastic` user. You can then remove revert the changes to user `cerebro` after it is done. To give user `cerebro` the `superuser` role, just add the following line to the `users_roles` file:

```auto
superuser:cerebro

```

PS: Once you made the change, the ES node will automoatically reload the file in at most 5 seconds.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 18, 2022, 1:33am UTC](https://discuss.elastic.co/t/no-login-with-elastic-user-after-upgrading-from-7-17-1-to-8-3-2/314515/12 "2022-10-18T01:33:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
