# No logs on Kibana discover under filebeat-\* index

**URL:** https://discuss.elastic.co/t/no-logs-on-kibana-discover-under-filebeat-index/156136
**Category:** Beats
**Tags:** filebeat
**Created:** [November 10, 2018, 12:49pm UTC](https://discuss.elastic.co/t/no-logs-on-kibana-discover-under-filebeat-index/156136 "2018-11-10T12:49:41Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Shahid\_Chaudhary](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shahid_chaudhary/32/37134_2.png) [@Shahid\_Chaudhary](https://discuss.elastic.co/u/Shahid_Chaudhary)
#### Post date: [November 10, 2018, 12:49pm UTC](https://discuss.elastic.co/t/no-logs-on-kibana-discover-under-filebeat-index/156136/1 "2018-11-10T12:49:41Z")

</div>

I installed new ELK server single node .

on the first login i am getting the error of indice idex .  
here is my filebeat logs form y ELK server.

sudo service filebeat restart  
root@ip-172-31-10-222:# sudo tail -f /var/log/filebeat/filebeat  
2018-11-10T12:23:15.678Z ERROR pipeline/output.go:100 Failed to connect to backoff(elasticsearch([http://localhost:9200](http://localhost:9200))): Connection marked as failed because the onConnect callback failed: Error loading pipeline for fileset nginx/access: This module requires the following Elasticsearch plugins: ingest-user-agent, ingest-geoip. You can install them by running the following commands on all the Elasticsearch nodes:  
sudo bin/elasticsearch-plugin install ingest-user-agent  
sudo bin/elasticsearch-plugin install ingest-geoip  
2018-11-10T12:23:15.678Z INFO pipeline/output.go:93 Attempting to reconnect to backoff(elasticsearch([http://localhost:9200](http://localhost:9200))) with 4 reconnect attempt(s)  
2018-11-10T12:23:15.679Z INFO [publish] pipeline/retry.go:189 retryer: send unwait-signal to consumer  
2018-11-10T12:23:15.679Z INFO [publish] pipeline/retry.go:191 done  
2018-11-10T12:23:15.679Z INFO [publish] pipeline/retry.go:166 retryer: send wait signal to consumer  
2018-11-10T12:23:15.679Z INFO [publish] pipeline/retry.go:168 done  
2018-11-10T12:23:15.699Z INFO elasticsearch/client.go:712 Connected to Elasticsearch version 6.4.3  
2018-11-10T12:23:15.719Z INFO template/load.go:129 Template already exists and will not be overwritten.  
2018-11-10T12:23:29.379Z INFO [monitoring] log/log.go:141 Non-zero metrics in the last 30s {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":120,"time":{"ms":121}},"total":{"ticks":770,"time":{"ms":775},"value":770},"user":{"ticks":650,"time":{"ms":654}}},"info":{"ephemeral\_id":"1d169a7c-b030-42f1-8b17-704cdee49d4d","uptime":{"ms":30250}},"memstats":{"gc\_next":11102784,"memory\_alloc":5923976,"memory\_total":20553408,"rss":29851648}},"filebeat":{"events":{"active":4126,"added":4145,"done":19},"harvester":{"open\_files":10,"running":10,"started":10}},"libbeat":{"config":{"module":{"running":0},"reloads":1},"output":{"read":{"bytes":9916},"type":"elasticsearch","write":{"bytes":5783}},"pipeline":{"clients":13,"events":{"active":4120,"filtered":22,"published":4116,"retry":100,"total":4142}}},"registrar":{"states":{"current":7,"update":19},"writes":{"success":19,"total":19}},"system":{"cpu":{"cores":2},"load":{"1":3.93,"15":3.69,"5":4,"norm":{"1":1.965,"15":1.845,"5":2}}}}}}  
2018-11-10T12:23:31.814Z **ERROR pipeline/output.go:100 Failed to connect to backoff(elasticsearch([http://localhost:9200](http://localhost:9200))): Connection marked as failed because the onConnect callback failed: Error loading pipeline for fileset nginx/access: This module requires the following Elasticsearch plugins: ingest-user-agent, ingest-geoip. You can install them by running the following commands on all the Elasticsearch nodes:**  
\*\* sudo bin/elasticsearch-plugin install ingest-user-agent\*\*  
\*\* sudo bin/elasticsearch-plugin install ingest-geoip\*\*

I tried to install this

by using the below bits its not installed.

**root@ip-172-31-10-222:/bin# sudo bin/elasticsearch-plugin install ingest-user-agent**  
**sudo: bin/elasticsearch-plugin: command not found**  
**root@ip-172-31-10-222:/bin# sudo elasticsearch-plugin install ingest-user-agent**  
**sudo: elasticsearch-plugin: command not found**  
**root@ip-172-31-10-222:/bin# apt-get install elasticsearch-plugin**  
**Reading package lists... Done**  
**Building dependency tree**  
**Reading state information... Done**  
**E: Unable to locate package elasticsearch-plugin**  
**root@ip-172-31-10-222:/bin# apt-get install -y elasticsearch-plugin**  
**Reading package lists... Done**  
**Building dependency tree**  
**Reading state information... Done**  
**E: Unable to locate package elasticsearch-plugin**

the issue is under the discover TAB i am getting logs against merticbeat-\* and heartbeat-\* indexs but there _no logs against the filebeat- index_\*  
please find the screen for the references

 ![Index%20details](https://us1.discourse-cdn.com/elastic/original/3X/d/4/d4971ff0f536eb855a95b3bfae5046a7fcecd9ea.png) ![Indices](https://us1.discourse-cdn.com/elastic/original/3X/4/3/43dac9c7af6f59655adfcb0f4f8df1f0aec7dde7.png) ![Discover-Filbeat](https://us1.discourse-cdn.com/elastic/original/3X/a/0/a03398bdcf565844cb00a95dac408e432d514b48.png)

---

<div class="post-metadata">

### Author: ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)
#### Post date: [November 12, 2018, 8:51pm UTC](https://discuss.elastic.co/t/no-logs-on-kibana-discover-under-filebeat-index/156136/2 "2018-11-12T20:51:33Z")

</div>

Please properly format CLI input/output, logs, and configuration files using the `</>` button.

How did you install/setup elasticsearch? Looks like your Elasticsearch setup is incomplete.

```auto
root@ip-172-31-10-222:/bin# sudo bin/elasticsearch-plugin install ingest-user-agent
sudo: bin/elasticsearch-plugin: command not found

```

You get this failure because you are either a) in the wrong directory, b) the source you installed from does not contain the elasticsearch-plugin tool, or c) elasticsearch-plugin is installed in some other directory.

You get this error:

```auto
root@ip-172-31-10-222:/bin# apt-get install -y elasticsearch-plugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package elasticsearch-plugin

```

Because the package does not exist.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 10, 2018, 8:51pm UTC](https://discuss.elastic.co/t/no-logs-on-kibana-discover-under-filebeat-index/156136/3 "2018-12-10T20:51:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
