# No meaningful logs from bulk write operation failure

**URL:** <https://discuss.elastic.co/t/no-meaningful-logs-from-bulk-write-operation-failure/137662>\
**Category:** Elasticsearch\
**Tags:** es-hadoop\
**Created:** [June 27, 2018, 4:41pm UTC](https://discuss.elastic.co/t/no-meaningful-logs-from-bulk-write-operation-failure/137662 "2018-06-27T16:41:45Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rkalluri](https://avatars.discourse-cdn.com/v4/letter/r/fbc32d/32.png) [@rkalluri](https://discuss.elastic.co/u/rkalluri)\
**Post date:** [June 27, 2018, 4:41pm UTC](https://discuss.elastic.co/t/no-meaningful-logs-from-bulk-write-operation-failure/137662/1 "2018-06-27T16:41:45Z")

</div>

I am trying to index some geo\_point data using apache spark, the operation fails with out giving me any information on what is wrong and how I can fix it. When I index the field as string everything checks out. Any clues on how to configure a bulk error handler to print meaningful message and move on. Currently spark crashes after some time.

I also have ignore\_malformed set to true on elastic side so am guessing this is happening on spark side of things and not elastic.

"settings": {  
"number\_of\_replicas" : 0,  
"index.mapping.ignore\_malformed": "true"  
}

Here is a fun stacktrace:

ERROR Executor: Exception in task 7.1 in stage 0.0 (TID 13)  
org.elasticsearch.hadoop.EsHadoopException: Could not write all entries for bulk operation [1/100]. Error sample (first [5] error messages):  
failed to parse  
Bailing out...  
at org.elasticsearch.hadoop.rest.bulk.BulkProcessor.flush(BulkProcessor.java:475)  
at org.elasticsearch.hadoop.rest.bulk.BulkProcessor.add(BulkProcessor.java:120)  
at org.elasticsearch.hadoop.rest.RestRepository.doWriteToIndex(RestRepository.java:187)  
at org.elasticsearch.hadoop.rest.RestRepository.writeToIndex(RestRepository.java:168)  
at org.elasticsearch.spark.rdd.EsRDDWriter.write(EsRDDWriter.scala:67)  
at org.elasticsearch.spark.sql.EsSparkSQL$$anonfun$saveToEs$1.apply(EsSparkSQL.scala:101)  
at org.elasticsearch.spark.sql.EsSparkSQL$$anonfun$saveToEs$1.apply(EsSparkSQL.scala:101)  
at org.apache.spark.scheduler.ResultTask.runTask(ResultTask.scala:87)  
at org.apache.spark.scheduler.Task.run(Task.scala:108)  
at org.apache.spark.executor.Executor$TaskRunner.run(Executor.scala:338)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624

---

<div class="post-metadata">

**Author:** ![james.baiera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/james.baiera/32/10209_2.png) [@james.baiera](https://discuss.elastic.co/u/james.baiera)\
**Post date:** [July 2, 2018, 4:22pm UTC](https://discuss.elastic.co/t/no-meaningful-logs-from-bulk-write-operation-failure/137662/2 "2018-07-02T16:22:43Z")

</div>

I agree, that is indeed a totally useless error message. I've opened [https://github.com/elastic/elasticsearch-hadoop/issues/1170](https://github.com/elastic/elasticsearch-hadoop/issues/1170) in response.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 30, 2018, 4:22pm UTC](https://discuss.elastic.co/t/no-meaningful-logs-from-bulk-write-operation-failure/137662/3 "2018-07-30T16:22:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
