# No metrics send to logstash

**URL:** <https://discuss.elastic.co/t/no-metrics-send-to-logstash/141208>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [July 23, 2018, 3:27pm UTC](https://discuss.elastic.co/t/no-metrics-send-to-logstash/141208 "2018-07-23T15:27:13Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Khaled\_Saidi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khaled_saidi/32/98636_2.png) [@Khaled\_Saidi](https://discuss.elastic.co/u/Khaled_Saidi)\
**Post date:** [July 23, 2018, 3:27pm UTC](https://discuss.elastic.co/t/no-metrics-send-to-logstash/141208/1 "2018-07-23T15:27:13Z")

</div>

Hi Elastic Team,

After installing and configuring Filebeat and Logstash, i can consult my gathered logs in Kibana.  
So, today full of confidence, i decided to install metricbeat.... and then, the drama ! LOL  
I inform that metricbeat was installed as a service on a Windows 7 environment.  
No metrics were send to logstash. I notice several errors in the metricbeat logfile.

```
ERROR	logstash/async.go:235	Failed to publish events caused by: read tcp XXXX : i/o timeout
ERROR	logstash/async.go:235	Failed to publish events caused by: client is not connected
ERROR	process/process.go:454	Error getting process details. pid=9696: error getting process arguments for pid=9696: ProcArgs failed for pid=9696: could not get Win32_Process WHERE ProcessId = 9696: Process not found

```

While i have no problems with filebeat...

in the metricbeat conf file, i have :

```
metricbeat.config.modules:
   path: ${path.config}/modules.d/*.yml
   reload.enabled: false
   reload.period: 60s

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
   
output.logstash:
  # The Logstash hosts
  hosts: mylogstash.url.com:5044

logging.level: info
logging.metrics.enabled: true
logging.metrics.period: 30s
logging.to_files: true

logging.files:
    path: "C:/ProgramData/TW/HWM/metricbeat/logs"
    name: metricbeat
    rotateeverybytes: 10485760
    keepfiles: 7
    permissions: 0600

logging.json: false

```

Do I have to specify something else on metricbeat and/or logstash conf ?  
Any ideas... ?

Thanks a lot for your help or any suggestions.

BR,  
Khaled

---

<div class="post-metadata">

**Author:** ![Khaled\_Saidi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khaled_saidi/32/98636_2.png) [@Khaled\_Saidi](https://discuss.elastic.co/u/Khaled_Saidi)\
**Post date:** [July 26, 2018, 1:00pm UTC](https://discuss.elastic.co/t/no-metrics-send-to-logstash/141208/2 "2018-07-26T13:00:10Z")

</div>

Up !

No one has ever encountered this error ?

BR,  
Khaled

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 23, 2018, 1:00pm UTC](https://discuss.elastic.co/t/no-metrics-send-to-logstash/141208/3 "2018-08-23T13:00:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
