# "No monitoring data found" error on Kibana

**URL:** https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749
**Category:** Elasticsearch
**Tags:** elastic-stack-monitoring
**Created:** [October 31, 2018, 4:33am UTC](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749 "2018-10-31T04:33:42Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![af615dbd55cac2cacf32](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@af615dbd55cac2cacf32](https://discuss.elastic.co/u/af615dbd55cac2cacf32)
#### Post date: [October 31, 2018, 4:33am UTC](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749/1 "2018-10-31T04:33:42Z")

</div>

hello,

my Kibana worked without issues for a while but started displaying "No monitoring data found" error today, then Status turned to RED on Kibana. I executed \_cluster/health command on the servers, but all status were GREEN. I checked via \_cat API but all .monitoring\* indices are existed.

why is this happened? why kibana suddenly not able to find .monitoring\* indices? why Status'es are different btw kibana and actual servers?

Please advice.

thanks!

---

<div class="post-metadata">

### Author: ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)
#### Post date: [October 31, 2018, 5:46am UTC](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749/2 "2018-10-31T05:46:07Z")

</div>

yesterday observed this behavior, somebody help plz)

---

<div class="post-metadata">

### Author: ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)
#### Post date: [November 1, 2018, 8:56am UTC](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749/3 "2018-11-01T08:56:31Z")

</div>

@af615dbd55cac2cacf32, today i noticed that problem solved by itself when check monitoring plugin in kibana.

---

<div class="post-metadata">

### Author: ![af615dbd55cac2cacf32](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@af615dbd55cac2cacf32](https://discuss.elastic.co/u/af615dbd55cac2cacf32)
#### Post date: [November 1, 2018, 9:39am UTC](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749/4 "2018-11-01T09:39:07Z")

</div>

Hello,

Did you restarted your Elasticsearch then it was resolved?

I tracked myself with all nodes log files. It looked my warm nodes used all heap memory which i set. L related logs i found were shown as below link.

> [@'gc' log lines from Elasticseaarch](https://discuss.elastic.co/t/gc-log-lines-from-elasticseaarch/154775/2):
>
> Please don't post images of text as they are hardly readable and not searchable. Instead paste the text and format it with \</\> icon. Check the preview window. Your nodes are under memory pressure and old GC is taking a lot of time to try to free the memory.

I guess .monitoring indices were not able to be updated from warm nodes after that happened, then my kibana was ahown above error. Weird thing was kibana displayed Status:RED after that even though \_cluster/health execution result via each actual nodes were still Status:green.

I decided to restart warm nodes, then issue was gone.

Thank you for sharing update btw.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 29, 2018, 9:39am UTC](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749/5 "2018-11-29T09:39:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
