# "No monitoring data found" error on Kibana

**URL:** https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749
**Category:** Elasticsearch
**Tags:** elastic-stack-monitoring
**Created:** [October 31, 2018, 4:33am UTC](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749 "2018-10-31T04:33:42Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![af615dbd55cac2cacf32](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@af615dbd55cac2cacf32](https://discuss.elastic.co/u/af615dbd55cac2cacf32)
#### Post date: [November 1, 2018, 9:39am UTC](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749/4 "2018-11-01T09:39:07Z")

</div>

Hello,

Did you restarted your Elasticsearch then it was resolved?

I tracked myself with all nodes log files. It looked my warm nodes used all heap memory which i set. L related logs i found were shown as below link.

> [@'gc' log lines from Elasticseaarch](https://discuss.elastic.co/t/gc-log-lines-from-elasticseaarch/154775/2):
>
> Please don't post images of text as they are hardly readable and not searchable. Instead paste the text and format it with \</\> icon. Check the preview window. Your nodes are under memory pressure and old GC is taking a lot of time to try to free the memory.

I guess .monitoring indices were not able to be updated from warm nodes after that happened, then my kibana was ahown above error. Weird thing was kibana displayed Status:RED after that even though \_cluster/health execution result via each actual nodes were still Status:green.

I decided to restart warm nodes, then issue was gone.

Thank you for sharing update btw.

---

_[View the full topic](https://discuss.elastic.co/t/no-monitoring-data-found-error-on-kibana/154749)._
