# Node failed to join

**URL:** <https://discuss.elastic.co/t/node-failed-to-join/239515>\
**Category:** Elasticsearch\
**Created:** [July 1, 2020, 3:21pm UTC](https://discuss.elastic.co/t/node-failed-to-join/239515 "2020-07-01T15:21:31Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![aakashR](https://avatars.discourse-cdn.com/v4/letter/a/6a8cbe/32.png) [@aakashR](https://discuss.elastic.co/u/aakashR)\
**Post date:** [July 1, 2020, 3:21pm UTC](https://discuss.elastic.co/t/node-failed-to-join/239515/1 "2020-07-01T15:21:32Z")

</div>

Hi

I am relatively new to elasticsearch. I installed elasticsearch oss 7.7.0 a couple of days ago on two Ubuntu 18.04.3. I want to form a test cluster with 2 nodes - one master and ingest and the other only data. I configured both the nodes. Then, I restarted the service and the cluster does not seem to be forming. The cluster-name.log file indicates a bad request.

test\_odex2 is master, ingest node  
test\_odex1 is data node

```auto
[2020-07-01T15:06:26,560][INFO][o.e.c.c.JoinHelper] [test_odex1] failed to join {test_odex2}{Y1FOygToRmKfWeClxqKcjQ}{qiJUWOiKQ0mkQHy3CL1L9g}{master-ip}{master-ip:9300}{imr} with JoinRequest{sourceNode={test_odex1}{lIigyxrETCO-QX7Oyae2_A}{-gn3_rGDRySwb1Uec9LIgg}{data-node-ip}{data-node-ip:9300}{dr}, minimumTerm=5, optionalJoin=Optional[Join{term=5, lastAcceptedTerm=2, lastAcceptedVersion=15, sourceNode={test_odex1}{lIigyxrETCO-QX7Oyae2_A}{-gn3_rGDRySwb1Uec9LIgg}{data-node-ip}{data-node-ip:9300}{dr}, targetNode={test_odex2}{Y1FOygToRmKfWeClxqKcjQ}{qiJUWOiKQ0mkQHy3CL1L9g}{master-ip}{master-ip:9300}{imr}}]}
org.elasticsearch.transport.RemoteTransportException: [test_odex2][master-ip:9300][internal:cluster/coordination/join]
Caused by: java.lang.IllegalStateException: failure when sending a validation request to node
        at org.elasticsearch.cluster.coordination.Coordinator$2.onFailure(Coordinator.java:514) ~[elasticsearch-7.7.0.jar:7.7.0]
        at org.elasticsearch.action.ActionListenerResponseHandler.handleException(ActionListenerResponseHandler.java:59) ~[elasticsearch-7.7.0.jar:7.7.0]
        at org.elasticsearch.transport.TransportService$ContextRestoreResponseHandler.handleException(TransportService.java:1139) ~[elasticsearch-7.7.0.jar:7.7.0]
        at org.elasticsearch.transport.InboundHandler.lambda$handleException$2(InboundHandler.java:244) ~[elasticsearch-7.7.0.jar:7.7.0]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:633) ~[elasticsearch-7.7.0.jar:7.7.0]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130) ~[?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630) ~[?:?]
        at java.lang.Thread.run(Thread.java:832) [?:?]
Caused by: org.elasticsearch.transport.RemoteTransportException: [test_odex1][192.168.252.201:9300][internal:cluster/coordination/join/validate]
Caused by: org.elasticsearch.cluster.coordination.CoordinationStateRejectedException: join validation on cluster state with a different cluster uuid K-GeJONfS5CWk8cB7ELoog than local cluster uuid WJtDxVYoTR2795eXzLOJVg, rejecting
        at org.elasticsearch.cluster.coordination.JoinHelper.lambda$new$4(JoinHelper.java:153) ~[elasticsearch-7.7.0.jar:7.7.0]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.transport.PerformanceAnalyzerTransportRequestHandler.messageReceived(PerformanceAnalyzerTransportRequestHandler.java:43) ~[?:?]
        at org.elasticsearch.transport.RequestHandlerRegistry.processMessageReceived(RequestHandlerRegistry.java:63) ~[elasticsearch-7.7.0.jar:7.7.0]
        at org.elasticsearch.transport.InboundHandler$RequestHandler.doRun(InboundHandler.java:264) ~[elasticsearch-7.7.0.jar:7.7.0]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:692) ~[elasticsearch-7.7.0.jar:7.7.0]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) ~[elasticsearch-7.7.0.jar:7.7.0]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130) ~[?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630) ~[?:?]
        at java.lang.Thread.run(Thread.java:832) ~[?:?]

```

I'm using the default certs and keys and discover\_seed\_hosts only has the master ip for both nodes.

What is not working here?

Thanks  
Aakash

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [July 7, 2020, 5:59am UTC](https://discuss.elastic.co/t/node-failed-to-join/239515/2 "2020-07-07T05:59:26Z")

</div>

> [@aakashR](#):
>
> `Caused by: org.elasticsearch.cluster.coordination.CoordinationStateRejectedException: join validation on cluster state with a different cluster uuid K-GeJONfS5CWk8cB7ELoog than local cluster uuid WJtDxVYoTR2795eXzLOJVg, rejecting`

It looks like the node joining has been started as part of a different cluster. Try deleting the data folder and try again.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 4, 2020, 5:59am UTC](https://discuss.elastic.co/t/node-failed-to-join/239515/3 "2020-08-04T05:59:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
