# Node is not joining the cluster (ES-5.6.3)

**URL:** <https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641>\
**Category:** Elasticsearch\
**Created:** [November 14, 2017, 10:16pm UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641 "2017-11-14T22:16:53Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![dzyubanv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dzyubanv/32/24110_2.png) [@dzyubanv](https://discuss.elastic.co/u/dzyubanv)\
**Post date:** [November 14, 2017, 10:16pm UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641/1 "2017-11-14T22:16:54Z")

</div>

I"m running two nodes cluster on two separate RHEL servers. Here are the configurations.

server ip \*\*\*1  
elasticsearch.yml  
cluster. name: es1  
[node.name](http://node.name): es1-node1  
node.master: true  
node.data: true  
network.host: \*\*\*1  
transport.host: localhost  
http.port: 9200  
transport.tcp.port: 9300  
discovery.zen.ping.unicast.hosts: ["\*\*\*1:9300", "\*\*\*2:9301]  
discovery.zen.ping\_timeout: 30s

server ip \*\*\*2  
elasticsearch.yml  
cluster. name: es1  
[node.name](http://node.name): es1-node2  
node.master: false  
node.data: true  
network.host: \*\*\*2  
transport.host: localhost  
http.port: 9201  
transport.tcp.port: 9301  
discovery.zen.ping.unicast.hosts: ["\*\*\*1:9300", "\*\*\*2:9301]  
discovery.zen.ping\_timeout: 30s

The node on server \*\*\*1 has master and data roles.  
The node on server \*\*\*2 has data role.  
I started ES instances on both servers without errors in their log files.  
Also, I can successfully request indices via curl on server \*\*\*1.

Unfortunately data node on server \*\*\*2 is not joining the cluster and running check for its health with  
curl -XGET 'http://\*\*\*2:9201/\_cat/health?v' on the server \*\*\*2 console outputs the following error:  
("error":("root\_cause":[("type":"master\_not\_discovered\_exception","reason":"null"), "status":503)

I think I might be missing something in config files, may be on the transport level or something else and any advise or help to resolve the issue will be appreciated.

---

<div class="post-metadata">

**Author:** ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)\
**Post date:** [November 15, 2017, 6:48am UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641/2 "2017-11-15T06:48:21Z")

</div>

**transport.host: localhost**  
not use localhost.

---

<div class="post-metadata">

**Author:** ![dzyubanv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dzyubanv/32/24110_2.png) [@dzyubanv](https://discuss.elastic.co/u/dzyubanv)\
**Post date:** [November 15, 2017, 1:44pm UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641/3 "2017-11-15T13:44:37Z")

</div>

Should I use in transport.host the same ip values as they are in network.host ?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 15, 2017, 3:23pm UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641/4 "2017-11-15T15:23:54Z")

</div>

You should just configure `network.host`. Not other settings.

---

<div class="post-metadata">

**Author:** ![dzyubanv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dzyubanv/32/24110_2.png) [@dzyubanv](https://discuss.elastic.co/u/dzyubanv)\
**Post date:** [November 15, 2017, 4:17pm UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641/5 "2017-11-15T16:17:29Z")

</div>

I commented out the transport.host in es yml on both servers, then started es on first server but it failed to start, the entries in log file:  
[INFO][o.e.b.BootstrapChecks] [es-node1] bound or publishing to a non-loopback or non-link-local address, enforsing bootstrap checks  
[ERROR][o.e.b.Bootstrap][es-node1] node validation exception  
[3]bootstrap checks failed  
...  
...stopped  
...closed

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 15, 2017, 5:45pm UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641/6 "2017-11-15T17:45:25Z")

</div>

Please read [https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![poojagupta](https://avatars.discourse-cdn.com/v4/letter/p/5daacb/32.png) [@poojagupta](https://discuss.elastic.co/u/poojagupta)\
**Post date:** [November 16, 2017, 10:06am UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641/7 "2017-11-16T10:06:36Z")

</div>

You should do settings for network host only.  
no need to mention transport host and port parameter and also for discovery.unicast parameter mention only with Ips. Also make sure the entries for both server in its host file for better communication between servers .  
Also open port 9200 and 9300 on both servers.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 14, 2017, 10:06am UTC](https://discuss.elastic.co/t/node-is-not-joining-the-cluster-es-5-6-3/107641/8 "2017-12-14T10:06:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
