# Node stats null\_pointer\_exception error

**URL:** <https://discuss.elastic.co/t/node-stats-null-pointer-exception-error/148739>\
**Category:** Elasticsearch\
**Created:** [September 16, 2018, 9:52am UTC](https://discuss.elastic.co/t/node-stats-null-pointer-exception-error/148739 "2018-09-16T09:52:56Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![dorinand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorinand/32/70521_2.png) [@dorinand](https://discuss.elastic.co/u/dorinand)\
**Post date:** [September 16, 2018, 9:52am UTC](https://discuss.elastic.co/t/node-stats-null-pointer-exception-error/148739/1 "2018-09-16T09:52:56Z")

</div>

I am trying to gen nodes stat, because I could not see any of them in Cerebro statistics. I receive this error.

```
curl -s -X GET "localhost:9201/_cat/nodes?v" | jq .
{
  "error": {
    "root_cause": [
      {
        "type": "null_pointer_exception",
        "reason": null
      }
    ],
    "type": "null_pointer_exception",
    "reason": null
  },
  "status": 500
}

```

What could cause this problem and how to solve it? My cluster is in green state at the moment.

I am usingElasticsearch v6.2.3.

---

<div class="post-metadata">

**Author:** ![nerophon](https://avatars.discourse-cdn.com/v4/letter/n/df788c/32.png) [@nerophon](https://discuss.elastic.co/u/nerophon)\
**Post date:** [September 18, 2018, 10:48am UTC](https://discuss.elastic.co/t/node-stats-null-pointer-exception-error/148739/2 "2018-09-18T10:48:23Z")

</div>

I've seen this very recently. In that case, it was a partially-failed master, but it's possible that any partially-failed node could cause \_cat/nodes to error in this way. The failure can't be complete, otherwise the node would simply be skipped. It has to be a partial failure which leaves the node running but unable to properly return a result to the methods triggered by \_cat/nodes.  
I suggest taking a support diagnostic via [https://github.com/elastic/support-diagnostics](https://github.com/elastic/support-diagnostics) and then looking at the "nodes.json" file in the output. That's how I discovered which node was at fault.

---

<div class="post-metadata">

**Author:** ![dorinand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorinand/32/70521_2.png) [@dorinand](https://discuss.elastic.co/u/dorinand)\
**Post date:** [September 18, 2018, 11:36am UTC](https://discuss.elastic.co/t/node-stats-null-pointer-exception-error/148739/3 "2018-09-18T11:36:05Z")

</div>

@nerophon Thank you for your reply.

I find out that one of my data noda registered IO error on disk mounted in `/var/lib/elasticsearch`. After replacing the disk, everythink start working.

Thank you for advice to use support-diagnostic, I will try it.

---

<div class="post-metadata">

**Author:** ![nerophon](https://avatars.discourse-cdn.com/v4/letter/n/df788c/32.png) [@nerophon](https://discuss.elastic.co/u/nerophon)\
**Post date:** [September 18, 2018, 11:43am UTC](https://discuss.elastic.co/t/node-stats-null-pointer-exception-error/148739/4 "2018-09-18T11:43:03Z")

</div>

No problem. Of course now that you found that one node had a disk problem, you probably don't need to run a diagnostic. If that node is fixed, \_cat/nodes should work again.

---

<div class="post-metadata">

**Author:** ![dorinand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorinand/32/70521_2.png) [@dorinand](https://discuss.elastic.co/u/dorinand)\
**Post date:** [September 18, 2018, 12:44pm UTC](https://discuss.elastic.co/t/node-stats-null-pointer-exception-error/148739/5 "2018-09-18T12:44:31Z")

</div>

Yes, when I removed the disk, it starts working.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 16, 2018, 12:44pm UTC](https://discuss.elastic.co/t/node-stats-null-pointer-exception-error/148739/6 "2018-10-16T12:44:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
