# Node with zero shards fails to start with error "Node is started with node.data=false, but has shard data"

**URL:** <https://discuss.elastic.co/t/node-with-zero-shards-fails-to-start-with-error-node-is-started-with-node-data-false-but-has-shard-data/205450>\
**Category:** Elasticsearch\
**Created:** [October 28, 2019, 11:37am UTC](https://discuss.elastic.co/t/node-with-zero-shards-fails-to-start-with-error-node-is-started-with-node-data-false-but-has-shard-data/205450 "2019-10-28T11:37:08Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![tomhe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomhe/32/120065_2.png) [@tomhe](https://discuss.elastic.co/u/tomhe)\
**Post date:** [October 28, 2019, 2:07pm UTC](https://discuss.elastic.co/t/node-with-zero-shards-fails-to-start-with-error-node-is-started-with-node-data-false-but-has-shard-data/205450/3 "2019-10-28T14:07:00Z")

</div>

Ran into the same situation again on the next node that I no longer wanted to use as a data node. The node has zero shards allocated.

```
sh-4.2# bin/elasticsearch-node repurpose -v
------------------------------------------------------------------------

    WARNING: Elasticsearch MUST be stopped before running this tool.

Obtaining lock for node
Collecting shard data paths
Paths to clean up:
  /usr/share/elasticsearch/data/nodes/0/indices/myrWs3pnSmuZwTplN3XKdw/3
Indices affected:
  important_index_in_use
Found 1 shards in 1 indices to clean up
Node is being re-purposed as master and no-data. Clean-up of shard data will be performed.
Do you want to proceed?
Confirm [y/N]

```

(Index is not named "important\_index\_in\_use", but I changed it here in the post.)

This index is in use. Why am I seeing shard data here even though the node has zero allocated shards?

---

_[View the full topic](https://discuss.elastic.co/t/node-with-zero-shards-fails-to-start-with-error-node-is-started-with-node-data-false-but-has-shard-data/205450)._
