# Nodes fail to add up and create a cluster

**URL:** <https://discuss.elastic.co/t/nodes-fail-to-add-up-and-create-a-cluster/108675>\
**Category:** Elasticsearch\
**Created:** [November 22, 2017, 9:07am UTC](https://discuss.elastic.co/t/nodes-fail-to-add-up-and-create-a-cluster/108675 "2017-11-22T09:07:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Junaid03](https://avatars.discourse-cdn.com/v4/letter/j/5f8ce5/32.png) [@Junaid03](https://discuss.elastic.co/u/Junaid03)\
**Post date:** [November 22, 2017, 9:07am UTC](https://discuss.elastic.co/t/nodes-fail-to-add-up-and-create-a-cluster/108675/1 "2017-11-22T09:07:53Z")

</div>

Hi,

I setup a cluster with 3 master nodes and 5 data nodes plus a coordinating node which connects with Kibana over localhost. Now I installed xpack on every node (Including the coordinating node) and restarted the entire cluster. However I am getting the below exception:

Caused by: org.elasticsearch.transport.RemoteTransportException: [\*\*\*BD2BF\*_01][1.1_1.\*\*\*.\*\*\*:9300][internal:transport/handshake]  
Caused by: org.elasticsearch.ElasticsearchSecurityException: missing authentication token for action [internal:transport/handshake]

What is the issue here? I read about the property xpack.security.enabled: false will resolve the issue but that means turning x-pack off and is not helpful. Please suggest. DO I have to purchase a subscription?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 22, 2017, 9:10am UTC](https://discuss.elastic.co/t/nodes-fail-to-add-up-and-create-a-cluster/108675/2 "2017-11-22T09:10:37Z")

</div>

What version are you on?

> [@Junaid03](#):
>
> I setup a cluster with 2 master nodes

That's not good, see [Important Configuration Changes | Elasticsearch: The Definitive Guide [2.x] | Elastic](https://www.elastic.co/guide/en/elasticsearch/guide/2.x/important-configuration-changes.html#_minimum_master_nodes).

---

<div class="post-metadata">

**Author:** ![Junaid03](https://avatars.discourse-cdn.com/v4/letter/j/5f8ce5/32.png) [@Junaid03](https://discuss.elastic.co/u/Junaid03)\
**Post date:** [November 22, 2017, 10:13am UTC](https://discuss.elastic.co/t/nodes-fail-to-add-up-and-create-a-cluster/108675/3 "2017-11-22T10:13:16Z")

</div>

That was a mistake, I have 3 master nodes. I am on version 5.5.1

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 20, 2017, 10:13am UTC](https://discuss.elastic.co/t/nodes-fail-to-add-up-and-create-a-cluster/108675/4 "2017-12-20T10:13:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
