# NoSuchFileException: /usr/share/elasticsearch/config

**URL:** https://discuss.elastic.co/t/nosuchfileexception-usr-share-elasticsearch-config/129056
**Category:** Elasticsearch
**Created:** [April 23, 2018, 8:24am UTC](https://discuss.elastic.co/t/nosuchfileexception-usr-share-elasticsearch-config/129056 "2018-04-23T08:24:19Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![souf\_el\_badraoui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/souf_el_badraoui/32/47746_2.png) [@souf\_el\_badraoui](https://discuss.elastic.co/u/souf_el_badraoui)
#### Post date: [April 23, 2018, 8:24am UTC](https://discuss.elastic.co/t/nosuchfileexception-usr-share-elasticsearch-config/129056/1 "2018-04-23T08:24:19Z")

</div>

Hello,  
ES 5.6.5 fails starting with systemd in Red hat and show the following error

> main ERROR Could not register mbeans java.security.Acces  
> at java.security.AccessControlContext.checkPermission(AccessControlConte  
> at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
> at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrust  
> at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(D  
> at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.j  
> at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
> at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfi  
> at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfi  
> at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerCo  
> at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:  
> at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log  
> at org.apache.logging.log4j.core.config.Configurator.initialize(Configur  
> at org.apache.logging.log4j.core.config.Configurator.initialize(Configur  
> at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogge  
> at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigu  
> at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigu  
> at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:307)  
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132  
> at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:  
> at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwar  
> at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1  
> at org.elasticsearch.cli.Command.main(Command.java:90)  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)
> 
> Exception in thread "main" org.elasticsearch.bootstrap.BootstrapException: java.  
> Likely root cause: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/c  
> at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86  
> at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)  
> at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)  
> at sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttrib  
> at sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvid  
> at sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProv  
> at java.nio.file.Files.readAttributes(Files.java:1737)  
> at java.nio.file.FileTreeWalker.getAttributes(FileTreeWalker.java:225)  
> at java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:276)  
> at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:322)  
> at java.nio.file.Files.walkFileTree(Files.java:2662)  
> at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigu  
> at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigu  
> at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:307)  
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132  
> at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:  
> at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwar  
> at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1  
> at org.elasticsearch.cli.Command.main(Command.java:90)  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)  
> Refer to the log for complete error details.

i install ES using RPM and i already have path.data and path.logs set in my elasticsearch.yml file :

> path.data: /var/lib/elasticsearch  
> path.logs: /var/log/elasticsearch

So ES should start with configuration file in /etc/elasticsearch/elasticsearch.yml and should not look in /usr /share /elasticsearch

Can you help me please !

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 21, 2018, 8:38am UTC](https://discuss.elastic.co/t/nosuchfileexception-usr-share-elasticsearch-config/129056/2 "2018-05-21T08:38:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
