# Not able to bootstrap users in ECK after custom config

**URL:** <https://discuss.elastic.co/t/not-able-to-bootstrap-users-in-eck-after-custom-config/230138>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [April 28, 2020, 10:30am UTC](https://discuss.elastic.co/t/not-able-to-bootstrap-users-in-eck-after-custom-config/230138 "2020-04-28T10:30:28Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![taseer94](https://avatars.discourse-cdn.com/v4/letter/t/f9ae1b/32.png) [@taseer94](https://discuss.elastic.co/u/taseer94)\
**Post date:** [April 28, 2020, 10:30am UTC](https://discuss.elastic.co/t/not-able-to-bootstrap-users-in-eck-after-custom-config/230138/1 "2020-04-28T10:30:28Z")

</div>

Hi all, so I just got up and running with ECK in Kubernetes.

For installation, I used all-in-one-1.0.1 and elasticsearch:7.6.2. However, I am getting the following error when I try to bootstrap the passwords.

```auto
[root@quickstart-es-default-0 bin]# elasticsearch-setup-passwords auto

Failed to authenticate user 'elastic' against http://10.244.0.18:9200/_security/_authenticate?pretty
Possible causes include:
 * The password for the 'elastic' user has already been changed on this cluster
 * Your elasticsearch node is running against a different keystore
   This tool used the keystore at /usr/share/elasticsearch/config/elasticsearch.keystore

ERROR: Failed to verify bootstrap password

```

I have used the following config file.

```auto
---
apiVersion: elasticsearch.k8s.elastic.co/v1
kind: Elasticsearch
metadata:
  name: quickstart
  namespace: testing
spec:
  version: 7.6.2
  http:
    tls:
      selfSignedCertificate:
        disabled: true
  nodeSets:
  - name: default
    count: 1
    config:
      node.master: true
      node.data: true
      node.ingest: true
      node.store.allow_mmap: false

```

It only happens when I add the http: tls configuration. Any help will be appreciated !

Thanks !

---

<div class="post-metadata">

**Author:** ![sebgl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sebgl/32/48702_2.png) [@sebgl](https://discuss.elastic.co/u/sebgl)\
**Post date:** [April 28, 2020, 12:24pm UTC](https://discuss.elastic.co/t/not-able-to-bootstrap-users-in-eck-after-custom-config/230138/2 "2020-04-28T12:24:56Z")

</div>

ECK already generates the default `elastic` user password, and stores it in a Kubernetes secret. So you don't have to use the `elasticsearch-setup-passwords` tool.

See [the quickstart](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-quickstart.html#k8s_request_elasticsearch_access) for an example how to retrieve it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 26, 2020, 12:30pm UTC](https://discuss.elastic.co/t/not-able-to-bootstrap-users-in-eck-after-custom-config/230138/3 "2020-05-26T12:30:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
