# Not able to connect to elastic from kibana

**URL:** <https://discuss.elastic.co/t/not-able-to-connect-to-elastic-from-kibana/341652>\
**Category:** Kibana\
**Created:** [August 25, 2023, 7:01am UTC](https://discuss.elastic.co/t/not-able-to-connect-to-elastic-from-kibana/341652 "2023-08-25T07:01:06Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![chouben](https://avatars.discourse-cdn.com/v4/letter/c/e495f1/32.png) [@chouben](https://discuss.elastic.co/u/chouben)\
**Post date:** [August 31, 2023, 9:29am UTC](https://discuss.elastic.co/t/not-able-to-connect-to-elastic-from-kibana/341652/3 "2023-08-31T09:29:34Z")

</div>

There not much info to go on (for me). Only thing I can confirm is that Kibana is not able to reach elasticsearch.

You should add a larger excerpt from your logs + increase log level to have more detailed info.

I assume you checked these topics with similar issues?

> [@Unable to revive connection: http://localhost:9200 with Docker](https://discuss.elastic.co/t/unable-to-revive-connection-http-localhost-9200-with-docker/260726/5):
>
> The error you're receiving is because Kibana cannot establish connection to Elasticsearch. Possible root cause is that something is wrong in Kibana configuration or that the Elasticsearch cluster didn't start properly. Could you check the health of ES cluster? curl -X GET "localhost:9200/\_cluster/health?pretty"

> [@Unable to revive connection: http://localhost:9200](https://discuss.elastic.co/t/unable-to-revive-connection-http-localhost-9200/208435/10):
>
> Hello @flash1293, This issue is resolved on my master node. I am not able to start kibana on my data node also. I am getting same error as i have mentioned in earlier comments. Can you help me in this? Regards, Priyanka

> [@How to resolve 'Unable to revive connection'?](https://discuss.elastic.co/t/how-to-resolve-unable-to-revive-connection/203107):
>
> I have a Elasticsearch instance in dev mode. My Elasticsearch config is following, cluster.name: "logparser" node.master: true node.data: true node.ingest: true node.ml: false path.data: /storage/elasticsearch path.logs: /var/log/elasticsearch network.host: \_local\_ xpack.security.enabled: true xpack.security.http.ssl.enabled: true xpack.security.http.ssl.keystore.path: certs/elasticsearch.p12 xpack.security.http.ssl.truststore.path: certs/elasticsearch.p12 Following is my Kibana configuration, …

---

_[View the full topic](https://discuss.elastic.co/t/not-able-to-connect-to-elastic-from-kibana/341652)._
