# Not able to start elastic Service

**URL:** <https://discuss.elastic.co/t/not-able-to-start-elastic-service/263347>\
**Category:** Elasticsearch\
**Created:** [February 5, 2021, 8:33am UTC](https://discuss.elastic.co/t/not-able-to-start-elastic-service/263347 "2021-02-05T08:33:39Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![keyofstarrysky973](https://avatars.discourse-cdn.com/v4/letter/k/e5b9ba/32.png) [@keyofstarrysky973](https://discuss.elastic.co/u/keyofstarrysky973)\
**Post date:** [February 5, 2021, 4:37pm UTC](https://discuss.elastic.co/t/not-able-to-start-elastic-service/263347/2 "2021-02-05T16:37:46Z")

</div>

Hey I found the following thread : [Unable to start elasticsearch as service - #5 by Kajol\_Nimesh](https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-service/178440/5)

It seems that you have a permission issue for the elastic directory /var/lib/elasticsearch :

> Caused by: java.io.IOException: failed to obtain lock on /var/lib/elasticsearch/nodes/0

The reported solution is to give root permission to that directory : `sudo chown -R elasticsearch:elasticsearch /var/lib/elasticsearch`

Whether or not this is best practice from a security standpoint is unkwon to me. Try this solution, and pls tell if it worked for you.

---

_[View the full topic](https://discuss.elastic.co/t/not-able-to-start-elastic-service/263347)._
