# Not able to start Elasticsearch cluster after disabling security

**URL:** https://discuss.elastic.co/t/not-able-to-start-elasticsearch-cluster-after-disabling-security/294673
**Category:** Elasticsearch
**Created:** [January 18, 2022, 9:01am UTC](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-cluster-after-disabling-security/294673 "2022-01-18T09:01:34Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![hallaoui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hallaoui/32/77342_2.png) [@hallaoui](https://discuss.elastic.co/u/hallaoui)
#### Post date: [January 18, 2022, 9:01am UTC](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-cluster-after-disabling-security/294673/1 "2022-01-18T09:01:34Z")

</div>

Hi All,

I disabled the security due to expiration of platinum subscription but when trying to start the cluster it is not starting.

Any help will be high appreciated.

Thanks

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [January 18, 2022, 1:18pm UTC](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-cluster-after-disabling-security/294673/2 "2022-01-18T13:18:18Z")

</div>

You'll need to provide more information than that.

What error do you get?  
What version of Elasticsearch are you running?  
What change did you make to disable security?

---

<div class="post-metadata">

### Author: ![hallaoui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hallaoui/32/77342_2.png) [@hallaoui](https://discuss.elastic.co/u/hallaoui)
#### Post date: [January 18, 2022, 1:45pm UTC](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-cluster-after-disabling-security/294673/3 "2022-01-18T13:45:37Z")

</div>

Thank you Tim for your replay.

The ELK version is 7.16 and to disable the security I just comment below lines in elasticsearch config file and set xpack.security.enabled: false

xpack.security.http.ssl.enabled: false  
#xpack.security.transport.ssl.enabled: true  
#xpack.security.http.ssl.key: certs/elasticsearch-01.key  
#xpack.security.http.ssl.certificate: certs/elasticsearch-01.crt  
#xpack.security.http.ssl.certificate\_authorities: certs/ca.crt  
#xpack.security.transport.ssl.key: certs/elasticsearch-01.key  
#xpack.security.transport.ssl.certificate: certs/elasticsearch-01.crt  
#xpack.security.transport.ssl.certificate\_authorities: certs/ca.crt

For your info I reverted back the changes enabling the security and managed to start 2 cluster nodes out of 3 but when I run below curl I got error.

# curl --cacert /etc/elasticsearch/certs/ca.crt -u 'elastic:XXXXXX' '[https://elasticsearch-02:9200/\_cat/nodes?v](https://elasticsearch-02:9200/_cat/nodes?v)'

{"error":{"root\_cause":[{"type":"security\_exception","reason":"current license is non-compliant for [security]","license.expired.feature":"security"}],"type":"security\_exception","reason":"current license is non-compliant for [security]","license.expired.feature":"security"},"status":403}

Thanks for your supprt.

---

<div class="post-metadata">

### Author: ![hallaoui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hallaoui/32/77342_2.png) [@hallaoui](https://discuss.elastic.co/u/hallaoui)
#### Post date: [January 18, 2022, 2:17pm UTC](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-cluster-after-disabling-security/294673/4 "2022-01-18T14:17:13Z")

</div>

I can see below logs when trying to start the 3rd node.

```auto
[2022-01-18T17:13:21,095][TRACE][o.e.d.PeerFinder] [elasticsearch-03] startProbe(10.73.65.78:9300) not probing local node
[2022-01-18T17:13:21,095][TRACE][o.e.d.PeerFinder] [elasticsearch-03] address [10.73.65.77:9300], node [null], requesting [false] attempting connection
[2022-01-18T17:13:21,096][TRACE][o.e.d.PeerFinder] [elasticsearch-03] address [10.73.65.76:9300], node [null], requesting [false] attempting connection
[2022-01-18T17:13:21,096][TRACE][o.e.d.HandshakingTransportAddressConnector] [elasticsearch-03] [connectToRemoteMasterNode[10.73.65.77:9300]] opening probe connection
[2022-01-18T17:13:21,096][DEBUG][o.e.d.SeedHostsResolver] [elasticsearch-03] resolveConfiguredHosts: lifecycle is STOPPED, not proceeding
[2022-01-18T17:13:21,097][TRACE][o.e.d.HandshakingTransportAddressConnector] [elasticsearch-03] [connectToRemoteMasterNode[10.73.65.76:9300]] opening probe connection
[2022-01-18T17:13:21,092][ERROR][i.n.u.c.D.rejectedExecution] [elasticsearch-03] Failed to submit a listener notification task. Event loop shut down?
java.util.concurrent.RejectedExecutionException: event executor terminated
        at io.netty.util.concurrent.SingleThreadEventExecutor.reject(SingleThreadEventExecutor.java:923) ~[netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.SingleThreadEventExecutor.offerTask(SingleThreadEventExecutor.java:350) ~[netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.SingleThreadEventExecutor.addTask(SingleThreadEventExecutor.java:343) ~[netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.SingleThreadEventExecutor.execute(SingleThreadEventExecutor.java:825) ~[netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.SingleThreadEventExecutor.execute(SingleThreadEventExecutor.java:815) ~[netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.DefaultPromise.safeExecute(DefaultPromise.java:842) [netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.DefaultPromise.notifyListeners(DefaultPromise.java:499) [netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.DefaultPromise.setValue0(DefaultPromise.java:616) [netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.DefaultPromise.setFailure0(DefaultPromise.java:609) [netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.util.concurrent.DefaultPromise.setFailure(DefaultPromise.java:109) [netty-common-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.channel.DefaultChannelPromise.setFailure(DefaultChannelPromise.java:89) [netty-transport-4.1.66.Final.jar:4.1.66.Final]
        at io.netty.channel.AbstractChannelHandlerContext.safeExecute(AbstractChannelHandlerContext.java:998) [netty-transport-4.1.66.Final.jar:4.1.66.Final]

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 15, 2022, 2:17pm UTC](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-cluster-after-disabling-security/294673/5 "2022-02-15T14:17:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
