# Not able to start elasticsearch post customization to modify default paths

**URL:** <https://discuss.elastic.co/t/not-able-to-start-elasticsearch-post-customization-to-modify-default-paths/379560>\
**Category:** Elastic Search\
**Created:** [June 27, 2025, 8:58am UTC](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-post-customization-to-modify-default-paths/379560 "2025-06-27T08:58:00Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)\
**Post date:** [June 30, 2025, 10:48am UTC](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-post-customization-to-modify-default-paths/379560/6 "2025-06-30T10:48:10Z")

</div>

Hello @venkat_tammi

As per the error message shared , could be issue with jvm.options files. you should share the elasticsearch.yml , jvm.options file so that anyone will be able to guide you further.

```auto
Jun 30 09:54:07 ip-.eu-central-1.compute.internal systemd-entrypoint[2727]: error:
Jun 30 09:54:07 ip-.eu-central-1.compute.internal systemd-entrypoint[2727]: Invalid -Xlog option '-Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/vfdest.log:utctime,level,pid,tags:filecount=32,filesize=64m', see error log for details.
Jun 30 09:54:07 ip-.eu-central-1.compute.internal systemd-entrypoint[2727]: **Error: Could not create the Java Virtual Machine.**
Jun 30 09:54:07 ip-.eu-central-1.compute.internal systemd-entrypoint[2727]: Error: A fatal exception has occurred. Program will exit.

```

> [@Error while installing offline Elasticsearch 7.12](https://discuss.elastic.co/t/error-while-installing-offline-elasticsearch-7-12/276659/3):
>
> this is defiantly java setting problem. check this setting in jvm.options JVM temporary directory -Djava.io.tmpdir=${ES\_TMPDIR} you also need to enable this as you are using java16 14-:-XX:+UseG1GC 14-:-XX:G1ReservePercent=25 14-:-XX:InitiatingHeapOccupancyPercent=30 it clearly says it can't create jva virtual machine. may be try full path for logs/gc.log

Thanks!!

---

_[View the full topic](https://discuss.elastic.co/t/not-able-to-start-elasticsearch-post-customization-to-modify-default-paths/379560)._
