# Not starting Elasticsearch for some reason I can't undestand

**URL:** <https://discuss.elastic.co/t/not-starting-elasticsearch-for-some-reason-i-cant-undestand/177092>\
**Category:** Elasticsearch\
**Created:** [April 16, 2019, 12:58pm UTC](https://discuss.elastic.co/t/not-starting-elasticsearch-for-some-reason-i-cant-undestand/177092 "2019-04-16T12:58:01Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![HikariNTB](https://avatars.discourse-cdn.com/v4/letter/h/bb73d2/32.png) [@HikariNTB](https://discuss.elastic.co/u/HikariNTB)\
**Post date:** [April 16, 2019, 12:58pm UTC](https://discuss.elastic.co/t/not-starting-elasticsearch-for-some-reason-i-cant-undestand/177092/1 "2019-04-16T12:58:01Z")

</div>

Hi,

I'm new with this software and I had installed 6.5.0 version months ago, but, when I tried to update I had problems, so I reset the CentOS 7 machine and try it again with this 7.0.0 version. I could make everything work except for Logstash and elasticsearch for some reasons I don't understand. I search for a solution on the internet but can't find a solution for this so, I finally came here for you.

Here you have what the machine say about this.....

> systemctl status elasticsearch logstash:

```
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since mar 2019-04-16 13:39:55 CEST; 56min ago
     Docs: http://www.elastic.co
  Process: 18614 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=78)
 Main PID: 18614 (code=exited, status=78)

abr 16 13:39:30 srvelesticsearch.Hikari.local systemd[1]: Started Elasticsearch.
abr 16 13:39:30 srvelesticsearch.Hikari.local elasticsearch[18614]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed ...e release.
abr 16 13:39:55 srvelesticsearch.Hikari.local systemd[1]: elasticsearch.service: main process exited, code=exited, status=78/n/a
abr 16 13:39:55 srvelesticsearch.Hikari.local systemd[1]: Unit elasticsearch.service entered failed state.
abr 16 13:39:55 srvelesticsearch.Hikari.local systemd[1]: elasticsearch.service failed.

● logstash.service - logstash
   Loaded: loaded (/etc/systemd/system/logstash.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since mar 2019-04-16 13:39:32 CEST; 57min ago
  Process: 18737 ExecStart=/usr/share/logstash/bin/logstash --path.settings /etc/logstash (code=exited, status=1/FAILURE)
 Main PID: 18737 (code=exited, status=1/FAILURE)

abr 16 13:39:31 srvelesticsearch.Hikari.local systemd[1]: logstash.service: main process exited, code=exited, status=1/FAILURE
abr 16 13:39:31 srvelesticsearch.Hikari.local systemd[1]: Unit logstash.service entered failed state.
abr 16 13:39:31 srvelesticsearch.Hikari.local systemd[1]: logstash.service failed.
abr 16 13:39:32 srvelesticsearch.Hikari.local systemd[1]: logstash.service holdoff time over, scheduling restart.
abr 16 13:39:32 srvelesticsearch.Hikari.local systemd[1]: Stopped logstash.
abr 16 13:39:32 srvelesticsearch.Hikari.local systemd[1]: start request repeated too quickly for logstash.service
abr 16 13:39:32 srvelesticsearch.Hikari.local systemd[1]: Failed to start logstash.
abr 16 13:39:32 srvelesticsearch.Hikari.local systemd[1]: Unit logstash.service entered failed state.
abr 16 13:39:32 srvelesticsearch.Hikari.local systemd[1]: logstash.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

```

> view /var/log/elasticsearch/elasticsearch.log

```
[2019-04-16T13:39:54,965][INFO][o.e.n.Node] [srvelesticsearch.Hikari.local] initialized
[2019-04-16T13:39:54,966][INFO][o.e.n.Node] [srvelesticsearch.Hikari.local] starting ...

[2019-04-16T13:39:55,297][INFO][o.e.t.TransportService] [srvelesticsearch.Hikari.local] publish_address {10.254.214.145:9300}, bound_addresses {10.254.214.145:9300}
[2019-04-16T13:39:55,312][INFO][o.e.b.BootstrapChecks] [srvelesticsearch.Hikari.local] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2019-04-16T13:39:55,315][ERROR][o.e.b.Bootstrap] [srvelesticsearch.Hikari.local] node validation exception
[1] bootstrap checks failed
[1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
[2019-04-16T13:39:55,394][INFO][o.e.n.Node] [srvelesticsearch.Hikari.local] stopping ...
[2019-04-16T13:39:55,512][INFO][o.e.n.Node] [srvelesticsearch.Hikari.local] stopped
[2019-04-16T13:39:55,513][INFO][o.e.n.Node] [srvelesticsearch.Hikari.local] closing ...
[2019-04-16T13:39:55,616][INFO][o.e.n.Node] [srvelesticsearch.Hikari.local] closed

```

And I think that's all, I know it can be very newbie question or whatever, but I really don't understand this issue, I have even tried to update java, but nothing seems to be solved....

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [April 16, 2019, 1:24pm UTC](https://discuss.elastic.co/t/not-starting-elasticsearch-for-some-reason-i-cant-undestand/177092/2 "2019-04-16T13:24:47Z")

</div>

You are binding to `10.254.214.145` which is not localhost, so you are in production mode:

> [@HikariNTB](#):
>
> ```plaintext
> bound or publishing to a non-loopback address, enforcing bootstrap checks
> 
> ```

However, your node configuration is not suitable for production use:

> [@HikariNTB](#):
>
> ```plaintext
> the default discovery settings are unsuitable for production use;
> at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
> 
> ```

If this is a production deployment, you should set one of these settings. If this is a test deployment only then you can either bind to localhost or else use [single-node discovery](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html#single-node-discovery) to avoid the bootstrap checks.

---

<div class="post-metadata">

**Author:** ![HikariNTB](https://avatars.discourse-cdn.com/v4/letter/h/bb73d2/32.png) [@HikariNTB](https://discuss.elastic.co/u/HikariNTB)\
**Post date:** [April 17, 2019, 8:09am UTC](https://discuss.elastic.co/t/not-starting-elasticsearch-for-some-reason-i-cant-undestand/177092/3 "2019-04-17T08:09:00Z")

</div>

Okay, thank you so much! I'll search about production mode and this, I had no idea this exists...

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [April 17, 2019, 8:59am UTC](https://discuss.elastic.co/t/not-starting-elasticsearch-for-some-reason-i-cant-undestand/177092/4 "2019-04-17T08:59:11Z")

</div>

Here's the blog post about the introduction of bootstrap checks, explaining the rationale:

> **[Bootstrap checks: Annoying you now instead of devastating you later!](https://www.elastic.co/blog/bootstrap_checks_annoying_instead_of_devastating)**
>
> Elasticsearch 5.x has ten new

The [page I linked above](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html#bootstrap-checks) also has some more details.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 15, 2019, 8:59am UTC](https://discuss.elastic.co/t/not-starting-elasticsearch-for-some-reason-i-cant-undestand/177092/5 "2019-05-15T08:59:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
