# observing error in elasticsearch logs as :   ClusterBlockException: index \[.ds-.logs-deprecation.elasticsearch-default-2022.10.27-000023\] blocked by: \[TOO\_MANY\_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block\];

**URL:** <https://discuss.elastic.co/t/observing-error-in-elasticsearch-logs-as-clusterblockexception-index-ds-logs-deprecation-elasticsearch-default-2022-10-27-000023-blocked-by-too-many-requests-12-disk-usage-exceeded-flood-stage-watermark-index-has-read-only-allow-delete-block/338688>\
**Category:** Elastic Search\
**Tags:** elastic-site-search\
**Created:** [July 18, 2023, 2:05pm UTC](https://discuss.elastic.co/t/observing-error-in-elasticsearch-logs-as-clusterblockexception-index-ds-logs-deprecation-elasticsearch-default-2022-10-27-000023-blocked-by-too-many-requests-12-disk-usage-exceeded-flood-stage-watermark-index-has-read-only-allow-delete-block/338688 "2023-07-18T14:05:47Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![2328943\_dc](https://avatars.discourse-cdn.com/v4/letter/2/a9adbd/32.png) [@2328943\_dc](https://discuss.elastic.co/u/2328943_dc)\
**Post date:** [July 18, 2023, 2:05pm UTC](https://discuss.elastic.co/t/observing-error-in-elasticsearch-logs-as-clusterblockexception-index-ds-logs-deprecation-elasticsearch-default-2022-10-27-000023-blocked-by-too-many-requests-12-disk-usage-exceeded-flood-stage-watermark-index-has-read-only-allow-delete-block/338688/1 "2023-07-18T14:05:47Z")

</div>

observing error in elasticsearch logs as : ClusterBlockException: index [.ds-.logs-deprecation.elasticsearch-default-2022.10.27-000023] blocked by: [TOO\_MANY\_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block];

---

<div class="post-metadata">

**Author:** ![nfeekery](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nfeekery/32/117349_2.png) [@nfeekery](https://discuss.elastic.co/u/nfeekery)\
**Post date:** [July 19, 2023, 8:14am UTC](https://discuss.elastic.co/t/observing-error-in-elasticsearch-logs-as-clusterblockexception-index-ds-logs-deprecation-elasticsearch-default-2022-10-27-000023-blocked-by-too-many-requests-12-disk-usage-exceeded-flood-stage-watermark-index-has-read-only-allow-delete-block/338688/2 "2023-07-19T08:14:44Z")

</div>

Hi Vandana, this is likely being caused by Elasticsearch thinking that the disk is running low on space. Elasticsearch enters read-only mode when it perceives low disk space, triggered by the default flood stage watermark set at 95%. This means even with many gigabytes of free space on large disks, the system can still activate the read-only mode. For instance, a 1TB drive requires at least 50GB of free space to avoid read-only mode activation.

I'm not sure what version of the stack you're running, but [here are the latest docs on disk allocation management](https://www.elastic.co/guide/en/elasticsearch/reference/8.8/modules-cluster.html#disk-based-shard-allocation) that may be helpful for you.

The solution to this problem may be to free up disk space until more than 5% is available, or to change the flood stage watermark settings (details are in the docs link above).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 16, 2023, 8:15am UTC](https://discuss.elastic.co/t/observing-error-in-elasticsearch-logs-as-clusterblockexception-index-ds-logs-deprecation-elasticsearch-default-2022-10-27-000023-blocked-by-too-many-requests-12-disk-usage-exceeded-flood-stage-watermark-index-has-read-only-allow-delete-block/338688/3 "2023-08-16T08:15:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
