# Offline install of logstash-output-influxdb fails

**URL:** <https://discuss.elastic.co/t/offline-install-of-logstash-output-influxdb-fails/129457>\
**Category:** Logstash\
**Created:** [April 25, 2018, 10:38am UTC](https://discuss.elastic.co/t/offline-install-of-logstash-output-influxdb-fails/129457 "2018-04-25T10:38:13Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![kjetilhp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kjetilhp/32/30464_2.png) [@kjetilhp](https://discuss.elastic.co/u/kjetilhp)\
**Post date:** [April 25, 2018, 10:38am UTC](https://discuss.elastic.co/t/offline-install-of-logstash-output-influxdb-fails/129457/1 "2018-04-25T10:38:13Z")

</div>

Hi, trying to install the influxdb plugin offline after doing the prepare offline pack on a online machine, but it still tries to go online when installing (trying to verify..) I've created an issue on the plugin itself but not sure if this is an plugin error or logstash error.  
(logstash v 6.2.3)

sudo /usr/share/logstash/bin/logstash-plugin install influx-plugin.zip --no-verify --local  
Validating influx-plugin.zip  
Unable to download data from [https://rubygems.org](https://rubygems.org) - SocketError: Failed to open TCP connection to [rubygems.org:443](http://rubygems.org:443) (initialize: name or service not known) ([https://rubygems.org/latest\_specs.4.8.gz](https://rubygems.org/latest_specs.4.8.gz))  
ERROR: Installation aborted, verification failed for influx-plugin.zip

(I guess the flags have no effect on this logstash version but tried with and without.. no luck)

---

<div class="post-metadata">

**Author:** ![NerdSec](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nerdsec/32/22056_2.png) [@NerdSec](https://discuss.elastic.co/u/NerdSec)\
**Post date:** [April 25, 2018, 10:49am UTC](https://discuss.elastic.co/t/offline-install-of-logstash-output-influxdb-fails/129457/2 "2018-04-25T10:49:32Z")

</div>

> [@kjetilhp](#):
>
> logstash-plugin install influx-plugin.zip

I think you missed specifying the `file://` extension before the zip file. Should be as follows:

```
bin/logstash-plugin install file:///path/to/plugin.zip

```

---

<div class="post-metadata">

**Author:** ![kjetilhp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kjetilhp/32/30464_2.png) [@kjetilhp](https://discuss.elastic.co/u/kjetilhp)\
**Post date:** [April 25, 2018, 10:53am UTC](https://discuss.elastic.co/t/offline-install-of-logstash-output-influxdb-fails/129457/3 "2018-04-25T10:53:06Z")

</div>

> [@NerdSec](#):
>
> file://

oh.. embarrassed.. that worked 😂

---

<div class="post-metadata">

**Author:** ![NerdSec](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nerdsec/32/22056_2.png) [@NerdSec](https://discuss.elastic.co/u/NerdSec)\
**Post date:** [April 25, 2018, 10:57am UTC](https://discuss.elastic.co/t/offline-install-of-logstash-output-influxdb-fails/129457/4 "2018-04-25T10:57:47Z")

</div>

Happens with us all 😃

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 23, 2018, 11:02am UTC](https://discuss.elastic.co/t/offline-install-of-logstash-output-influxdb-fails/129457/5 "2018-05-23T11:02:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
