# Offline plugin installation?

**URL:** <https://discuss.elastic.co/t/offline-plugin-installation/29062>\
**Category:** Logstash\
**Created:** [September 10, 2015, 7:29pm UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062 "2015-09-10T19:29:55Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![CraigFoote](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/craigfoote/32/4571_2.png) [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Post date:** [September 10, 2015, 7:29pm UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062/1 "2015-09-10T19:29:55Z")

</div>

I have transferred the http\_poller.gem file to my non-internet-connected intranet machine but when I run plugin install /pathToPlugin it times out trying to connect to the rubygems site. I saw some mention of --local flag but it comes back as an unrecognized option. I am running Logstash-1.5.3. Any help greatly appreciated.

Craig

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 11, 2015, 6:59am UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062/2 "2015-09-11T06:59:00Z")

</div>

That should definitely work, are you providing the full path?

---

<div class="post-metadata">

**Author:** ![stevedearl](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@stevedearl](https://discuss.elastic.co/u/stevedearl)\
**Post date:** [September 11, 2015, 9:18am UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062/3 "2015-09-11T09:18:16Z")

</div>

Hi Craig,

We're behind a firewall and I've been having the same problem when trying to do a local install of the Logstash-input-Lumberjack GEMS file into Logstash1.5.4.

See [https://github.com/logstash-plugins/logstash-input-lumberjack/issues/46#issuecomment-138895158](https://github.com/logstash-plugins/logstash-input-lumberjack/issues/46#issuecomment-138895158) for history of the issue.

I haven't found a workaround for this yet so would be interested if anyone here has any suggestions.

Cheers,  
Steve

---

<div class="post-metadata">

**Author:** ![CraigFoote](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/craigfoote/32/4571_2.png) [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Post date:** [September 14, 2015, 3:08pm UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062/4 "2015-09-14T15:08:43Z")

</div>

The command I'm issuing is /opt/logstash/bin/plugin install --no-verify /tmp/logstash-input-http\_poller-1.1.2.gem. The response I'm getting is ERROR: Installation Aborted, message: Could not fetch specs from https//rubygems.org. I tried with the --local flag as well but it came back ERROR: Unrecognized option '--local'.

---

<div class="post-metadata">

**Author:** ![CraigFoote](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/craigfoote/32/4571_2.png) [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Post date:** [September 14, 2015, 4:15pm UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062/5 "2015-09-14T16:15:20Z")

</div>

Ok this is interesting. Thinking the sequence of arguments might matter I ran `/opt/logstash/bin/plugin install /tmp/logstash-input-http_poller-1.1.2.gem --local` (with the --local at the end) and now I'm getting `ERROR: Mixed source of plugins, you can't mix local .gem and remote gems`.

Does anyone have an example of using --local to install local gems offline?

---

<div class="post-metadata">

**Author:** ![CraigFoote](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/craigfoote/32/4571_2.png) [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Post date:** [September 14, 2015, 6:49pm UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062/6 "2015-09-14T18:49:45Z")

</div>

So now my installation is broken ☹  
Running anything including `/opt/logstash/bin/logstash --version` returns:  
`Bundler::VersionConflict: Bundler could not find compatible versions for gem logstash-mixin-http_client ... Could not find gem logstash-mixin-http_client (>=1.0.1) java, which is required by gem logstash-input-heep_poller(=1.1.2) java, in any of the sources. Start at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bunndler/resolved.rb:203 ...`

That was logstash-1.5.3. I'm going to remove it and install 1.5.4 to see if the same thing happens.  
Still waiting on someone to point to instructions of how to install a gem file offline...I can't believe I'm the first!

Craig

---

<div class="post-metadata">

**Author:** ![Ankush\_Shankar](https://avatars.discourse-cdn.com/v4/letter/a/bbce88/32.png) [@Ankush\_Shankar](https://discuss.elastic.co/u/Ankush_Shankar)\
**Post date:** [January 5, 2016, 6:12am UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062/7 "2016-01-05T06:12:33Z")

</div>

Hi Craig

Did you have any luck with 1.5.4?  
I am having the same problem. The plugin wants to connect to [rubygems.org](http://rubygems.org) even when I give it the path to my gem.

```
Error Bundler::HTTPError, retrying 1/10
Could not fetch specs from https://rubygems.org/
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:16am UTC](https://discuss.elastic.co/t/offline-plugin-installation/29062/8 "2017-07-06T05:16:52Z")

</div>


