# Only some users can login to kibana without Connection Failure

**URL:** <https://discuss.elastic.co/t/only-some-users-can-login-to-kibana-without-connection-failure/76691>\
**Category:** Kibana\
**Created:** [February 27, 2017, 8:56pm UTC](https://discuss.elastic.co/t/only-some-users-can-login-to-kibana-without-connection-failure/76691 "2017-02-27T20:56:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![teej](https://avatars.discourse-cdn.com/v4/letter/t/b5a626/32.png) [@teej](https://discuss.elastic.co/u/teej)\
**Post date:** [February 27, 2017, 8:56pm UTC](https://discuss.elastic.co/t/only-some-users-can-login-to-kibana-without-connection-failure/76691/1 "2017-02-27T20:56:54Z")

</div>

We are using kibana 3 and have found that when one user logs in, he has no problem but when another one logs in they get the following:

* * *

Connection Failed  
Possibility #1: Your elasticsearch server is down or unreachable  
This can be caused by a network outage, or a failure of the Elasticsearch process. If you have recently run a query that required a terms facet to be executed it is possible the process has run out of memory and stopped. Be sure to check your Elasticsearch logs for any sign of memory pressure.  
Possibility #2: You are running Elasticsearch 1.4 or higher  
Elasticsearch 1.4 ships with a security setting that prevents Kibana from connecting. You will need to set the following in your elasticsearch.yml:

```
http.cors.enabled: true
http.cors.allow-origin to the correct protocol, hostname, and port (if not 80) that your access Kibana from. Note that if you are running Kibana in a sub-url, you should exclude the sub-url path and only include the protocol, hostname and port. For example, http://mycompany.com:8080, not http://mycompany.com:8080/kibana.

```

Click back, or the home button, when you have resolved the connection issue

* * *

The configs are as suggested. The accounts that successfully login, do so consistently and those that get the error message, do so consistently. So it appears to be USER specific.

Has anyone experienced something similar? Thank you.

---

<div class="post-metadata">

**Author:** ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)\
**Post date:** [February 27, 2017, 10:04pm UTC](https://discuss.elastic.co/t/only-some-users-can-login-to-kibana-without-connection-failure/76691/2 "2017-02-27T22:04:43Z")

</div>

Kibana 3 has reached its EOL (you can view the support and timelines here [https://www.elastic.co/support/eol](https://www.elastic.co/support/eol)), I would suggest upgrading if possible.

---

<div class="post-metadata">

**Author:** ![teej](https://avatars.discourse-cdn.com/v4/letter/t/b5a626/32.png) [@teej](https://discuss.elastic.co/u/teej)\
**Post date:** [March 2, 2017, 1:35pm UTC](https://discuss.elastic.co/t/only-some-users-can-login-to-kibana-without-connection-failure/76691/3 "2017-03-02T13:35:52Z")

</div>

Thanks and that would be the obvious direction but thats not an option at the moment.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 30, 2017, 1:36pm UTC](https://discuss.elastic.co/t/only-some-users-can-login-to-kibana-without-connection-failure/76691/4 "2017-03-30T13:36:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
