# Open Files Limit

**URL:** <https://discuss.elastic.co/t/open-files-limit/54961>\
**Category:** Logstash\
**Created:** [July 7, 2016, 3:44pm UTC](https://discuss.elastic.co/t/open-files-limit/54961 "2016-07-07T15:44:21Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![jezeling](https://avatars.discourse-cdn.com/v4/letter/j/edb3f5/32.png) [@jezeling](https://discuss.elastic.co/u/jezeling)\
**Post date:** [July 7, 2016, 3:44pm UTC](https://discuss.elastic.co/t/open-files-limit/54961/1 "2016-07-07T15:44:21Z")

</div>

Hi,

Apologies if this is in the wrong group but I have started to receive an open file error on my logstash nodes that push the data into my two node elastic cluster: -

Reached open files limit: 4095, set by the 'max\_open\_files' option or default, files yet to open: 28217

I've simplified my indexes down, I did have date specific ones, to make sure I don't have too many open files per node but still the error persists. From all the settings I've checked I can't find any mention of 4095, all I see is 65535.

Is anyone able to offer any insight as to if they have seen similar issues? I have followed various posts about open file limits but still coming up with the error.

Cheers

Jez

---

<div class="post-metadata">

**Author:** ![jezeling](https://avatars.discourse-cdn.com/v4/letter/j/edb3f5/32.png) [@jezeling](https://discuss.elastic.co/u/jezeling)\
**Post date:** [July 7, 2016, 4:19pm UTC](https://discuss.elastic.co/t/open-files-limit/54961/2 "2016-07-07T16:19:25Z")

</div>

Ok so I fixed this, turns out it was being caused by a file path monitor on LogStash for CDR and CMR files from the Cisco Call Manager....lots and lots of files not cleaned up.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:49am UTC](https://discuss.elastic.co/t/open-files-limit/54961/3 "2017-07-06T04:49:04Z")

</div>


