# Opening terminal for operator fails on OpenShift

**URL:** <https://discuss.elastic.co/t/opening-terminal-for-operator-fails-on-openshift/243691>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [August 4, 2020, 10:53am UTC](https://discuss.elastic.co/t/opening-terminal-for-operator-fails-on-openshift/243691 "2020-08-04T10:53:49Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![misz](https://avatars.discourse-cdn.com/v4/letter/m/dfb087/32.png) [@misz](https://discuss.elastic.co/u/misz)\
**Post date:** [August 4, 2020, 10:53am UTC](https://discuss.elastic.co/t/opening-terminal-for-operator-fails-on-openshift/243691/1 "2020-08-04T10:53:49Z")

</div>

Hi,  
I have successfully deployed the ECK 1.2.0 Operator and Elasticsearch on my OpenShift cluster 3.11. However, I cannot open a terminal for the Operator pod. It fails with:

```auto
rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:235: starting container process caused "exec: \"/bin/sh\": stat /bin/sh: no such file or directory"

```

Can you help me out with this?

Regards  
Michael

---

<div class="post-metadata">

**Author:** ![pebrc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pebrc/32/101790_2.png) [@pebrc](https://discuss.elastic.co/u/pebrc)\
**Post date:** [August 4, 2020, 11:34am UTC](https://discuss.elastic.co/t/opening-terminal-for-operator-fails-on-openshift/243691/2 "2020-08-04T11:34:08Z")

</div>

We are using a [distroless base image](https://github.com/GoogleContainerTools/distroless) for the operator. It does not have a shell to exec into so this behaviour is expected.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 8:08am UTC](https://discuss.elastic.co/t/opening-terminal-for-operator-fails-on-openshift/243691/3 "2022-11-04T08:08:47Z")

</div>


