# OpenJDK 64-Bit Server VM warning ElasticSearch FAILED TO START

**URL:** <https://discuss.elastic.co/t/openjdk-64-bit-server-vm-warning-elasticsearch-failed-to-start/158638>\
**Category:** Elasticsearch\
**Created:** [November 28, 2018, 6:55pm UTC](https://discuss.elastic.co/t/openjdk-64-bit-server-vm-warning-elasticsearch-failed-to-start/158638 "2018-11-28T18:55:48Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Richard\_Phillips\_Roy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/richard_phillips_roy/32/46989_2.png) [@Richard\_Phillips\_Roy](https://discuss.elastic.co/u/Richard_Phillips_Roy)\
**Post date:** [November 28, 2018, 6:55pm UTC](https://discuss.elastic.co/t/openjdk-64-bit-server-vm-warning-elasticsearch-failed-to-start/158638/1 "2018-11-28T18:55:48Z")

</div>

I'm a newbie , i'm running DEBAIN on virtual box , and i'm getting this error please help.

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Thu 2018-11-29 00:09:49 IST; 11s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 10967 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p {PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs={LOG\_DIR} -Edefault.path.data={DATA\_DIR} -Edefault.path.conf={CONF\_DIR} (code=  
Process: 10964 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 10967 (code=exited, status=1/FAILURE)

Nov 29 00:09:48 roy systemd[1]: Starting Elasticsearch...  
Nov 29 00:09:48 roy systemd[1]: Started Elasticsearch.  
Nov 29 00:09:49 roy elasticsearch[10967]: OpenJDK 64-Bit Server VM warning: INFO: os::commit\_memory(0x000000008a660000, 1973026816, 0) failed; error='Cannot allocate memory' (errno=12)  
Nov 29 00:09:49 roy systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE  
Nov 29 00:09:49 roy systemd[1]: elasticsearch.service: Unit entered failed state.  
Nov 29 00:09:49 roy systemd[1]: elasticsearch.service: Failed with result 'exit-code'.  
~

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 28, 2018, 8:58pm UTC](https://discuss.elastic.co/t/openjdk-64-bit-server-vm-warning-elasticsearch-failed-to-start/158638/2 "2018-11-28T20:58:33Z")

</div>

Is there anything in your Elasticsearch logs?  
Usually that's in `/var/log/elasticsearch/`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 26, 2018, 8:58pm UTC](https://discuss.elastic.co/t/openjdk-64-bit-server-vm-warning-elasticsearch-failed-to-start/158638/3 "2018-12-26T20:58:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
