# OpenSSL::SSL::SSLError: Received fatal alert: handshake\_failure

**URL:** <https://discuss.elastic.co/t/openssl-ssl-sslerror-received-fatal-alert-handshake-failure/56831>\
**Category:** Logstash\
**Created:** [July 31, 2016, 3:36pm UTC](https://discuss.elastic.co/t/openssl-ssl-sslerror-received-fatal-alert-handshake-failure/56831 "2016-07-31T15:36:59Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![HUANG](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@HUANG](https://discuss.elastic.co/u/HUANG)\
**Post date:** [July 31, 2016, 3:36pm UTC](https://discuss.elastic.co/t/openssl-ssl-sslerror-received-fatal-alert-handshake-failure/56831/1 "2016-07-31T15:36:59Z")

</div>

I used Logstash to send alert email when application exception via smtp with ssl.But Logstash reported ':exception=\>#\<OpenSSL::SSL::SSLError: Received fatal alert: handshake\_failure' When deliver mail.What Happened? At first it works well.  
The version of logstash: 2.3.4；  
OS Version:CentOS 7.  
Here is Log:  
{:timestamp=\>"2016-07-31T23:13:06.864000+0800",  
:message=\>"Something happen while delivering an email",  
:exception=\>#\<OpenSSL::SSL::SSLError: Received fatal alert: handshake\_failure\>,  
:level=\>:error}  
Plugin:Logstash-output-email

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 2, 2016, 10:12am UTC](https://discuss.elastic.co/t/openssl-ssl-sslerror-received-fatal-alert-handshake-failure/56831/2 "2016-08-02T10:12:21Z")

</div>

Providing your config would be useful.

---

<div class="post-metadata">

**Author:** ![HUANG](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@HUANG](https://discuss.elastic.co/u/HUANG)\
**Post date:** [August 2, 2016, 10:26am UTC](https://discuss.elastic.co/t/openssl-ssl-sslerror-received-fatal-alert-handshake-failure/56831/3 "2016-08-02T10:26:43Z")

</div>

Thanks, Mark.  
We have solved this problem.  
The email provider stopped our email function. log-stash can't communicate to email server via ssl protocol.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:45am UTC](https://discuss.elastic.co/t/openssl-ssl-sslerror-received-fatal-alert-handshake-failure/56831/4 "2017-07-06T04:45:24Z")

</div>


