# org.elasticsearch.ElasticsearchIllegalArgumentException: No version type match \[34\]

**URL:** <https://discuss.elastic.co/t/org-elasticsearch-elasticsearchillegalargumentexception-no-version-type-match-34/17732>\
**Category:** Elasticsearch\
**Created:** [May 26, 2014, 6:51pm UTC](https://discuss.elastic.co/t/org-elasticsearch-elasticsearchillegalargumentexception-no-version-type-match-34/17732 "2014-05-26T18:51:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jorn\_Eilander](https://avatars.discourse-cdn.com/v4/letter/j/b5a626/32.png) [@Jorn\_Eilander](https://discuss.elastic.co/u/Jorn_Eilander)\
**Post date:** [May 26, 2014, 6:51pm UTC](https://discuss.elastic.co/t/org-elasticsearch-elasticsearchillegalargumentexception-no-version-type-match-34/17732/1 "2014-05-26T18:51:47Z")

</div>

Hey guys,

I had to delete a few indices on my Logstash/ElasticSearch one node  
'cluster' since I ran out of diskspace.

After that the current index refused to come online with the following  
messages (see below). Google isn't much help with the 'No version type  
match' so I was wondering if you guys have any ideas:

[2014-05-26 20:21:08,987][INFO][node] [Vicky the  
Viking] started  
[2014-05-26 20:21:20,313][WARN][indices.cluster] [Vicky the  
Viking] [logstash-2014.05.26][0] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
[logstash-2014.05.26][0] failed to recover shard  
at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:242)  
at  
org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:197)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.ElasticsearchIllegalArgumentException: No  
version type match [34]  
at  
org.elasticsearch.index.VersionType.fromValue(VersionType.java:227)  
at  
org.elasticsearch.index.translog.Translog$Create.readFrom(Translog.java:363)  
at  
org.elasticsearch.index.translog.TranslogStreams.readTranslogOperation(TranslogStreams.java:52)  
at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:219)  
... 4 more  
[2014-05-26 20:21:20,343][WARN][cluster.action.shard] [Vicky the  
Viking] [logstash-2014.05.26][0] sending failed shard for  
[logstash-2014.05.26][0], node[3YVw0sg5TWOw1DCU3QkzCw], [P],  
s[INITIALIZING], indexUUID [wSalAu\_5QgeQ1KWXZxVQ6w], reason [Failed to  
start shard, message  
[IndexShardGatewayRecoveryException[[logstash-2014.05.26][0] failed to  
recover shard]; nested: ElasticsearchIllegalArgumentException[No version  
type match [34]]; ]]  
[2014-05-26 20:21:20,362][WARN][cluster.action.shard] [Vicky the  
Viking] [logstash-2014.05.26][0] received shard failed for  
[logstash-2014.05.26][0], node[3YVw0sg5TWOw1DCU3QkzCw], [P],  
s[INITIALIZING], indexUUID [wSalAu\_5QgeQ1KWXZxVQ6w], reason [Failed to  
start shard, message  
[IndexShardGatewayRecoveryException[[logstash-2014.05.26][0] failed to  
recover shard]; nested: ElasticsearchIllegalArgumentException[No version  
type match [34]]; ]]

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/8ced06f2-67b7-44ef-a206-e8597191687b%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/8ced06f2-67b7-44ef-a206-e8597191687b%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:26am UTC](https://discuss.elastic.co/t/org-elasticsearch-elasticsearchillegalargumentexception-no-version-type-match-34/17732/2 "2017-07-06T01:26:50Z")

</div>


