# Org.elasticsearch.transport.ConnectTransportException

**URL:** <https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751>\
**Category:** Elasticsearch\
**Created:** [May 17, 2012, 7:41pm UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751 "2012-05-17T19:41:57Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mohit\_Anchlia](https://avatars.discourse-cdn.com/v4/letter/m/848f3c/32.png) [@Mohit\_Anchlia](https://discuss.elastic.co/u/Mohit_Anchlia)\
**Post date:** [May 17, 2012, 7:41pm UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751/1 "2012-05-17T19:41:57Z")

</div>

In the hadoop job I used embedded client. For some reason the job failed.  
But even though job failed and the "embedded client" died, log is still  
spooling this message. I think it's trying to reconnect to the client. So  
my question is, this the right thing for a cluster to do? How do others  
deal with this situation and what should I do?

[2012-05-17 12:39:09,901][WARN][cluster.service] [Eros] failed  
to reconnect to node  
[Infamnia][YMmBmOEFTkKbTWKSwICnbA][inet[/140.18.62.199:9300]]{client=true,  
data=false}  
org.elasticsearch.transport.ConnectTransportException: [Infamnia][inet[/  
140.18.62.199:9300]] connect\_timeout[30s]  
at  
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:560)  
at  
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:503)  
at  
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:482)  
at  
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:128)  
at  
org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:377)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:662)  
Caused by: java.net.ConnectException: Connection refused  
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
at  
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)  
at  
org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.connect(NioClientSocketPipelineSink.java:399)  
at  
org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.processSelectedKeys(NioClientSocketPipelineSink.java:361)  
at  
org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.run(NioClientSocketPipelineSink.java:277)  
at  
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

---

<div class="post-metadata">

**Author:** ![Mohit\_Anchlia](https://avatars.discourse-cdn.com/v4/letter/m/848f3c/32.png) [@Mohit\_Anchlia](https://discuss.elastic.co/u/Mohit_Anchlia)\
**Post date:** [May 18, 2012, 5:10pm UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751/2 "2012-05-18T17:10:28Z")

</div>

Any help would be appreciated. This behaviour makes cluster unusable.

On Thu, May 17, 2012 at 12:41 PM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:

> In the hadoop job I used embedded client. For some reason the job failed.  
> But even though job failed and the "embedded client" died, log is still  
> spooling this message. I think it's trying to reconnect to the client. So  
> my question is, this the right thing for a cluster to do? How do others  
> deal with this situation and what should I do?
> 
> [2012-05-17 12:39:09,901][WARN][cluster.service] [Eros] failed  
> to reconnect to node  
> [Infamnia][YMmBmOEFTkKbTWKSwICnbA][inet[/140.18.62.199:9300]]{client=true,  
> data=false}  
> org.elasticsearch.transport.ConnectTransportException: [Infamnia][inet[/  
> 140.18.62.199:9300]] connect\_timeout[30s]  
> at  
> org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:560)  
> at  
> org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:503)  
> at  
> org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:482)  
> at  
> org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:128)  
> at  
> org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:377)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
> at java.lang.Thread.run(Thread.java:662)  
> Caused by: java.net.ConnectException: Connection refused  
> at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
> at  
> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.connect(NioClientSocketPipelineSink.java:399)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.processSelectedKeys(NioClientSocketPipelineSink.java:361)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.run(NioClientSocketPipelineSink.java:277)  
> at  
> org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 20, 2012, 8:28pm UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751/3 "2012-05-20T20:28:12Z")

</div>

Are you closing the Client when you are done. And if you started a Node  
client, are you closing the node as well?

On Thu, May 17, 2012 at 9:41 PM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:

> In the hadoop job I used embedded client. For some reason the job failed.  
> But even though job failed and the "embedded client" died, log is still  
> spooling this message. I think it's trying to reconnect to the client. So  
> my question is, this the right thing for a cluster to do? How do others  
> deal with this situation and what should I do?
> 
> [2012-05-17 12:39:09,901][WARN][cluster.service] [Eros] failed  
> to reconnect to node  
> [Infamnia][YMmBmOEFTkKbTWKSwICnbA][inet[/140.18.62.199:9300]]{client=true,  
> data=false}  
> org.elasticsearch.transport.ConnectTransportException: [Infamnia][inet[/  
> 140.18.62.199:9300]] connect\_timeout[30s]  
> at  
> org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:560)  
> at  
> org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:503)  
> at  
> org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:482)  
> at  
> org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:128)  
> at  
> org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:377)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
> at java.lang.Thread.run(Thread.java:662)  
> Caused by: java.net.ConnectException: Connection refused  
> at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
> at  
> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.connect(NioClientSocketPipelineSink.java:399)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.processSelectedKeys(NioClientSocketPipelineSink.java:361)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.run(NioClientSocketPipelineSink.java:277)  
> at  
> org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

---

<div class="post-metadata">

**Author:** ![Mohit\_Anchlia](https://avatars.discourse-cdn.com/v4/letter/m/848f3c/32.png) [@Mohit\_Anchlia](https://discuss.elastic.co/u/Mohit_Anchlia)\
**Post date:** [May 20, 2012, 11:18pm UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751/4 "2012-05-20T23:18:36Z")

</div>

On Sun, May 20, 2012 at 1:28 PM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:

> Are you closing the Client when you are done. And if you started a Node  
> client, are you closing the node as well?
> 
> I'll look inside "wonderdog" code. But my question was why should this  
> impact other nodes? Failures could occur anytime and this shouldn't impact  
> the clusters.

> On Thu, May 17, 2012 at 9:41 PM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:
> 
> > In the hadoop job I used embedded client. For some reason the job failed.  
> > But even though job failed and the "embedded client" died, log is still  
> > spooling this message. I think it's trying to reconnect to the client. So  
> > my question is, this the right thing for a cluster to do? How do others  
> > deal with this situation and what should I do?
> > 
> > [2012-05-17 12:39:09,901][WARN][cluster.service] [Eros] failed  
> > to reconnect to node  
> > [Infamnia][YMmBmOEFTkKbTWKSwICnbA][inet[/140.18.62.199:9300]]{client=true,  
> > data=false}  
> > org.elasticsearch.transport.ConnectTransportException: [Infamnia][inet[/  
> > 140.18.62.199:9300]] connect\_timeout[30s]  
> > at  
> > org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:560)  
> > at  
> > org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:503)  
> > at  
> > org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:482)  
> > at  
> > org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:128)  
> > at  
> > org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:377)  
> > at  
> > java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
> > at  
> > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
> > at java.lang.Thread.run(Thread.java:662)  
> > Caused by: java.net.ConnectException: Connection refused  
> > at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
> > at  
> > sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)  
> > at  
> > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.connect(NioClientSocketPipelineSink.java:399)  
> > at  
> > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.processSelectedKeys(NioClientSocketPipelineSink.java:361)  
> > at  
> > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.run(NioClientSocketPipelineSink.java:277)  
> > at  
> > org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 23, 2012, 9:05pm UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751/5 "2012-05-23T21:05:03Z")

</div>

You did not mention in the mail that it affects other nodes, can you  
elaborate on it?

On Mon, May 21, 2012 at 1:18 AM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:

> On Sun, May 20, 2012 at 1:28 PM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:
> 
> > Are you closing the Client when you are done. And if you started a Node  
> > client, are you closing the node as well?
> > 
> > I'll look inside "wonderdog" code. But my question was why should this  
> > impact other nodes? Failures could occur anytime and this shouldn't impact  
> > the clusters.
> 
> > On Thu, May 17, 2012 at 9:41 PM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:
> > 
> > > In the hadoop job I used embedded client. For some reason the job  
> > > failed. But even though job failed and the "embedded client" died, log is  
> > > still spooling this message. I think it's trying to reconnect to the  
> > > client. So my question is, this the right thing for a cluster to do? How do  
> > > others deal with this situation and what should I do?
> > > 
> > > [2012-05-17 12:39:09,901][WARN][cluster.service] [Eros]  
> > > failed to reconnect to node  
> > > [Infamnia][YMmBmOEFTkKbTWKSwICnbA][inet[/140.18.62.199:9300]]{client=true,  
> > > data=false}  
> > > org.elasticsearch.transport.ConnectTransportException: [Infamnia][inet[/  
> > > 140.18.62.199:9300]] connect\_timeout[30s]  
> > > at  
> > > org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:560)  
> > > at  
> > > org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:503)  
> > > at  
> > > org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:482)  
> > > at  
> > > org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:128)  
> > > at  
> > > org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:377)  
> > > at  
> > > java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
> > > at  
> > > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
> > > at java.lang.Thread.run(Thread.java:662)  
> > > Caused by: java.net.ConnectException: Connection refused  
> > > at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
> > > at  
> > > sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)  
> > > at  
> > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.connect(NioClientSocketPipelineSink.java:399)  
> > > at  
> > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.processSelectedKeys(NioClientSocketPipelineSink.java:361)  
> > > at  
> > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.run(NioClientSocketPipelineSink.java:277)  
> > > at  
> > > org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

---

<div class="post-metadata">

**Author:** ![Mohit\_Anchlia](https://avatars.discourse-cdn.com/v4/letter/m/848f3c/32.png) [@Mohit\_Anchlia](https://discuss.elastic.co/u/Mohit_Anchlia)\
**Post date:** [May 23, 2012, 11:13pm UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751/6 "2012-05-23T23:13:20Z")

</div>

On Wed, May 23, 2012 at 2:05 PM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:

> You did not mention in the mail that it affects other nodes, can you  
> elaborate on it?
> 
> What I see is that the nodes that are up keeps throwing tons of error  
> messages. They never take that embeded client node out of cluster. When I  
> tried to send more requests to the already active node it just hangs.

> On Mon, May 21, 2012 at 1:18 AM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:
> 
> > On Sun, May 20, 2012 at 1:28 PM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:
> > 
> > > Are you closing the Client when you are done. And if you started a Node  
> > > client, are you closing the node as well?
> > > 
> > > I'll look inside "wonderdog" code. But my question was why should this  
> > > impact other nodes? Failures could occur anytime and this shouldn't impact  
> > > the clusters.
> > 
> > > On Thu, May 17, 2012 at 9:41 PM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:
> > > 
> > > > In the hadoop job I used embedded client. For some reason the job  
> > > > failed. But even though job failed and the "embedded client" died, log is  
> > > > still spooling this message. I think it's trying to reconnect to the  
> > > > client. So my question is, this the right thing for a cluster to do? How do  
> > > > others deal with this situation and what should I do?
> > > > 
> > > > [2012-05-17 12:39:09,901][WARN][cluster.service] [Eros]  
> > > > failed to reconnect to node  
> > > > [Infamnia][YMmBmOEFTkKbTWKSwICnbA][inet[/140.18.62.199:9300]]{client=true,  
> > > > data=false}  
> > > > org.elasticsearch.transport.ConnectTransportException: [Infamnia][inet[/  
> > > > 140.18.62.199:9300]] connect\_timeout[30s]  
> > > > at  
> > > > org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:560)  
> > > > at  
> > > > org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:503)  
> > > > at  
> > > > org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:482)  
> > > > at  
> > > > org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:128)  
> > > > at  
> > > > org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:377)  
> > > > at  
> > > > java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
> > > > at  
> > > > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
> > > > at java.lang.Thread.run(Thread.java:662)  
> > > > Caused by: java.net.ConnectException: Connection refused  
> > > > at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
> > > > at  
> > > > sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)  
> > > > at  
> > > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.connect(NioClientSocketPipelineSink.java:399)  
> > > > at  
> > > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.processSelectedKeys(NioClientSocketPipelineSink.java:361)  
> > > > at  
> > > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.run(NioClientSocketPipelineSink.java:277)  
> > > > at  
> > > > org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 25, 2012, 10:36pm UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751/7 "2012-05-25T22:36:37Z")

</div>

If you don't close the client (or kill -9 the process for example), then  
that node will be removed eventually, depending on the fault detection  
process and ping intervals. Do you still see those message constantly, or  
do they go away. Usually, btw, the socket ends up being closed / broken, so  
the detection of failure is much faster. Not sure what happens in Hadoop in  
case of a job failure.

On Thu, May 24, 2012 at 1:13 AM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:

> On Wed, May 23, 2012 at 2:05 PM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:
> 
> > You did not mention in the mail that it affects other nodes, can you  
> > elaborate on it?
> > 
> > What I see is that the nodes that are up keeps throwing tons of error  
> > messages. They never take that embeded client node out of cluster. When I  
> > tried to send more requests to the already active node it just hangs.
> 
> > On Mon, May 21, 2012 at 1:18 AM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:
> > 
> > > On Sun, May 20, 2012 at 1:28 PM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:
> > > 
> > > > Are you closing the Client when you are done. And if you started a Node  
> > > > client, are you closing the node as well?
> > > > 
> > > > I'll look inside "wonderdog" code. But my question was why should this  
> > > > impact other nodes? Failures could occur anytime and this shouldn't impact  
> > > > the clusters.
> > > 
> > > > On Thu, May 17, 2012 at 9:41 PM, Mohit Anchlia [mohitanchlia@gmail.com](mailto:mohitanchlia@gmail.com)wrote:
> > > > 
> > > > > In the hadoop job I used embedded client. For some reason the job  
> > > > > failed. But even though job failed and the "embedded client" died, log is  
> > > > > still spooling this message. I think it's trying to reconnect to the  
> > > > > client. So my question is, this the right thing for a cluster to do? How do  
> > > > > others deal with this situation and what should I do?
> > > > > 
> > > > > [2012-05-17 12:39:09,901][WARN][cluster.service] [Eros]  
> > > > > failed to reconnect to node  
> > > > > [Infamnia][YMmBmOEFTkKbTWKSwICnbA][inet[/140.18.62.199:9300]]{client=true,  
> > > > > data=false}  
> > > > > org.elasticsearch.transport.ConnectTransportException:  
> > > > > [Infamnia][inet[/140.18.62.199:9300]] connect\_timeout[30s]  
> > > > > at  
> > > > > org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:560)  
> > > > > at  
> > > > > org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:503)  
> > > > > at  
> > > > > org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:482)  
> > > > > at  
> > > > > org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:128)  
> > > > > at  
> > > > > org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:377)  
> > > > > at  
> > > > > java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
> > > > > at  
> > > > > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
> > > > > at java.lang.Thread.run(Thread.java:662)  
> > > > > Caused by: java.net.ConnectException: Connection refused  
> > > > > at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
> > > > > at  
> > > > > sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)  
> > > > > at  
> > > > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.connect(NioClientSocketPipelineSink.java:399)  
> > > > > at  
> > > > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.processSelectedKeys(NioClientSocketPipelineSink.java:361)  
> > > > > at  
> > > > > org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink$Boss.run(NioClientSocketPipelineSink.java:277)  
> > > > > at  
> > > > > org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:26am UTC](https://discuss.elastic.co/t/org-elasticsearch-transport-connecttransportexception/7751/8 "2017-07-06T03:26:57Z")

</div>


