# OS X + Beats 5.0.0-alpha5でBeatsダッシュボードが作れない

**URL:** <https://discuss.elastic.co/t/os-x-beats-5-0-0-alpha5-beats/60493>\
**Category:** 日本語による質問・議論はこちら\
**Created:** [September 14, 2016, 11:30am UTC](https://discuss.elastic.co/t/os-x-beats-5-0-0-alpha5-beats/60493 "2016-09-14T11:30:28Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cero-t](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cero-t/32/28149_2.png) [@cero-t](https://discuss.elastic.co/u/cero-t)\
**Post date:** [September 14, 2016, 11:30am UTC](https://discuss.elastic.co/t/os-x-beats-5-0-0-alpha5-beats/60493/1 "2016-09-14T11:30:28Z")

</div>

OS X環境でBeatsのダッシュボード作成（import\_dashboards.sh）を行うと、途中でエラーになります。  
alpha4までは作成できていました。

**・環境**  
OS X El Capitan 10.11.6  
Elasticsearch, Kibana, Metericbeat, Packatbeat 5.0.0-alpha5

**・手順**

1. Elasticsearch 5.0.0-alpha5 / Kibana 5.0.0-alpha5 のインストール（zip / tar.gzの解凍）

2. Elasticsearch / Kibanaを起動（bin/elasticsearch / bin/kibana の実行）

3. Metricbeat / Packetbeatのインストール（tar.gzの解凍）

4. Metricbeat / Packetbeatのダッシュボードのローディング

ここで、ダッシュボード作成途中に止まる。

  
\*\*・エラーメッセージ\*\*

Metricbeat側

```
Import dashboards,visualizations, searches and index pattern from . to http://localhost:9200 in .kibana
Import search Apache-HTTPD:
{"_index":".kibana","_type":"search","_id":"Apache-HTTPD","_version":1,"result":"created","_shards":{"total":2,"successful":1,"failed":0},"created":true}
Import search Cpu-Load-stats:
{"_index":".kibana","_type":"search","_id":"Cpu-Load-stats","_version":1,"result":"created","_shards":{"total":2,"successful":1,"failed":0},"created":true}
(中略)
Import search System-stats:
{"_index":".kibana","_type":"search","_id":"System-stats","_version":1,"result":"created","_shards":{"total":2,"successful":1,"failed":0},"created":true}
Import visualization Apache-HTTPD-CPU:
curl: (52) Empty reply from server

```

Packetbeat側

```
Import dashboards,visualizations, searches and index pattern from . to http://localhost:9200 in .kibana
Import search Cache-transactions:
{"_index":".kibana","_type":"search","_id":"Cache-transactions","_version":1,"result":"created","_shards":{"total":2,"successful":1,"failed":0},"created":true}
Import search DB-transactions:
{"_index":".kibana","_type":"search","_id":"DB-transactions","_version":1,"result":"created","_shards":{"total":2,"successful":1,"failed":0},"created":true}
Import search HTTP-errors:
（中略）
{"_index":".kibana","_type":"visualization","_id":"Evolution-of-the-CPU-times-per-process","_version":1,"result":"created","_shards":{"total":2,"successful":1,"failed":0},"created":true}
Import visualization HTTP-codes-for-the-top-queries:
{"_index":".kibana","_type":"visualization","_id":"HTTP-codes-for-the-top-queries","_version":1,"result":"created","_shards":{"total":2,"successful":1,"failed":0},"created":true}
Import visualization HTTP-error-codes-evolution:
curl: (52) Empty reply from server

```

Elasticsearch側

```
[2016-09-14 20:26:07,185][WARN][http.netty4] [KXOvHPh] caught exception while handling client http traffic, closing connection [id: 0xc1bd7db1, L:/0:0:0:0:0:0:0:1:9200 - R:/0:0:0:0:0:0:0:1:53468]
java.lang.UnsupportedOperationException: unsupported message type: DefaultFullHttpResponse (expected: ByteBuf, FileRegion)
	at io.netty.channel.nio.AbstractNioByteChannel.filterOutboundMessage(AbstractNioByteChannel.java:260)
	at io.netty.channel.AbstractChannel$AbstractUnsafe.write(AbstractChannel.java:799)
	at io.netty.channel.DefaultChannelPipeline$HeadContext.write(DefaultChannelPipeline.java:1291)
	at io.netty.channel.AbstractChannelHandlerContext.invokeWrite0(AbstractChannelHandlerContext.java:748)
	at io.netty.channel.AbstractChannelHandlerContext.invokeWriteAndFlush(AbstractChannelHandlerContext.java:811)
	at io.netty.channel.AbstractChannelHandlerContext.write(AbstractChannelHandlerContext.java:824)
	at io.netty.channel.AbstractChannelHandlerContext.writeAndFlush(AbstractChannelHandlerContext.java:804)
	at io.netty.channel.AbstractChannelHandlerContext.writeAndFlush(AbstractChannelHandlerContext.java:841)
	at io.netty.handler.codec.MessageAggregator.decode(MessageAggregator.java:222)
（略）

```

よろしくお願いします！

---

<div class="post-metadata">

**Author:** ![cero-t](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cero-t/32/28149_2.png) [@cero-t](https://discuss.elastic.co/u/cero-t)\
**Post date:** [September 14, 2016, 11:59am UTC](https://discuss.elastic.co/t/os-x-beats-5-0-0-alpha5-beats/60493/2 "2016-09-14T11:59:27Z")

</div>

すみません、取り下げます。  
とっくに検知済みでした。Amazon Linuxでも問題が起きますね。

> <https://github.com/elastic/elasticsearch/issues/19893>

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:45pm UTC](https://discuss.elastic.co/t/os-x-beats-5-0-0-alpha5-beats/60493/3 "2017-07-06T13:45:29Z")

</div>


