# OutOfMemoryError ELK 5.0.2

**URL:** <https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645>\
**Category:** Elasticsearch\
**Created:** [December 21, 2016, 8:33am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645 "2016-12-21T08:33:30Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 8:33am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/1 "2016-12-21T08:33:30Z")

</div>

Hello guys, today i had problem with ELK.  
Next error i had in my log:  
2016-12-21T14:21:54,206][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] fatal error in thread [elasticsearch[node-1][generic][T#8]], exiting  
java.lang.OutOfMemoryError: unable to create new native thread  
at java.lang.Thread.start0(Native Method) ~[?:1.8.0\_101]  
at java.lang.Thread.start(Thread.java:714) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.addWorker(ThreadPoolExecutor.java:950) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.processWorkerExit(ThreadPoolExecutor.java:1018) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1160) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) ~[?:1.8.0\_101]  
at java.lang.Thread.run(Thread.java:745) [?:1.8.0\_101]

my server have 32 Gb ram,  
and i run there 2 node of ELK  
node1 - node.master , Xms1g, Xmx1g  
node2 - node.data, Xms15g, Xmx15g.

what kind of recommendation you can give me?  
Is it neccesary to low Xms, Xmx for node.data to 13g?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 21, 2016, 8:37am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/2 "2016-12-21T08:37:07Z")

</div>

Which node had the error?

---

<div class="post-metadata">

**Author:** ![omkarp](https://avatars.discourse-cdn.com/v4/letter/o/22d042/32.png) [@omkarp](https://discuss.elastic.co/u/omkarp)\
**Post date:** [December 21, 2016, 8:37am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/3 "2016-12-21T08:37:49Z")

</div>

> [@nugusbayevkk](#):
>
> Xms, Xmx

Why do you less to node1 ? can you even distrubute around 8GB for each node?

refer this link [Heap: Sizing and Swapping | Elasticsearch: The Definitive Guide [2.x] | Elastic](https://www.elastic.co/guide/en/elasticsearch/guide/current/heap-sizing.html#_give_less_than_half_your_memory_to_lucene)

---

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 8:38am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/4 "2016-12-21T08:38:36Z")

</div>

Data.node:  
[2016-12-21T14:11:12,434][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-2] fatal error in thread [elasticsearch[node-2][flush][T#4]], exiting  
java.lang.OutOfMemoryError: unable to create new native thread  
at java.lang.Thread.start0(Native Method) ~[?:1.8.0\_101]  
at java.lang.Thread.start(Thread.java:714) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.addWorker(ThreadPoolExecutor.java:950) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.processWorkerExit(ThreadPoolExecutor.java:1018) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1160) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) ~[?:1.8.0\_101]  
Master.node:  
[2016-12-21T14:21:54,206][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] fatal error in thread [elasticsearch[node-1][generic][T#8]], exiting  
java.lang.OutOfMemoryError: unable to create new native thread  
at java.lang.Thread.start0(Native Method) ~[?:1.8.0\_101]  
at java.lang.Thread.start(Thread.java:714) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.addWorker(ThreadPoolExecutor.java:950) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.processWorkerExit(ThreadPoolExecutor.java:1018) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1160) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) ~[?:1.8.0\_101]  
at java.lang.Thread.run(Thread.java:745) [?:1.8.0\_101]

---

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 8:39am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/5 "2016-12-21T08:39:06Z")

</div>

Both node had the error

---

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 8:43am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/6 "2016-12-21T08:43:16Z")

</div>

my configuration of jvm data.node:  
-Xms13g (before the error there is was 15g)  
-Xmx13g (before the error there is was 15g)

## GC configuration

-XX:+UseConcMarkSweepGC  
-XX:CMSInitiatingOccupancyFraction=75  
-XX:+UseCMSInitiatingOccupancyOnly  
-XX:+UseCompressedOops //this i added earlier

and master node:  
-Xms1g  
-Xmx1g

## GC configuration

-XX:+UseConcMarkSweepGC  
-XX:CMSInitiatingOccupancyFraction=75  
-XX:+UseCMSInitiatingOccupancyOnly  
-XX:+UseCompressedOops //this i added earlier

Error occur after my migration from elk 2.34 to 5.0.2.  
2 hour earlier i migrate.  
at 12:15.

---

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 8:44am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/7 "2016-12-21T08:44:47Z")

</div>

now i have follow state of nodes :  
[event\_manager@event-handler-prod1 elasticsearch-5.0.2-node2]$ curl localhost:9212/\_cat/nodes?v  
ip heap.percent ram.percent cpu load\_1m load\_5m load\_15m node.role master name  
server2 3 61 1 0.00 0.03 0.12 di - node-4  
server1 23 61 1 0.09 0.15 0.20 mi - node-1  
server1 2 61 1 0.09 0.15 0.20 di - node-2  
server2 27 61 1 0.00 0.03 0.12 mi \* node-3

---

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 8:49am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/8 "2016-12-21T08:49:08Z")

</div>

In tomcat i had the same problem.  
May be new version of ELK consume more Memory?  
21-Dec-2016 14:10:55.703 SEVERE [http-nio-8080-exec-9] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.service() for servlet [dispatcher] in context with path [/EventHandlerApp] thre  
w exception [Handler processing failed; nested exception is java.lang.OutOfMemoryError: unable to create new native thread] with root cause  
java.lang.OutOfMemoryError: unable to create new native thread  
at java.lang.Thread.start0(Native Method)  
at java.lang.Thread.start(Thread.java:714)  
at org.elasticsearch.threadpool.ThreadPool.(ThreadPool.java:217)  
at org.elasticsearch.client.transport.TransportClient.buildTemplate(TransportClient.java:120)  
at org.elasticsearch.client.transport.TransportClient.(TransportClient.java:241)  
at org.elasticsearch.transport.client.PreBuiltTransportClient.(PreBuiltTransportClient.java:92)  
at org.elasticsearch.transport.client.PreBuiltTransportClient.(PreBuiltTransportClient.java:81)  
at org.elasticsearch.transport.client.PreBuiltTransportClient.(PreBuiltTransportClient.java:71)  
at kz.ksp.dsm.spring.elasticsearch.DBConnector.getElasticSearchConn(DBConnector.java:32)

---

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 10:25am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/9 "2016-12-21T10:25:26Z")

</div>

Warkolm, can you give me some advice?

---

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 10:38am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/10 "2016-12-21T10:38:49Z")

</div>

it is my app log:  
2016-12-21 14:10:25.707 [http-nio-8080-exec-9] DEBUG org.elasticsearch.client.transport.TransportClientNodesService - node\_sampler\_interval[5s]  
2016-12-21 14:10:25.708 [http-nio-8080-exec-9] DEBUG org.elasticsearch.client.transport.TransportClientNodesService - adding address [{#transport#-1}{\_gVFiMlPSr6zz2IHygusrQ}{server1}{server1:9300}]  
2016-12-21 14:10:25.718 [http-nio-8080-exec-9] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - connected to node [{#transport#-1}{\_gVFiMlPSr6zz2IHygusrQ}{server1}{server1:9300}]  
2016-12-21 14:10:25.810 [http-nio-8080-exec-9] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - connected to node [{node-1}{oxkDAeF1S1iclLH7sI0PvA}{L4rYBM9IQVeu2hCyOHSzPg}{server1}{server1:9300}]  
2016-12-21 14:10:25.810 [http-nio-8080-exec-9] DEBUG org.elasticsearch.client.transport.TransportClientNodesService - adding address [{#transport#-2}{avYl5wWPQia1TmuRKNKLlQ}{server1}{server1:9301}]  
2016-12-21 14:10:25.852 [http-nio-8080-exec-9] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - connected to node [{#transport#-2}{avYl5wWPQia1TmuRKNKLlQ}{server1}{server1:9301}]  
2016-12-21 14:10:25.883 [http-nio-8080-exec-9] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - connected to node [{node-2}{pyM14CYLS7G1HAViPaHagw}{1XotyG7hTZqa\_gV7\_RGCzA}{server1}{server1:9301}]  
2016-12-21 14:10:25.896 [http-nio-8080-exec-9] DEBUG kz.ksp.dsm.spring.elasticsearch.ConnectionChecker - numberOfDataNodes:1  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - no modules loaded  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.index.reindex.ReindexPlugin]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.percolator.PercolatorPlugin]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.script.mustache.MustachePlugin]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.transport.Netty3Plugin]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.transport.Netty4Plugin]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [force\_merge], size [1], queue size [unbounded]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [fetch\_shard\_started], core [1], max [8], keep alive [5m]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [listener], size [2], queue size [unbounded]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [index], size [4], queue size [200]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [refresh], core [1], max [2], keep alive [5m]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [generic], core [4], max [128], keep alive [30s]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [warmer], core [1], max [2], keep alive [5m]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [search], size [7], queue size [1k]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [flush], core [1], max [2], keep alive [5m]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [fetch\_shard\_store], core [1], max [8], keep alive [5m]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [management], core [1], max [5], keep alive [5m]  
2016-12-21 14:10:55.701 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [get], size [4], queue size [1k]  
2016-12-21 14:10:55.702 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [bulk], size [4], queue size [50]  
2016-12-21 14:10:55.702 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [snapshot], core [1], max [2], keep alive [5m]  
2016-12-21 14:11:13.781 [elasticsearch[_client_][generic][T#3]] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - disconnecting from [{node-2}{pyM14CYLS7G1HAViPaHagw}{1XotyG7hTZqa\_gV7\_RG  
CzA}{server1}{server1:9301}], channel closed event

---

<div class="post-metadata">

**Author:** ![nugusbayevkk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nugusbayevkk/32/126683_2.png) [@nugusbayevkk](https://discuss.elastic.co/u/nugusbayevkk)\
**Post date:** [December 21, 2016, 11:21am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/11 "2016-12-21T11:21:46Z")

</div>

currently i had the same problem only in node2(data-node) and in tomcat:

[2016-12-21T16:45:08,965][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-2] fatal error in thread [elasticsearch[node-2][refresh][T#2]], exiting  
java.lang.OutOfMemoryError: unable to create new native thread  
at java.lang.Thread.start0(Native Method) ~[?:1.8.0\_101]  
at java.lang.Thread.start(Thread.java:714) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.addWorker(ThreadPoolExecutor.java:950) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.processWorkerExit(ThreadPoolExecutor.java:1018) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1160) ~[?:1.8.0\_101]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) ~[?:1.8.0\_101]  
at java.lang.Thread.run(Thread.java:745) [?:1.8.0\_101]

and i noticed that for every query created threadpool. I have checker that every 30 second check my server available and there execute query.

2016-12-21 16:41:41.107 [http-nio-8080-exec-5] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - connected to node [{#transport#-1}{Z95qgsoiQo6uf7Wu3xBmFA}{server1}{server1:9300}]  
2016-12-21 16:41:41.196 [http-nio-8080-exec-5] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - connected to node [{node-1}{oxkDAeF1S1iclLH7sI0PvA}{5Yu8N\_elR8uv7jmN1bejww}{server1}{1  
0.17.9.67:9300}]  
2016-12-21 16:41:41.204 [http-nio-8080-exec-5] DEBUG org.elasticsearch.client.transport.TransportClientNodesService - adding address [{#transport#-2}{hoAY9KiiSyWLw\_IE\_si\_AA}{server1}{server1:9301}]  
2016-12-21 16:41:41.205 [http-nio-8080-exec-5] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - connected to node [{#transport#-2}{hoAY9KiiSyWLw\_IE\_si\_AA}{server1}{server1:9301}]  
2016-12-21 16:41:41.246 [http-nio-8080-exec-5] DEBUG org.elasticsearch.transport.netty4.Netty4Transport - connected to node [{node-2}{pyM14CYLS7G1HAViPaHagw}{QcR0trVVTsS90uZCn0j40Q}{server1}{server1:9301}]  
2016-12-21 16:41:41.263 [http-nio-8080-exec-5] DEBUG kz.ksp.dsm.spring.elasticsearch.ConnectionChecker - numberOfDataNodes:1  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - no modules loaded  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.index.reindex.ReindexPlugin]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.percolator.PercolatorPlugin]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.script.mustache.MustachePlugin]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.transport.Netty3Plugin]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] INFO org.elasticsearch.plugins.PluginsService - loaded plugin [org.elasticsearch.transport.Netty4Plugin]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [force\_merge], size [1], queue size [unbounded]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [fetch\_shard\_started], core [1], max [8], keep alive [5m]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [listener], size [2], queue size [unbounded]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [index], size [4], queue size [200]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [refresh], core [1], max [2], keep alive [5m]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [generic], core [4], max [128], keep alive [30s]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [warmer], core [1], max [2], keep alive [5m]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [search], size [7], queue size [1k]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [flush], core [1], max [2], keep alive [5m]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [fetch\_shard\_store], core [1], max [8], keep alive [5m]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [management], core [1], max [5], keep alive [5m]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [get], size [4], queue size [1k]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [bulk], size [4], queue size [50]  
2016-12-21 16:42:11.090 [http-nio-8080-exec-9] DEBUG org.elasticsearch.threadpool.ThreadPool - created thread pool: name [snapshot], core [1], max [2], keep alive [5m]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 18, 2017, 11:21am UTC](https://discuss.elastic.co/t/outofmemoryerror-elk-5-0-2/69645/12 "2017-01-18T11:21:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
