# Output.elasticsearch.hosts doe snot exist persisten error

**URL:** https://discuss.elastic.co/t/output-elasticsearch-hosts-doe-snot-exist-persisten-error/374455
**Category:** Logstash
**Created:** [February 12, 2025, 7:57pm UTC](https://discuss.elastic.co/t/output-elasticsearch-hosts-doe-snot-exist-persisten-error/374455 "2025-02-12T19:57:00Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![latte123](https://avatars.discourse-cdn.com/v4/letter/l/a88e57/32.png) [@latte123](https://discuss.elastic.co/u/latte123)
#### Post date: [February 12, 2025, 7:57pm UTC](https://discuss.elastic.co/t/output-elasticsearch-hosts-doe-snot-exist-persisten-error/374455/1 "2025-02-12T19:57:00Z")

</div>

ES, Logstash 8.17.1. I've implemented syslog via conf file in conf.d directory of Logstash to connect to OpenShift in Sandbox/dev environment. It all worked one day. Next day logs stopped with error in /var/log/logstash/logstash-plain.log that jruby exits with Fatal error due to output.elasticsearch.hosts does not exist. Since then I've reinstalled Logstash 3 times without any result. If there is known resolution please let me know. Environment: RHEL 8.10, ELK rpm installation, YUM/RPM Logstash installations with "yum update"," logstash-plugin update". I verified that /var/log/messages generated and it has the same error.

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [February 12, 2025, 8:42pm UTC](https://discuss.elastic.co/t/output-elasticsearch-hosts-doe-snot-exist-persisten-error/374455/2 "2025-02-12T20:42:11Z")

</div>

> [@latte123](#):
>
> Next day logs stopped with error in /var/log/logstash/logstash-plain.log that jruby exits with Fatal error due to output.elasticsearch.hosts does not exist

Can you share the exact log line you are receiving? Without seeing the exact log error you are receiving is pretty hard to do any troubleshooting.

`output.elasticsarch.hosts` is not a Logstash configuration, it is a beats configuration, maybe something is mixed up in your system?

---

<div class="post-metadata">

### Author: ![latte123](https://avatars.discourse-cdn.com/v4/letter/l/a88e57/32.png) [@latte123](https://discuss.elastic.co/u/latte123)
#### Post date: [February 12, 2025, 10:19pm UTC](https://discuss.elastic.co/t/output-elasticsearch-hosts-doe-snot-exist-persisten-error/374455/3 "2025-02-12T22:19:46Z")

</div>

I am attaching 5 fiiles:

 ![anticipated_logstash-plain-log](https://us1.discourse-cdn.com/elastic/original/3X/9/a/9ac080aa2c5eb8a1ab9f26be18e7d9bd955d3b19.jpeg)  
 ![logstash-yml](https://us1.discourse-cdn.com/elastic/original/3X/d/1/d13b21aaca69a3e10527bd44c900e04298de45e2.jpeg)

 ![var-log-messages](https://us1.discourse-cdn.com/elastic/original/3X/f/c/fcd269e94df5175640e82b74f982ea3964e54eef.jpeg)

files: content of /var/log/messages, /var/log/logstash/logstash-plain.log, logstash-sample.conf, anticipated logstash-plain.log

 ![logstash-plain-log](https://us1.discourse-cdn.com/elastic/original/3X/c/b/cb3ab82c4150762d72be208e25c33e7908ab1b90.jpeg)

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [February 12, 2025, 10:37pm UTC](https://discuss.elastic.co/t/output-elasticsearch-hosts-doe-snot-exist-persisten-error/374455/4 "2025-02-12T22:37:27Z")

</div>

Please avoid sharing screenshots, they can be hard to read and it is not possible to quote them to provide feedback.

Share the configurations and logs as plain text using the Prefromatted text option, the `</>` button.

On the `logstash-yml` image, where did you get this configuration? This is wrong, there is no `output.*` in this file, this is a filebeat configuration.

Outputs in Logstash are configured in the logstash configuration file.

Remove the `output.*` configurations from `logstash.yml`, this does not exist.

---

<div class="post-metadata">

### Author: ![latte123](https://avatars.discourse-cdn.com/v4/letter/l/a88e57/32.png) [@latte123](https://discuss.elastic.co/u/latte123)
#### Post date: [February 13, 2025, 6:36am UTC](https://discuss.elastic.co/t/output-elasticsearch-hosts-doe-snot-exist-persisten-error/374455/5 "2025-02-13T06:36:45Z")

</div>

Thank you! I found more issues in config file itself as well: I was using cacert instead of ssl\_certificate\_authorities; cacert was absolete.

I did remove output from logstash.yml. Its all working now.

Irina
