# Parameter indexing\_pressure.memory.limit

**URL:** <https://discuss.elastic.co/t/parameter-indexing-pressure-memory-limit/304823>\
**Category:** Elasticsearch\
**Created:** [May 16, 2022, 1:05pm UTC](https://discuss.elastic.co/t/parameter-indexing-pressure-memory-limit/304823 "2022-05-16T13:05:45Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![masyutka](https://avatars.discourse-cdn.com/v4/letter/m/90ced4/32.png) [@masyutka](https://discuss.elastic.co/u/masyutka)\
**Post date:** [May 16, 2022, 1:05pm UTC](https://discuss.elastic.co/t/parameter-indexing-pressure-memory-limit/304823/1 "2022-05-16T13:05:45Z")

</div>

Hi !  
We are trying to understand if parameter indexing\_pressure.memory.limit can be adjusted and how. We cannot find any info on how to change it, we found only this help link [Indexing pressure | Elasticsearch Guide [8.2] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/index-modules-indexing-pressure.html)  
Thanks a lot!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 17, 2022, 1:50am UTC](https://discuss.elastic.co/t/parameter-indexing-pressure-memory-limit/304823/2 "2022-05-17T01:50:41Z")

</div>

Why do you want to adjust this?

---

<div class="post-metadata">

**Author:** ![masyutka](https://avatars.discourse-cdn.com/v4/letter/m/90ced4/32.png) [@masyutka](https://discuss.elastic.co/u/masyutka)\
**Post date:** [May 19, 2022, 12:40am UTC](https://discuss.elastic.co/t/parameter-indexing-pressure-memory-limit/304823/3 "2022-05-19T00:40:45Z")

</div>

We've had an indexing pressure situation with below rejection errors:

"Caused by: org.Elasticsearch.transport.RemoteTransportException: [elk-mon-es-eu-central-1b-data-1][192.168.19.104:9300][indices:data/write/bulk[s]]",  
"Caused by: org.Elasticsearch.common.util.concurrent.EsRejectedExecutionException: rejected execution of primary operation [coordinating\_and\_primary\_bytes=3221225182, replica\_bytes=0, all\_bytes=3221225182, primary\_operation\_bytes=2121, max\_coordinating\_and\_primary\_bytes=3221225472]",  
"at org.Elasticsearch.index.IndexingPressure.markPrimaryOperationStarted(IndexingPressure.java:105) ~[Elasticsearch-7.12.1.jar:7.12.1]",  
"at org.Elasticsearch.action.support.replication.TransportWriteAction.checkOperationLimits(TransportWriteAction.java:80) ~[Elasticsearch-7.12.1.jar:7.12.1]",  
"at org.Elasticsearch.action.support.replication.TransportWriteAction.checkOperationLimits(TransportWriteAction.java:49) ~[Elasticsearch-7.12.1.jar:7.12.1]",  
"at org.Elasticsearch.action.support.replication.TransportReplicationAction.handleOperationRequest(TransportReplicationAction.java:277) ~[Elasticsearch-7.12.1.jar:7.12.1]",  
"at org.Elasticsearch.xpack.security.transport.SecurityServerTransportInterceptor$ProfileSecuredRequestHandler$1.doRun(SecurityServerTransportInterceptor.java:261) ~[?:?]",  
"at org.Elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:26) ~[Elasticsearch-7.12.1.jar:7.12.1]",  
"at org.Elasticsearch

So we have found there is a parameter that controls limit. We just wanted to understand if this is something adjustable, or we have to stick with default (10% of heap) and better not touch it.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 19, 2022, 1:56am UTC](https://discuss.elastic.co/t/parameter-indexing-pressure-memory-limit/304823/4 "2022-05-19T01:56:14Z")

</div>

It'd be useful if you shared the full error please.

---

<div class="post-metadata">

**Author:** ![masyutka](https://avatars.discourse-cdn.com/v4/letter/m/90ced4/32.png) [@masyutka](https://discuss.elastic.co/u/masyutka)\
**Post date:** [May 23, 2022, 12:48pm UTC](https://discuss.elastic.co/t/parameter-indexing-pressure-memory-limit/304823/5 "2022-05-23T12:48:51Z")

</div>

We don't have full callstack unfortunately.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 20, 2022, 12:49pm UTC](https://discuss.elastic.co/t/parameter-indexing-pressure-memory-limit/304823/6 "2022-06-20T12:49:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
