# Path.repo cannot be supported in es 2.1.0?

**URL:** <https://discuss.elastic.co/t/path-repo-cannot-be-supported-in-es-2-1-0/37534>\
**Category:** Elasticsearch\
**Created:** [December 18, 2015, 4:34am UTC](https://discuss.elastic.co/t/path-repo-cannot-be-supported-in-es-2-1-0/37534 "2015-12-18T04:34:05Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Benny](https://avatars.discourse-cdn.com/v4/letter/b/49beb7/32.png) [@Benny](https://discuss.elastic.co/u/Benny)\
**Post date:** [December 18, 2015, 4:34am UTC](https://discuss.elastic.co/t/path-repo-cannot-be-supported-in-es-2-1-0/37534/1 "2015-12-18T04:34:05Z")

</div>

Hi. I want to use snapshot in es 2.1.0.  
But after I wrote the below setting in elasticsearch.yml as the way of es 1.7.2, es cannot be started.  
Is the setting wrong? Coule anyone tell me how to config? Thanks a lot.

in elasticsearch.yml:  
path.repo: ["/tmp/backups"]

the error:  
[hadoop@Hadoop elasticsearch-2.1.0]$ bin/elasticsearch  
Exception in thread "main" SettingsException[Failed to load settings from [elasticsearch.yml]]; nested: ElasticsearchParseException[malformed, expected end of settings but encountered additional content starting at line number: [39], column number: [1]]; nested: ParserException[expected '', but found BlockMappingStart  
in 'reader', line 39, column 1:  
path.repo: ["/tmp/backups"]  
^  
];  
Likely root cause: expected '', but found BlockMappingStart  
in 'reader', line 39, column 1:  
path.repo: ["/tmp/backups"]  
^

```
    at com.fasterxml.jackson.dataformat.yaml.snakeyaml.parser.ParserImpl$ParseDocumentStart.produce(ParserImpl.java:225)
    at com.fasterxml.jackson.dataformat.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158)
    at com.fasterxml.jackson.dataformat.yaml.snakeyaml.parser.ParserImpl.getEvent(ParserImpl.java:168)
    at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:342)
    at org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:53)
    at org.elasticsearch.common.settings.loader.XContentSettingsLoader.load(XContentSettingsLoader.java:72)
    at org.elasticsearch.common.settings.loader.XContentSettingsLoader.load(XContentSettingsLoader.java:45)
    at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:46)
    at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1074)
    at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1061)
    at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:88)
    at org.elasticsearch.common.cli.CliTool.<init>(CliTool.java:107)
    at org.elasticsearch.common.cli.CliTool.<init>(CliTool.java:100)
    at org.elasticsearch.bootstrap.BootstrapCLIParser.<init>(BootstrapCLIParser.java:48)
    at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:241)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)

```

Refer to the log for complete error details.

---

<div class="post-metadata">

**Author:** ![jakommo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jakommo/32/6716_2.png) [@jakommo](https://discuss.elastic.co/u/jakommo)\
**Post date:** [December 18, 2015, 8:58am UTC](https://discuss.elastic.co/t/path-repo-cannot-be-supported-in-es-2-1-0/37534/2 "2015-12-18T08:58:57Z")

</div>

Hi Benny,

this looks like a yaml error, sometimes this is caused by an earlier setting starting with a space or something.  
Can you please attach the whole `elasticsearch.yml` file?  
I tried `path.repo: ["/tmp/backups"]` and do not get this error, it just works.

Just a note about using `/tmp`, many distros mount it in your RAM using `tmpfs`, so space is limited and ephemeral.

Cheers,  
Jakob

---

<div class="post-metadata">

**Author:** ![Benny](https://avatars.discourse-cdn.com/v4/letter/b/49beb7/32.png) [@Benny](https://discuss.elastic.co/u/Benny)\
**Post date:** [March 25, 2016, 12:38pm UTC](https://discuss.elastic.co/t/path-repo-cannot-be-supported-in-es-2-1-0/37534/3 "2016-03-25T12:38:08Z")

</div>

Sorry for replying late. I‘ve found my mistake.  
Before the setting text, there should be a whitespace!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:05pm UTC](https://discuss.elastic.co/t/path-repo-cannot-be-supported-in-es-2-1-0/37534/4 "2017-07-05T23:05:12Z")

</div>


