# Path.repo makes ES fail to start

**URL:** <https://discuss.elastic.co/t/path-repo-makes-es-fail-to-start/58482>\
**Category:** Elasticsearch\
**Created:** [August 19, 2016, 6:27pm UTC](https://discuss.elastic.co/t/path-repo-makes-es-fail-to-start/58482 "2016-08-19T18:27:05Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![isaacpm](https://avatars.discourse-cdn.com/v4/letter/i/b9e5f3/32.png) [@isaacpm](https://discuss.elastic.co/u/isaacpm)\
**Post date:** [August 19, 2016, 6:27pm UTC](https://discuss.elastic.co/t/path-repo-makes-es-fail-to-start/58482/1 "2016-08-19T18:27:05Z")

</div>

Hi,

I'm trying to set the path.repo setting in the the es config.  
I'm using this line:  
path.repo: ["/tmp/backups"]  
(with a space at the start of the line)

But when I use it, ES fails to start.  
Are there any permissions that have to be taken into account or something?

Thanks,  
Isaac

---

<div class="post-metadata">

**Author:** ![mikemccand](https://avatars.discourse-cdn.com/v4/letter/m/f04885/32.png) [@mikemccand](https://discuss.elastic.co/u/mikemccand)\
**Post date:** [August 19, 2016, 7:03pm UTC](https://discuss.elastic.co/t/path-repo-makes-es-fail-to-start/58482/2 "2016-08-19T19:03:16Z")

</div>

Hmm, which configuration file are you adding the line to? Which ES version? When it fails, does it give any hints as to why (an exception or something)? If you comment out only that one line does it start successfully?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 19, 2016, 10:46pm UTC](https://discuss.elastic.co/t/path-repo-makes-es-fail-to-start/58482/3 "2016-08-19T22:46:17Z")

</div>

> [@isaacpm](#):
>
> (with a space at the start of the line)

Remove the space.  
YAML is space sensitive.

---

<div class="post-metadata">

**Author:** ![isaacpm](https://avatars.discourse-cdn.com/v4/letter/i/b9e5f3/32.png) [@isaacpm](https://discuss.elastic.co/u/isaacpm)\
**Post date:** [August 20, 2016, 7:49am UTC](https://discuss.elastic.co/t/path-repo-makes-es-fail-to-start/58482/4 "2016-08-20T07:49:41Z")

</div>

doh!  
I was using the space because I thought it had to be there.  
Should have checked the other parameters...

Thanks,  
Isaac

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 20, 2016, 8:11am UTC](https://discuss.elastic.co/t/path-repo-makes-es-fail-to-start/58482/5 "2016-08-20T08:11:56Z")

</div>

I've raised a GH issue on this, it's not uncommon so maybe we can do better - [https://github.com/elastic/elasticsearch/issues/20090](https://github.com/elastic/elasticsearch/issues/20090)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:26pm UTC](https://discuss.elastic.co/t/path-repo-makes-es-fail-to-start/58482/6 "2017-07-05T22:26:27Z")

</div>


