# Permission denied when i'm trying to use elasticsearch command

**URL:** <https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [February 8, 2022, 4:00pm UTC](https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629 "2022-02-08T16:00:18Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Arkoos62](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arkoos62/32/101179_2.png) [@Arkoos62](https://discuss.elastic.co/u/Arkoos62)\
**Post date:** [February 8, 2022, 4:00pm UTC](https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629/1 "2022-02-08T16:00:18Z")

</div>

Hello there,  
I am trying to configure basic security on my Elasticsearch production but i'm getting error when i try to launch a command from the path /usr/share/Elasticsearch/bin i'm getting this error

```auto
./elasticsearch-env: line 88: /etc/default/elasticsearch: Permission denied

```

here is the "ls -l" :

```auto
total 3472
-rwxr-xr-x 1 elasticsearch elasticsearch 2985 Jan 6 23:48 elasticsearch
-rwxr-xr-x 1 elasticsearch elasticsearch 501 Jan 6 23:48 elasticsearch-certgen
-rwxr-xr-x 1 elasticsearch elasticsearch 493 Jan 6 23:48 elasticsearch-certutil
-rwxr-xr-x 1 elasticsearch elasticsearch 996 Jan 6 23:48 elasticsearch-cli
-rwxr-xr-x 1 elasticsearch elasticsearch 443 Jan 6 23:48 elasticsearch-croneval
-rwxr-xr-x 1 elasticsearch elasticsearch 5522 Feb 2 14:14 elasticsearch-env
-rwxr-xr-x 1 elasticsearch elasticsearch 1828 Jan 6 23:48 elasticsearch-env-from-file
-rwxr-xr-x 1 elasticsearch elasticsearch 168 Jan 6 23:48 elasticsearch-geoip
-rwxr-xr-x 1 elasticsearch elasticsearch 184 Jan 6 23:48 elasticsearch-keystore
-rwxr-xr-x 1 elasticsearch elasticsearch 450 Jan 6 23:48 elasticsearch-migrate
-rwxr-xr-x 1 elasticsearch elasticsearch 126 Jan 6 23:48 elasticsearch-node
-rwxr-xr-x 1 elasticsearch elasticsearch 176 Jan 6 23:48 elasticsearch-plugin
-rwxr-xr-x 1 elasticsearch elasticsearch 441 Jan 6 23:48 elasticsearch-saml-metadata
-rwxr-xr-x 1 elasticsearch elasticsearch 439 Jan 6 23:48 elasticsearch-service-tokens
-rwxr-xr-x 1 elasticsearch elasticsearch 448 Jan 6 23:48 elasticsearch-setup-passwords
-rwxr-xr-x 1 elasticsearch elasticsearch 118 Jan 6 23:48 elasticsearch-shard
-rwxr-xr-x 1 elasticsearch elasticsearch 483 Jan 6 23:48 elasticsearch-sql-cli
-rwxr-xr-x 1 elasticsearch elasticsearch 3455027 Jan 6 23:48 elasticsearch-sql-cli-7.16.3.jar
-rwxr-xr-x 1 elasticsearch elasticsearch 436 Jan 6 23:48 elasticsearch-syskeygen
-rwxr-xr-x 1 elasticsearch elasticsearch 436 Jan 6 23:48 elasticsearch-users
-rwxr-xr-x 1 elasticsearch elasticsearch 332 Jan 6 23:48 systemd-entrypoint
-rwxr-xr-x 1 elasticsearch elasticsearch 356 Jan 6 23:48 x-pack-env
-rwxr-xr-x 1 elasticsearch elasticsearch 364 Jan 6 23:48 x-pack-security-env
-rwxr-xr-x 1 elasticsearch elasticsearch 363 Jan 6 23:48 x-pack-watcher-env

```

Thanks

---

<div class="post-metadata">

**Author:** ![Arkoos62](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arkoos62/32/101179_2.png) [@Arkoos62](https://discuss.elastic.co/u/Arkoos62)\
**Post date:** [February 8, 2022, 4:01pm UTC](https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629/2 "2022-02-08T16:01:13Z")

</div>

i forgot to precise that i'm on ubuntu 20.04 and this is the 7.16.3 version of ES

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 8, 2022, 9:36pm UTC](https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629/3 "2022-02-08T21:36:40Z")

</div>

What user are you running this command as?

---

<div class="post-metadata">

**Author:** ![Arkoos62](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arkoos62/32/101179_2.png) [@Arkoos62](https://discuss.elastic.co/u/Arkoos62)\
**Post date:** [February 10, 2022, 2:04pm UTC](https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629/4 "2022-02-10T14:04:10Z")

</div>

I tried to su Elasticsearch but i still see my default user on the shell and it still doesn’t work

---

<div class="post-metadata">

**Author:** ![wsouza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wsouza/32/92547_2.png) [@wsouza](https://discuss.elastic.co/u/wsouza)\
**Post date:** [February 10, 2022, 2:23pm UTC](https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629/5 "2022-02-10T14:23:47Z")

</div>

Checks who owns this directory (/etc/default/elasticsearch) and if not elasticsearch, assigns permission to this user and group:

**sudo chown -R elasticsearch:elasticsearch /etc/default/elasticsearch**

Alternatively, run the command below:

**sudo chmod +x /usr/share/elasticsearch/bin/elasticsearch**

With your username, use the **sudo** command to run ./elasticsearch

> [@Arkoos62](#):
>
> `/etc/default/elasticsearch`

---

<div class="post-metadata">

**Author:** ![Arkoos62](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arkoos62/32/101179_2.png) [@Arkoos62](https://discuss.elastic.co/u/Arkoos62)\
**Post date:** [February 11, 2022, 2:52pm UTC](https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629/6 "2022-02-11T14:52:07Z")

</div>

> [@Arkoos62](#):
>
> usr/share/Elasticsearch/bin

Ok the directory /etc/default/elasticsearch is owned by the right user and group

```auto
-rw-rw---- 1 elasticsearch elasticsearch 1724 Feb 8 15:47 /etc/default/elasticsearch

```

then i run this command like you said : **sudo chmod +x /usr/share/Elasticsearch/bin/Elasticsearch**  
then i run the command : sudo /usr/share/elasticsearch/bin/elasticsearch  
and i got this error :

```auto
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
[2022-02-11T14:43:15,503][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [arkoosnode] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.RuntimeException: can not run elasticsearch as root
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:157) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:77) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112) ~[elasticsearch-cli-7.16.3.jar:7.16.3]
        at org.elasticsearch.cli.Command.main(Command.java:77) ~[elasticsearch-cli-7.16.3.jar:7.16.3]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:122) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) ~[elasticsearch-7.16.3.jar:7.16.3]
Caused by: java.lang.RuntimeException: can not run elasticsearch as root
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:107) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:183) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:166) ~[elasticsearch-7.16.3.jar:7.16.3]
        ... 6 more
uncaught exception in thread [main]
java.lang.RuntimeException: can not run elasticsearch as root
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:107)
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:183)
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434)
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:166)
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:157)
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:77)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)
        at org.elasticsearch.cli.Command.main(Command.java:77)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:122)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80)
For complete error details, refer to the log at /var/log/elasticsearch/elasticsearch.log
2022-02-11 14:43:15,874409 UTC [3267] INFO Main.cc@111 Parent process died - ML controller exiting

```

in the log it tells : **Caused by: java.lang.RuntimeException: can not run elasticsearch as root**  
Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 11, 2022, 2:52pm UTC](https://discuss.elastic.co/t/permission-denied-when-im-trying-to-use-elasticsearch-command/296629/7 "2022-03-11T14:52:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
