# Permission to elasticsearch config directory

**URL:** <https://discuss.elastic.co/t/permission-to-elasticsearch-config-directory/227491>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [April 10, 2020, 11:44am UTC](https://discuss.elastic.co/t/permission-to-elasticsearch-config-directory/227491 "2020-04-10T11:44:54Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ethical20](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ethical20/32/68123_2.png) [@ethical20](https://discuss.elastic.co/u/ethical20)\
**Post date:** [April 10, 2020, 11:44am UTC](https://discuss.elastic.co/t/permission-to-elasticsearch-config-directory/227491/1 "2020-04-10T11:44:55Z")

</div>

Hi,

Is it normal for the elasticsearch config directory to be only accessible using sudo ?

```
amdin1@amdin1-virtual-machine:~$ cd /etc/elasticsearch
bash: cd: /etc/elasticsearch: Permission denied

```

The issue is that when setting the path for the .p12 cert, elasticsearch wont start throwing an error Permission denied, unable to access /etc/elasticsearch/certs/node-1.p12

`xpack.security.transport.ssl.keystore.path: certs/node-1.p12`

ls -l on /etc/ gave this result for the elasticsearch folder

`drwxr-s--- 2 root elasticsearch 4096 Apr 10 14:30 elasticsearch`

Any help is highly appreciated.

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [April 10, 2020, 12:44pm UTC](https://discuss.elastic.co/t/permission-to-elasticsearch-config-directory/227491/2 "2020-04-10T12:44:33Z")

</div>

How did you install elasticsearch and what OS are you using? How are you running elasticsearch ?

This looks very much related to what happens with your kibana installation with the permission issues in [Using https to login to Kibana](https://discuss.elastic.co/t/using-https-to-login-to-kibana/227328/6).

---

<div class="post-metadata">

**Author:** ![ethical20](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ethical20/32/68123_2.png) [@ethical20](https://discuss.elastic.co/u/ethical20)\
**Post date:** [April 10, 2020, 4:01pm UTC](https://discuss.elastic.co/t/permission-to-elasticsearch-config-directory/227491/3 "2020-04-10T16:01:18Z")

</div>

How did you install elasticsearch?  
_[https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html)_

what OS are you using?  
`Ubuntu 18.04 bionic`

How are you running elasticsearch ?  
`sudo systemctl start elasticsearch.service`

Regarding permission issue:

We are asked to save the .p12 in the default config path which is /etc/elasticsearch/

When I `cd /etc/elasticsearch/` I got a permission denied, for this the .p12 was not been accessed where it resides on `config/certs/node-1.p12`

```auto
    ./bin/elasticsearch-certutil cert \
    --ca elastic-stack-ca.p12 \ 
    --dns localhost \ 
    --ip 127.0.0.1,::1 
    --out config/certs/node-1.p12 

```

To solve this, the only thing (which is I don't think is a good practice at all, is I've chmod the .p12

`sudo chmod 777 node-1.p12`

This solved the issue, but I think there is something wrong with permissions, hope you can help in this to avoid such thing in production environment.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 8, 2020, 4:02pm UTC](https://discuss.elastic.co/t/permission-to-elasticsearch-config-directory/227491/4 "2020-05-08T16:02:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
