# Persistent Queue Error after hang up

**URL:** https://discuss.elastic.co/t/persistent-queue-error-after-hang-up/95143
**Category:** Logstash
**Created:** [July 31, 2017, 8:33am UTC](https://discuss.elastic.co/t/persistent-queue-error-after-hang-up/95143 "2017-07-31T08:33:21Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Shaoranlaos](https://avatars.discourse-cdn.com/v4/letter/s/c57346/32.png) [@Shaoranlaos](https://discuss.elastic.co/u/Shaoranlaos)
#### Post date: [July 31, 2017, 8:33am UTC](https://discuss.elastic.co/t/persistent-queue-error-after-hang-up/95143/1 "2017-07-31T08:33:21Z")

</div>

Our Logstash has hung up(not terminated) on the 29.7. 13:55 so that no events where processed.  
Curiosly on the 30.7. 14:10 it has started again but threw only Errors(see under config decription) until i restarted it on the 31.7. 7:30.  
After the restart it again processed normally the backlogged events.

The logstash config is mostly the default with the following exceptions:  
path.data: /var/lib/logstash  
path.config: /etc/logstash/conf.d  
queue.type: persisted  
path.logs: /var/log/logstash  
It was installed with yum on CentOS 7 in Version 5.4.3 (upgraded from 5.3.2 on the 17.07.2017).

The hang up occured without an error.  
The error that was continuossly thrown(every 5 seconds) on the next day is an IOException (it will not let me post the complete error).

Knows someone what the cause for this error is?

Thanks  
Shaoranlaos

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [August 2, 2017, 5:42pm UTC](https://discuss.elastic.co/t/persistent-queue-error-after-hang-up/95143/2 "2017-08-02T17:42:15Z")

</div>

We need to see the full error message. If it's too much to post here (because of a long stacktrace) you can make multiple posts, put it on pastebin or in a gist, or worst case truncate the stacktrace(s) to reduce their size.

---

<div class="post-metadata">

### Author: ![Shaoranlaos](https://avatars.discourse-cdn.com/v4/letter/s/c57346/32.png) [@Shaoranlaos](https://discuss.elastic.co/u/Shaoranlaos)
#### Post date: [August 3, 2017, 5:01am UTC](https://discuss.elastic.co/t/persistent-queue-error-after-hang-up/95143/3 "2017-08-03T05:01:50Z")

</div>

Here is the Link to the Error on Pastebin  
[https://pastebin.com/jBXXc14p](https://pastebin.com/jBXXc14p)

---

<div class="post-metadata">

### Author: ![Shaoranlaos](https://avatars.discourse-cdn.com/v4/letter/s/c57346/32.png) [@Shaoranlaos](https://discuss.elastic.co/u/Shaoranlaos)
#### Post date: [August 7, 2017, 5:38am UTC](https://discuss.elastic.co/t/persistent-queue-error-after-hang-up/95143/4 "2017-08-07T05:38:34Z")

</div>

it has happend again this weekend with the same error

i have deactivated the persistent queue now and will see if the failure will happen again

---

<div class="post-metadata">

### Author: ![Shaoranlaos](https://avatars.discourse-cdn.com/v4/letter/s/c57346/32.png) [@Shaoranlaos](https://discuss.elastic.co/u/Shaoranlaos)
#### Post date: [August 28, 2017, 7:03am UTC](https://discuss.elastic.co/t/persistent-queue-error-after-hang-up/95143/5 "2017-08-28T07:03:16Z")

</div>

ok after deactivating the persistent queue logstash works again without error to date  
so there seems to be an error with this feature in our installation?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 25, 2017, 7:03am UTC](https://discuss.elastic.co/t/persistent-queue-error-after-hang-up/95143/6 "2017-09-25T07:03:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
