# Pipeline aborted due to error {:exception=\>#\<LogStash::ConfigurationError: Cipher?

**URL:** <https://discuss.elastic.co/t/pipeline-aborted-due-to-error-exception-logstash-configurationerror-cipher/95148>\
**Category:** Logstash\
**Created:** [July 31, 2017, 8:46am UTC](https://discuss.elastic.co/t/pipeline-aborted-due-to-error-exception-logstash-configurationerror-cipher/95148 "2017-07-31T08:46:59Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ndarkness](https://avatars.discourse-cdn.com/v4/letter/n/90db22/32.png) [@ndarkness](https://discuss.elastic.co/u/ndarkness)\
**Post date:** [July 31, 2017, 8:47am UTC](https://discuss.elastic.co/t/pipeline-aborted-due-to-error-exception-logstash-configurationerror-cipher/95148/1 "2017-07-31T08:47:00Z")

</div>

HEllo,

I am seeing the following errors on my logstash log

```
[2017-07-31T10:11:57,951][INFO][logstash.pipeline] Starting pipeline {"id"=>"main", "pipeline.workers"=>4, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>5, "pipeline.max_inflight"=>500}
[2017-07-31T10:11:58,245][INFO][logstash.inputs.beats] Beats inputs: Starting input listener {:address=>"0.0.0.0:5044"}
[2017-07-31T10:11:58,949][ERROR][logstash.pipeline] Error registering plugin {:plugin=>"<LogStash::Inputs::Beats port=>5044, ssl=>true, ssl_certificate=>\"/etc/pki/tls/certs/logstash-forwarder.crt\", ssl_key=>\"/etc/pki/tls/private/logstash-forwarder.key\", id=>\"907b71db99a3505505967783ce186c0d2de0711a-1\", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>\"plain_b7b9a94c-d647-446c-89b7-a1e0d34ec99d\", enable_metric=>true, charset=>\"UTF-8\">, host=>\"0.0.0.0\", ssl_verify_mode=>\"none\", include_codec_tag=>true, ssl_handshake_timeout=>10000, congestion_threshold=>5, target_field_for_codec=>\"message\", tls_min_version=>1, tls_max_version=>1.2, cipher_suites=>[\"TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384\", \"TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384\", \"TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256\", \"TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256\", \"TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384\", \"TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384\", \"TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256\"], client_inactivity_timeout=>60>", :error=>"Cipher `TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384` is not available"}
[2017-07-31T10:12:00,238][ERROR][logstash.agent] Pipeline aborted due to error {:exception=>#<LogStash::ConfigurationError: Cipher `TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384` is not available>, :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-beats-3.1.15-java/lib/logstash/inputs/beats.rb:167:in `create_server'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-beats-3.1.15-java/lib/logstash/inputs/beats.rb:155:in `register'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:268:in `register_plugin'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:279:in `register_plugins'", "org/jruby/RubyArray.java:1613:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:279:in `register_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:429:in `start_inputs'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:323:in `start_workers'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:214:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:398:in `start_pipeline'"]}

```

What is the cause of this error and how can I fix it?

My java version

```
# java -version
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

```

I am using logstash 5.5

```
$ps -aux | grep logstash
root 3688 0.0 0.0 7260 604 pts/0 S+ 10:38 0:00 tail -f /var/log/logstash/logstash-plain.log
logstash 3797 25.4 4.7 3643192 387484 ? SNsl 10:46 1:25 /usr/bin/java -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -Djava.awt.headless=true -Dfile.encoding=UTF-8 -XX:+HeapDumpOnOutOfMemoryError -Dio.netty.native.workdir=$HOME -Xmx1g -Xms256m -Xss2048k -Djffi.boot.library.path=/usr/share/logstash/vendor/jruby/lib/jni -Xbootclasspath/a:/usr/share/logstash/vendor/jruby/lib/jruby.jar -classpath : -Djruby.home=/usr/share/logstash/vendor/jruby -Djruby.lib=/usr/share/logstash/vendor/jruby/lib -Djruby.script=jruby -Djruby.shell=/bin/sh org.jruby.Main /usr/share/logstash/lib/bootstrap/environment.rb logstash/runner.rb --path.settings /etc/logstash
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 28, 2017, 8:47am UTC](https://discuss.elastic.co/t/pipeline-aborted-due-to-error-exception-logstash-configurationerror-cipher/95148/2 "2017-08-28T08:47:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
