# Pipeline cannot start with http\_poller

**URL:** <https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405>\
**Category:** Logstash\
**Created:** [November 20, 2017, 2:21pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405 "2017-11-20T14:21:49Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tonni\_Hult](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tonni_hult/32/11992_2.png) [@Tonni\_Hult](https://discuss.elastic.co/u/Tonni_Hult)\
**Post date:** [November 20, 2017, 2:21pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/1 "2017-11-20T14:21:49Z")

</div>

Hi  
I've installed v6.0 and get a problem when using input http\_poller because the pipeline crashes when starting up and the output that I get is:

`Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:main, :exception=>"NoMethodError", :message=>"undefined method ``get' for #<Hash:0x7e616f62>\nDid you mean? gem"`

My configuration looks like this and I cannot figure out what the problem is and why it is complaining about method:

```
  http_poller {
    urls => {
      dev => {
        method => get
        url => "..."
        headers => {
          Accept => "application/json"
        }
      }
    }
    request_timeout => 60
	schedule => { "every" => "10s"}
    codec => "json"
    metadata_target => "http_poller_metadata"
  }

```

Regards  
Tonni

---

<div class="post-metadata">

**Author:** ![fozzeuh](https://avatars.discourse-cdn.com/v4/letter/f/e9c0ed/32.png) [@fozzeuh](https://discuss.elastic.co/u/fozzeuh)\
**Post date:** [November 21, 2017, 12:46pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/2 "2017-11-21T12:46:44Z")

</div>

Did you find solution ?

---

<div class="post-metadata">

**Author:** ![Tonni\_Hult](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tonni_hult/32/11992_2.png) [@Tonni\_Hult](https://discuss.elastic.co/u/Tonni_Hult)\
**Post date:** [November 21, 2017, 12:50pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/3 "2017-11-21T12:50:13Z")

</div>

No I haven't. Any idea on what could be the problem?

---

<div class="post-metadata">

**Author:** ![fozzeuh](https://avatars.discourse-cdn.com/v4/letter/f/e9c0ed/32.png) [@fozzeuh](https://discuss.elastic.co/u/fozzeuh)\
**Post date:** [November 21, 2017, 1:06pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/4 "2017-11-21T13:06:25Z")

</div>

I tried with logstash 5.0 and it's work fine ☹

---

<div class="post-metadata">

**Author:** ![Thor77](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thor77/32/24512_2.png) [@Thor77](https://discuss.elastic.co/u/Thor77)\
**Post date:** [November 21, 2017, 1:14pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/5 "2017-11-21T13:14:12Z")

</div>

Can reproduce 😕

My error looks slightly different, though:

```
The given configuration is invalid. Reason: undefined method `get' for {"url"=>"..."}:hash:
Did you mean? gem

```

With this configuration:

```
input {
    http_poller {
        urls => {
            localhost => {
                url => "..."
            }
        }
        codec => "json_lines"
        schedule => { every => "60s" }
        metadata_target => "[@metadata][http_poller]"
    }
}
```

---

<div class="post-metadata">

**Author:** ![Edjin](https://avatars.discourse-cdn.com/v4/letter/e/ee7513/32.png) [@Edjin](https://discuss.elastic.co/u/Edjin)\
**Post date:** [November 21, 2017, 5:06pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/6 "2017-11-21T17:06:36Z")

</div>

Hi,  
I have the same problem with logstash v6.0 with this code :

```
input {
    http_poller {
        urls => {
            test => {
                method => get
                headers => {
                    Accept => "application/json"
                }
                url => "http://localhost:9200/_cluster/health"
            }
        }
        request_timeout => 60
        schedule => { in => "1s"}
        codec => "json"
    }
}
filter{}
output {
    stdout {
        codec => rubydebug
    }
}

```

This code was written based on the exemple on : [https://www.elastic.co/guide/en/logstash/6.0/plugins-inputs-http\_poller.html](https://www.elastic.co/guide/en/logstash/6.0/plugins-inputs-http_poller.html)

And the error is :

_Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"NoMethodError", :message=\>"undefined method `get' for {"Accept"=\>"application/json"}:Hash\nDid you mean? gem",_

Like you I don't understand what is the problem but maybe this example can help to reproduce the problem for elastic team members.

---

<div class="post-metadata">

**Author:** ![Giri\_Manoharan](https://avatars.discourse-cdn.com/v4/letter/g/ed8c4c/32.png) [@Giri\_Manoharan](https://discuss.elastic.co/u/Giri_Manoharan)\
**Post date:** [November 22, 2017, 5:33pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/7 "2017-11-22T17:33:43Z")

</div>

Even I've the same problem.

> Blockquote

[2017-11-22T17:14:28,097][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"NoMethodError", :message=\>"undefined method `get' for #Hash:0x4359aa3f\nDid you mean? gem",

> Blockquote

---

<div class="post-metadata">

**Author:** ![Brando](https://avatars.discourse-cdn.com/v4/letter/b/bcef8e/32.png) [@Brando](https://discuss.elastic.co/u/Brando)\
**Post date:** [November 29, 2017, 8:50pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/8 "2017-11-29T20:50:14Z")

</div>

I had this exact issue with http\_poller after upgrading to 6.0. The config worked fine in previous versions.

I've submitted a ticket to elastic support, I'll try to post here if they provide any additional updates or a fix.

---

<div class="post-metadata">

**Author:** ![Sawyer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sawyer/32/15842_2.png) [@Sawyer](https://discuss.elastic.co/u/Sawyer)\
**Post date:** [November 29, 2017, 8:53pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/9 "2017-11-29T20:53:33Z")

</div>

We have the same issue as well, we just upgraded to 6.0.0 on our test instance and found this plugin is the only logstash plugin with an issue.

However, we tested with only one url and no additional auth config, and it seemed to work. So, maybe the auth portion is causing an issue. But it seems some folks in this thread have issues without auth enabled.

---

<div class="post-metadata">

**Author:** ![ryan\_gallagher](https://avatars.discourse-cdn.com/v4/letter/r/d07c76/32.png) [@ryan\_gallagher](https://discuss.elastic.co/u/ryan_gallagher)\
**Post date:** [November 30, 2017, 2:19am UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/10 "2017-11-30T02:19:51Z")

</div>

Hitting this issue as well!

---

<div class="post-metadata">

**Author:** ![alext234](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alext234/32/25087_2.png) [@alext234](https://discuss.elastic.co/u/alext234)\
**Post date:** [December 5, 2017, 10:27pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/11 "2017-12-05T22:27:25Z")

</div>

From this [https://github.com/logstash-plugins/logstash-input-http\_poller/issues/90](https://github.com/logstash-plugins/logstash-input-http_poller/issues/90),  
it is already a known issue and they will fix it 6.0.1

---

<div class="post-metadata">

**Author:** ![Tonni\_Hult](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tonni_hult/32/11992_2.png) [@Tonni\_Hult](https://discuss.elastic.co/u/Tonni_Hult)\
**Post date:** [December 13, 2017, 3:53pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/12 "2017-12-13T15:53:30Z")

</div>

I have installed 6.0.1 and was then able to use http\_poller

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 10, 2018, 4:06pm UTC](https://discuss.elastic.co/t/pipeline-cannot-start-with-http-poller/108405/13 "2018-01-10T16:06:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
