# Pipeline error "pipeline-id" :exception=\>#\<Psych::DisallowedClass: Tried to load unspecified class: Time

**URL:** <https://discuss.elastic.co/t/pipeline-error-pipeline-id-exception-psych-tried-to-load-unspecified-class-time/336786>\
**Category:** Logstash\
**Created:** [June 23, 2023, 3:04pm UTC](https://discuss.elastic.co/t/pipeline-error-pipeline-id-exception-psych-tried-to-load-unspecified-class-time/336786 "2023-06-23T15:04:46Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Gelinski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gelinski/32/142412_2.png) [@Gelinski](https://discuss.elastic.co/u/Gelinski)\
**Post date:** [June 23, 2023, 3:04pm UTC](https://discuss.elastic.co/t/pipeline-error-pipeline-id-exception-psych-tried-to-load-unspecified-class-time/336786/1 "2023-06-23T15:04:46Z")

</div>

Hello folks,

I have a logstash pipeline that is using a **jdbc input** and is configured with a schedule (0/1 \* \* \* \*) and after change its schedule to any other schedule the following error starts to happen:

[2023-06-23T11:24:52,886][ERROR][logstash.javapipeline][lxxxxxxxx] Pipeline error {:pipeline\_id=\>"lxxxxx", :exception=\>#\<Psych::DisallowedClass: Tried to load unspecified class: Time\>

Even if I change it back to the original schedule (0/1 \* \* \* \*) it still not work and shows the same error.

I did a few tests regarding the logstash/data files and I noticed that if I remove the following file and restart the logstash process the pipeline starts to work again.

logstash/data/plugins/inputs/jdbc/logstash\_jdbc\_last\_run

I was not able to reproduce this same behavior using a **elasticsearch input**. Here, changing the schedule works as expected.

My env:

Logstash version: 8.8.1  
Install method: YUM

Could this be a bug?

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [June 23, 2023, 4:08pm UTC](https://discuss.elastic.co/t/pipeline-error-pipeline-id-exception-psych-tried-to-load-unspecified-class-time/336786/2 "2023-06-23T16:08:32Z")

</div>

> [@Gelinski](#):
>
> Could this be a bug?

Yes, see [this](https://discuss.elastic.co/t/possible-issue-with-tracking-column-type-timestamp-in-8-1-1/336255/2) thread. A fix has already been submitted. The exception occurs when the input tries to parse the YAML that is persisted in logstash\_jdbc\_last\_run. No YAML, no exception.

---

<div class="post-metadata">

**Author:** ![Gelinski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gelinski/32/142412_2.png) [@Gelinski](https://discuss.elastic.co/u/Gelinski)\
**Post date:** [June 27, 2023, 6:29pm UTC](https://discuss.elastic.co/t/pipeline-error-pipeline-id-exception-psych-tried-to-load-unspecified-class-time/336786/3 "2023-06-27T18:29:20Z")

</div>

Got it.

In this meantime I did a downgrade to 8.7.1 version as a workaround and its working fine.

Thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 25, 2023, 6:29pm UTC](https://discuss.elastic.co/t/pipeline-error-pipeline-id-exception-psych-tried-to-load-unspecified-class-time/336786/4 "2023-07-25T18:29:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
