# Pipeline/output.go:154 Failed to connect to backoff

**URL:** https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767
**Category:** Beats
**Tags:** filebeat
**Created:** [December 2, 2021, 12:50pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767 "2021-12-02T12:50:07Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![abhi.logs](https://avatars.discourse-cdn.com/v4/letter/a/d26b3c/32.png) [@abhi.logs](https://discuss.elastic.co/u/abhi.logs)
#### Post date: [December 2, 2021, 12:50pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/1 "2021-12-02T12:50:07Z")

</div>

Hello,  
I'm getting this error, does anyone knows how to solve this?

```auto
ERROR	[publisher_pipeline_output]	pipeline/output.go:154	Failed to connect to backoff(elasticsearch(https://xxxxxx:9200)): Connection marked as failed because the onConnect callback failed: resource 'filebeat-7.14.0' exists, but it is not an alias

```

---

<div class="post-metadata">

### Author: ![AquaX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aquax/32/92006_2.png) [@AquaX](https://discuss.elastic.co/u/AquaX)
#### Post date: [December 2, 2021, 2:11pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/2 "2021-12-02T14:11:06Z")

</div>

> [@abhi.logs](#):
>
> `Connection marked as failed because the onConnect callback failed: resource 'filebeat-7.14.0' exists, but it is not an alias`

I think this means that the index you are trying to write to exists but is not an alias as you likely defined some sort of ILM rules to be followed.

If you can paste your beats output config then that will help to figure out the problem.

---

<div class="post-metadata">

### Author: ![abhi.logs](https://avatars.discourse-cdn.com/v4/letter/a/d26b3c/32.png) [@abhi.logs](https://discuss.elastic.co/u/abhi.logs)
#### Post date: [December 2, 2021, 2:14pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/3 "2021-12-02T14:14:09Z")

</div>

Thanks for reply

```auto
 # ================================== Outputs ===================================

# Configure what output to use when sending the data collected by the beat.

# ---------------------------- Elasticsearch Output ----------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["xxxxxx:9200"]

  indices:
    - index: "logindex-%{[fields.server]}-%{[fields.log_type]}-%{+yyyy.MM.dd}"
      when.contains:
        fields.log_group: "paltform"

  # Protocol - either `http` (default) or `https`.
  protocol: "https"

  # Authentication credentials - either API key or username/password.
  username: "username"
  password: "password"

```

---

<div class="post-metadata">

### Author: ![AquaX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aquax/32/92006_2.png) [@AquaX](https://discuss.elastic.co/u/AquaX)
#### Post date: [December 2, 2021, 2:19pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/4 "2021-12-02T14:19:37Z")

</div>

Have you recently upgraded your agents or Elasticsearch?

Try setting this in filebeat:

```auto
setup.template.settings:
  setup.template.overwrite: true
  setup.template.enabled: true

```

---

<div class="post-metadata">

### Author: ![abhi.logs](https://avatars.discourse-cdn.com/v4/letter/a/d26b3c/32.png) [@abhi.logs](https://discuss.elastic.co/u/abhi.logs)
#### Post date: [December 2, 2021, 2:29pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/5 "2021-12-02T14:29:31Z")

</div>

> [@AquaX](#):
>
> `setup.template.enabled: true`

No, we didn't upgrade anything, We shut down ES for a month. When we started ES it stopped working and getting this error @AquaX template setting not working

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/4/a49e06632adb2927766dc76a6f14bd5bd5bc4bf8.png)

---

<div class="post-metadata">

### Author: ![AquaX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aquax/32/92006_2.png) [@AquaX](https://discuss.elastic.co/u/AquaX)
#### Post date: [December 2, 2021, 2:36pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/6 "2021-12-02T14:36:56Z")

</div>

Put

```auto
setup.template.enabled: true
setup.template.overwrite: true

```

before `setup.template.settings:`  
ideally `above setup.template.name`

---

<div class="post-metadata">

### Author: ![abhi.logs](https://avatars.discourse-cdn.com/v4/letter/a/d26b3c/32.png) [@abhi.logs](https://discuss.elastic.co/u/abhi.logs)
#### Post date: [December 2, 2021, 2:43pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/7 "2021-12-02T14:43:33Z")

</div>

Getting the same error for both conditions.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/8/4/84e92bfc84639ce6bf379d2c468eab17260a868c.png)  
 ![Screenshot 2021-12-02 at 8.11.52 PM](https://us1.discourse-cdn.com/elastic/original/3X/4/2/42d429d1074a1d64dcc234665b4b7757e6acdaf1.png)

---

<div class="post-metadata">

### Author: ![AquaX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aquax/32/92006_2.png) [@AquaX](https://discuss.elastic.co/u/AquaX)
#### Post date: [December 2, 2021, 3:00pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/8 "2021-12-02T15:00:54Z")

</div>

Hmm... strange. I'm honestly not sure what the problem could be.  
Does your template on Elasticsearch include an alias?

---

<div class="post-metadata">

### Author: ![abhi.logs](https://avatars.discourse-cdn.com/v4/letter/a/d26b3c/32.png) [@abhi.logs](https://discuss.elastic.co/u/abhi.logs)
#### Post date: [December 2, 2021, 3:08pm UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/9 "2021-12-02T15:08:45Z")

</div>

How to check alias?  
I hope this is correct cmd.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/c/bc3f3fc522ec01dde154c67cf4bec8b42922aa7e.png)

---

<div class="post-metadata">

### Author: ![abhi.logs](https://avatars.discourse-cdn.com/v4/letter/a/d26b3c/32.png) [@abhi.logs](https://discuss.elastic.co/u/abhi.logs)
#### Post date: [December 3, 2021, 11:53am UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/10 "2021-12-03T11:53:37Z")

</div>

While checking the ES logs, I received this error.

```auto

> [ERROR][o.e.x.i.IndexLifecycleRunner] [ip] current step [{"phase":"hot","action":"rollover","name":"check-rollover-ready"}] for index [logindex-qa-xx-log-2021.10.03] with policy [10-day_delete_policy] is not recognized

```

---

<div class="post-metadata">

### Author: ![abhi.logs](https://avatars.discourse-cdn.com/v4/letter/a/d26b3c/32.png) [@abhi.logs](https://discuss.elastic.co/u/abhi.logs)
#### Post date: [December 7, 2021, 5:03am UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/11 "2021-12-07T05:03:31Z")

</div>

Deleted the filebeat-7.14.0 index.  
This one help me to resolved this issue  
------\>\>

> [@Exiting: resource 'metricbeat-7.4.2' exists, but it is not an alias](https://discuss.elastic.co/t/exiting-resource-metricbeat-7-4-2-exists-but-it-is-not-an-alias/206685/3):
>
> I managed to find a way around this in case anyone else is interested. Here's what I had to do: Stop new index auto-creation Added action.auto\_create\_index: false to the user override settings for the node Deleted the metricbeat-7.4.0 index (I can afford to lose this data) Created a new metricbeat-7.4.0-2019-11-06 index and assign it the alias PUT /metricbeat-7.4.0-2019-11-06 { "actions" : [ { "add" : { "index" : "metricbeat-7.4.0-2019.11.06-000001", "alias" : "metric…

\<\<------

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 4, 2022, 7:03am UTC](https://discuss.elastic.co/t/pipeline-output-go-154-failed-to-connect-to-backoff/290767/12 "2022-01-04T07:03:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
