# Pipeline stopped due to database recovery

**URL:** <https://discuss.elastic.co/t/pipeline-stopped-due-to-database-recovery/268983>\
**Category:** Logstash\
**Created:** [April 1, 2021, 5:46am UTC](https://discuss.elastic.co/t/pipeline-stopped-due-to-database-recovery/268983 "2021-04-01T05:46:51Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dhruv\_Rank](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dhruv_rank/32/86442_2.png) [@Dhruv\_Rank](https://discuss.elastic.co/u/Dhruv_Rank)\
**Post date:** [April 1, 2021, 5:46am UTC](https://discuss.elastic.co/t/pipeline-stopped-due-to-database-recovery/268983/1 "2021-04-01T05:46:51Z")

</div>

Hello,I am new to this and everyday I got same issue  
`[2021-03-31T19:28:00,364][ERROR][logstash.inputs.jdbc][add-jobs] Unable to connect to database. Tried 1 times {:error_message=>"Java::OrgPostgresqlUtil::PSQLException: FATAL: the database system is in recovery mode"}`

---

<div class="post-metadata">

**Author:** ![grumo35](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grumo35/32/59451_2.png) [@grumo35](https://discuss.elastic.co/u/grumo35)\
**Post date:** [April 1, 2021, 3:05pm UTC](https://discuss.elastic.co/t/pipeline-stopped-due-to-database-recovery/268983/2 "2021-04-01T15:05:52Z")

</div>

Looks like your databse is in fact in recovery mode, did you try to restart your pssql service ?

What's the state of the service ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 29, 2021, 3:06pm UTC](https://discuss.elastic.co/t/pipeline-stopped-due-to-database-recovery/268983/3 "2021-04-29T15:06:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
