# Pipelines.yml pipeline to pipeline address unavailable error again!

**URL:** <https://discuss.elastic.co/t/pipelines-yml-pipeline-to-pipeline-address-unavailable-error-again/221954>\
**Category:** Logstash\
**Created:** [March 3, 2020, 11:21pm UTC](https://discuss.elastic.co/t/pipelines-yml-pipeline-to-pipeline-address-unavailable-error-again/221954 "2020-03-03T23:21:33Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Devopsio](https://avatars.discourse-cdn.com/v4/letter/d/ebca7d/32.png) [@Devopsio](https://discuss.elastic.co/u/Devopsio)\
**Post date:** [March 3, 2020, 11:21pm UTC](https://discuss.elastic.co/t/pipelines-yml-pipeline-to-pipeline-address-unavailable-error-again/221954/1 "2020-03-03T23:21:33Z")

</div>

Hi. I don't understand why my multipiplines don't work while it should as I've created config files by an example. I've tried to restart Logstash as it was using a single-file pipeline (using -f flag). Logstash is a container and its version is 7.5.1. What's wrong with any of the files? Here's pipelines.yml:

```
 - pipeline.id: main
   config.string: |
    input {
      beats {
         port => 5000
         ssl => true
         ssl_certificate => "/logstash.crt"
         ssl_key => "/logstash.key"
       }
}

output {
  if [container][name] =~ 'redis' {
    pipeline {
      send_to => redis
    }
  }
}
- pipeline.id: redis
  queue.type: persisted
  pipeline.workers: 1
  path.config: "/usr/share/logstash/pipeline/redis.conf"

```

/usr/share/logstash/pipeline/redis.conf:

```
input {
 pipeline {
  address => redis
 }
}

output {
    elasticsearch {
            hosts => "elasticsearch:9200"
            user => "user"
            password => "password"
            ilm_enabled => true
            template_overwrite => true
            ilm_rollover_alias => "redis"
            ilm_policy => "generic"
            index => "redis"
    }
    stdout { codec => json}
}

```

Errors I get:

```
  Attempted to send event to 'redis' but that address was unavailable. Maybe the destination pipeline is down or stopping? Will Retry.
  [logstash.config.source.local.configpathloader] No config files found in path {:path=>"/usr/share/logstash/pipeline/redis.conf"}
```

---

<div class="post-metadata">

**Author:** ![Wolfram\_Haussig](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wolfram_haussig/32/70528_2.png) [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)\
**Post date:** [March 4, 2020, 7:23am UTC](https://discuss.elastic.co/t/pipelines-yml-pipeline-to-pipeline-address-unavailable-error-again/221954/2 "2020-03-04T07:23:45Z")

</div>

Hi,

Have you tried placing the redis.conf in another directory? Maybe LogStash has not anough privileges to read the file?

Best regards  
Wolfram

---

<div class="post-metadata">

**Author:** ![Devopsio](https://avatars.discourse-cdn.com/v4/letter/d/ebca7d/32.png) [@Devopsio](https://discuss.elastic.co/u/Devopsio)\
**Post date:** [March 4, 2020, 8:07am UTC](https://discuss.elastic.co/t/pipelines-yml-pipeline-to-pipeline-address-unavailable-error-again/221954/3 "2020-03-04T08:07:22Z")

</div>

It has such permissions: it can read the redis.conf and any other files in the same directory.

So the question is: why Logstash can't access the redis virtual address? We have the same setup on another ELK and there it works fine.

---

<div class="post-metadata">

**Author:** ![Devopsio](https://avatars.discourse-cdn.com/v4/letter/d/ebca7d/32.png) [@Devopsio](https://discuss.elastic.co/u/Devopsio)\
**Post date:** [March 4, 2020, 2:28pm UTC](https://discuss.elastic.co/t/pipelines-yml-pipeline-to-pipeline-address-unavailable-error-again/221954/4 "2020-03-04T14:28:44Z")

</div>

Turns out I was using yml files while it should conf files. My bad.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 1, 2020, 2:28pm UTC](https://discuss.elastic.co/t/pipelines-yml-pipeline-to-pipeline-address-unavailable-error-again/221954/5 "2020-04-01T14:28:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
