# Please help in Logstash Error

**URL:** <https://discuss.elastic.co/t/please-help-in-logstash-error/62926>\
**Category:** Logstash\
**Created:** [October 13, 2016, 10:49am UTC](https://discuss.elastic.co/t/please-help-in-logstash-error/62926 "2016-10-13T10:49:09Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![amits](https://avatars.discourse-cdn.com/v4/letter/a/919ad9/32.png) [@amits](https://discuss.elastic.co/u/amits)\
**Post date:** [October 13, 2016, 10:49am UTC](https://discuss.elastic.co/t/please-help-in-logstash-error/62926/1 "2016-10-13T10:49:09Z")

</div>

Hi all,

I am trying to read log files from other machine using Filebeat at my end in Logstash.  
When I am staring my logstash, it is throwing an ERROR as below:

A plugin had an unrecoverable error. Will restart this plugin.  
Plugin: \<LogStash::Inputs::Beats port=\>9300, codec=\>\<LogStash::Codecs::Plain charset=\>"UTF-8"\>, host=\>"0.0.0.0", ssl=\>false, ssl\_verify\_mode=\>"none", include\_codec\_tag=\>true, ssl\_handshake\_timeout=\>10000, congestion\_threshold=\>5, target\_field\_for\_codec=\>"message", tls\_min\_version=\>1, tls\_max\_version=\>1.2, cipher\_suites=\>["TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_GCM\_SHA38", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_GCM\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_RSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA256"], client\_inactivity\_timeout=\>15\>

My logstash Config file is:

input {  
beats {  
port =\> 9300  
}  
}

#}

# The filter part of this file is commented out to indicate that it is

# optional.

# filter {

# 

# }

output {  
elasticsearch {  
hosts =\> ["10.250.22.115:9200"]  
index =\> "logstashes-%{+YYYY.MM.dd}"  
}  
file {  
path =\> "/home/amits/ELK-deploy/logstash-2.4.0/logstash-data/logs.txt"  
}  
stdout { codec =\> rubydebug }  
}

Please help. Thanks in advance.

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [October 13, 2016, 10:53am UTC](https://discuss.elastic.co/t/please-help-in-logstash-error/62926/2 "2016-10-13T10:53:41Z")

</div>

Is here nothing else in the log?

Why use port 9300 when that's Elasticsearch's preferred port? If you currently run ES on the same host that could explain why Logstash refuses to start.

---

<div class="post-metadata">

**Author:** ![amits](https://avatars.discourse-cdn.com/v4/letter/a/919ad9/32.png) [@amits](https://discuss.elastic.co/u/amits)\
**Post date:** [October 13, 2016, 12:29pm UTC](https://discuss.elastic.co/t/please-help-in-logstash-error/62926/3 "2016-10-13T12:29:34Z")

</div>

Thanks magnus 🙂  
Now its working. It was issue of port only. 5044 works for me

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:34am UTC](https://discuss.elastic.co/t/please-help-in-logstash-error/62926/4 "2017-07-06T04:34:23Z")

</div>


