# Please help

**URL:** <https://discuss.elastic.co/t/please-help/181457>\
**Category:** Elasticsearch\
**Created:** [May 16, 2019, 5:17pm UTC](https://discuss.elastic.co/t/please-help/181457 "2019-05-16T17:17:27Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Aryan90](https://avatars.discourse-cdn.com/v4/letter/a/e68b1a/32.png) [@Aryan90](https://discuss.elastic.co/u/Aryan90)\
**Post date:** [May 16, 2019, 5:17pm UTC](https://discuss.elastic.co/t/please-help/181457/1 "2019-05-16T17:17:27Z")

</div>

[elastic@elasticsearch elasticsearch] sudo systemctl status elasticsearch -l ● elasticsearch.service - Elasticsearch Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled) Active: failed (Result: exit-code) since Mon 2018-12-10 03:55:01 EST; 2min 35s ago Docs: http://www.elastic.co Process: 81969 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p {PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 81969 (code=exited, status=1/FAILURE)

Dec 10 03:55:01 elasticsearch.local elasticsearch[81969]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)  
Dec 10 03:55:01 elasticsearch.local elasticsearch[81969]: at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:219)  
Dec 10 03:55:01 elasticsearch.local elasticsearch[81969]: at java.base/java.nio.file.Files.newByteChannel(Files.java:373)  
Dec 10 03:55:01 elasticsearch.local elasticsearch[81969]: at java.base/java.nio.file.Files.newByteChannel(Files.java:424)  
Dec 10 03:55:01 elasticsearch.local elasticsearch[81969]: at java.base/java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:420)  
Dec 10 03:55:01 elasticsearch.local elasticsearch[81969]: at java.base/java.nio.file.Files.newInputStream(Files.java:158)  
Dec 10 03:55:01 elasticsearch.local elasticsearch[81969]: at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:60)  
Dec 10 03:55:01 elasticsearch.local systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Dec 10 03:55:01 elasticsearch.local systemd[1]: Unit elasticsearch.service entered failed state.  
Dec 10 03:55:01 elasticsearch.local systemd[1]: elasticsearch.service failed.

and kibana status

[elastic@elasticsearch elasticsearch]$ systemctl status kibana -l  
● kibana.service - Kibana  
Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)  
Active: failed (Result: start-limit) since Mon 2018-12-10 03:49:51 EST; 10min ago  
Process: 81604 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=217/USER)  
Main PID: 81604 (code=exited, status=217/USER)

Dec 10 03:49:51 elasticsearch.local systemd[1]: kibana.service: main process exited, code=exited, status=217/USER  
Dec 10 03:49:51 elasticsearch.local systemd[1]: Unit kibana.service entered failed state.  
Dec 10 03:49:51 elasticsearch.local systemd[1]: kibana.service failed.  
Dec 10 03:49:51 elasticsearch.local systemd[1]: kibana.service holdoff time over, scheduling restart.  
Dec 10 03:49:51 elasticsearch.local systemd[1]: Stopped Kibana.  
Dec 10 03:49:51 elasticsearch.local systemd[1]: start request repeated too quickly for kibana.service  
Dec 10 03:49:51 elasticsearch.local systemd[1]: Failed to start Kibana.  
Dec 10 03:49:51 elasticsearch.local systemd[1]: Unit kibana.service entered failed state.  
Dec 10 03:49:51 elasticsearch.local systemd[1]: kibana.service failed.

I'm not able to start both the services and currenlty version is 7

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 19, 2019, 1:32pm UTC](https://discuss.elastic.co/t/please-help/181457/2 "2019-05-19T13:32:34Z")

</div>

What do your actual Elasticsearch logs show?

---

<div class="post-metadata">

**Author:** ![Aryan90](https://avatars.discourse-cdn.com/v4/letter/a/e68b1a/32.png) [@Aryan90](https://discuss.elastic.co/u/Aryan90)\
**Post date:** [May 19, 2019, 5:10pm UTC](https://discuss.elastic.co/t/please-help/181457/3 "2019-05-19T17:10:39Z")

</div>

Elasticsearch logs

[2018-12-10T03:10:24,240][INFO][o.e.p.PluginsService] [elasticsearch.local] loaded module [x-pack-ml]  
[2018-12-10T03:10:24,240][INFO][o.e.p.PluginsService] [elasticsearch.local] loaded module [x-pack-monitoring]  
[2018-12-10T03:10:24,240][INFO][o.e.p.PluginsService] [elasticsearch.local] loaded module [x-pack-rollup]  
[2018-12-10T03:10:24,240][INFO][o.e.p.PluginsService] [elasticsearch.local] loaded module [x-pack-security]  
[2018-12-10T03:10:24,240][INFO][o.e.p.PluginsService] [elasticsearch.local] loaded module [x-pack-sql]  
[2018-12-10T03:10:24,240][INFO][o.e.p.PluginsService] [elasticsearch.local] loaded module [x-pack-watcher]  
[2018-12-10T03:10:24,241][INFO][o.e.p.PluginsService] [elasticsearch.local] no plugins loaded  
[2018-12-10T03:10:33,308][INFO][o.e.x.s.a.s.FileRolesStore] [elasticsearch.local] parsed [0] roles from file [/etc/elasticsearch/roles.yml]  
[2018-12-10T03:10:36,743][INFO][o.e.x.m.p.l.CppLogMessageHandler] [elasticsearch.local] [controller/75660] [Main.cc@109] controller (64 bit): Version 7.0.1 (Build 6a88928693d862) Copyright (c) 2019 Elasticsearch BV  
[2018-12-10T03:10:38,961][DEBUG][o.e.a.ActionModule] [elasticsearch.local] Using REST wrapper from plugin org.elasticsearch.xpack.security.Security  
[2018-12-10T03:10:40,326][INFO][o.e.d.DiscoveryModule] [elasticsearch.local] using discovery type [zen] and seed hosts providers [settings]  
[2018-12-10T03:10:44,121][INFO][o.e.n.Node] [elasticsearch.local] initialized  
[2018-12-10T03:10:44,122][INFO][o.e.n.Node] [elasticsearch.local] starting ...  
[2018-12-10T03:10:44,858][INFO][o.e.t.TransportService] [elasticsearch.local] publish\_address {127.0.0.1:9300}, bound\_addresses {[::1]:9300}, {127.0.0.1:9300}  
[2018-12-10T03:10:44,910][WARN][o.e.b.BootstrapChecks] [elasticsearch.local] the default discovery settings are unsuitable for production use; at least one of [discovery.seed\_hosts, discovery.seed\_providers, cluster.initial\_master\_nodes] must be configured  
[2018-12-10T03:10:44,971][INFO][o.e.c.c.ClusterBootstrapService] [elasticsearch.local] no discovery configuration found, will perform best-effort cluster bootstrapping after [3s] unless existing master is discovered  
[2018-12-10T03:10:47,974][INFO][o.e.c.c.Coordinator] [elasticsearch.local] setting initial configuration to VotingConfiguration{BXhH-TIoS8qrKlhULvRG-Q}  
[2018-12-10T03:10:48,312][INFO][o.e.c.s.MasterService] [elasticsearch.local] elected-as-master ([1] nodes joined)[{elasticsearch.local}{BXhH-TIoS8qrKlhULvRG-Q}{vvnMuNAWQhuDvD\_1ROnKFA}{127.0.0.1}{127.0.0.1:9300}{ml.machine\_memory=2906284032, xpack.installed=tru[2018-12-10T03:10:49,171][INFO][o.e.c.m.MetaDataIndexTemplateService] [elasticsearch.local] adding template [.monitoring-logstash] for index patterns [.monitoring-logstash-7-_]  
[2018-12-10T03:10:49,260][INFO][o.e.c.m.MetaDataIndexTemplateService] [elasticsearch.local] adding template [.monitoring-es] for index patterns [.monitoring-es-7-_]  
[2018-12-10T03:10:49,326][INFO][o.e.c.m.MetaDataIndexTemplateService] [elasticsearch.local] adding template [.monitoring-beats] for index patterns [.monitoring-beats-7-_]  
[2018-12-10T03:10:49,406][INFO][o.e.c.m.MetaDataIndexTemplateService] [elasticsearch.local] adding template [.monitoring-alerts-7] for index patterns [.monitoring-alerts-7]  
[2018-12-10T03:10:49,473][INFO][o.e.c.m.MetaDataIndexTemplateService] [elasticsearch.local] adding template [.monitoring-kibana] for index patterns [.monitoring-kibana-7-_]  
[2018-12-10T03:10:49,541][INFO][o.e.x.i.a.TransportPutLifecycleAction] [elasticsearch.local] adding index lifecycle policy [watch-history-ilm-policy]  
[2018-12-10T03:10:49,732][INFO][o.e.l.LicenseService] [elasticsearch.local] license [ebb566ef-0441-4e9f-8176-13b7079fc1b1] mode [basic] - valid  
[2018-12-10T03:19:02,492][INFO][o.e.n.Node] [elasticsearch.local] stopping ...  
[2018-12-10T03:19:02,531][INFO][o.e.x.w.WatcherService] [elasticsearch.local] stopping watch service, reason [shutdown initiated]  
[2018-12-10T03:19:02,604][INFO][o.e.x.m.p.l.CppLogMessageHandler] [elasticsearch.local] [controller/75660] [Main.cc@148] Ml controller exiting  
[2018-12-10T03:19:02,619][INFO][o.e.x.m.p.NativeController] [elasticsearch.local] Native controller process has stopped - no new native processes can be started  
[2018-12-10T03:19:02,628][INFO][o.e.n.Node] [elasticsearch.local] stopped  
[2018-12-10T03:19:02,629][INFO][o.e.n.Node] [elasticsearch.local] closing ...  
[2018-12-10T03:19:02,699][INFO][o.e.n.Node] [elasticsearch.local] closed

Kibana logs

[root@elasticsearch ~]# systemctl status kibana -l  
● kibana.service - Kibana  
Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)  
Active: failed (Result: start-limit) since Thu 2019-05-16 19:57:46 EDT; 2h 35min ago  
Main PID: 4326 (code=exited, status=1/FAILURE)

May 16 19:57:46 elasticsearch.local systemd[1]: kibana.service holdoff time over, scheduling restart.  
May 16 19:57:46 elasticsearch.local systemd[1]: Stopped Kibana.  
May 16 19:57:46 elasticsearch.local systemd[1]: start request repeated too quickly for kibana.service  
May 16 19:57:46 elasticsearch.local systemd[1]: Failed to start Kibana.  
May 16 19:57:46 elasticsearch.local systemd[1]: Unit kibana.service entered failed state.  
May 16 19:57:46 elasticsearch.local systemd[1]: kibana.service failed.  
May 16 20:21:26 elasticsearch.local systemd[1]: [/etc/systemd/system/kibana.service:3] Unknown lvalue 'StartLimitIntervalSec' in section 'Unit'  
May 16 20:21:26 elasticsearch.local systemd[1]: [/etc/systemd/system/kibana.service:4] Unknown lvalue 'StartLimitBurst' in section 'Unit'  
May 16 21:25:49 elasticsearch.local systemd[1]: [/etc/systemd/system/kibana.service:3] Unknown lvalue 'StartLimitIntervalSec' in section 'Unit'  
May 16 21:25:49 elasticsearch.local systemd[1]: [/etc/systemd/system/kibana.service:4] Unknown lvalue 'StartLimitBurst' in section 'Unit'

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 19, 2019, 7:20pm UTC](https://discuss.elastic.co/t/please-help/181457/4 "2019-05-19T19:20:32Z")

</div>

Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

> [@Aryan90](#):
>
> [2018-12-10T03:10:49,732][INFO][o.e.l.LicenseService] [elasticsearch.local] license [ebb566ef-0441-4e9f-8176-13b7079fc1b1] mode [basic] - valid  
> [2018-12-10T03:19:02,492][INFO][o.e.n.Node] [elasticsearch.local] stopping ...  
> [2018-12-10T03:19:02,531][INFO][o.e.x.w.WatcherService] [elasticsearch.local] stopping watch service, reason [shutdown initiated]

Basically that says the process started ok, but something then asked it to shutdown. Which it did.

---

<div class="post-metadata">

**Author:** ![Aryan90](https://avatars.discourse-cdn.com/v4/letter/a/e68b1a/32.png) [@Aryan90](https://discuss.elastic.co/u/Aryan90)\
**Post date:** [May 22, 2019, 6:15pm UTC](https://discuss.elastic.co/t/please-help/181457/5 "2019-05-22T18:15:22Z")

</div>

Thanks for replying.  
i read it somewhere but I'm not able to understand how to write that code within \<\> . Could you please show me how to use that with the code?

---

<div class="post-metadata">

**Author:** ![elk11](https://avatars.discourse-cdn.com/v4/letter/e/45deac/32.png) [@elk11](https://discuss.elastic.co/u/elk11)\
**Post date:** [May 22, 2019, 6:21pm UTC](https://discuss.elastic.co/t/please-help/181457/6 "2019-05-22T18:21:22Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/f/f/ff16520195529dd89d8ed9c9cf41f19bcf8e9272.png)

I select the log and then click on \</\> to format the logs.

---

<div class="post-metadata">

**Author:** ![Aryan90](https://avatars.discourse-cdn.com/v4/letter/a/e68b1a/32.png) [@Aryan90](https://discuss.elastic.co/u/Aryan90)\
**Post date:** [May 22, 2019, 6:24pm UTC](https://discuss.elastic.co/t/please-help/181457/7 "2019-05-22T18:24:34Z")

</div>

@elk11 I'm still not getting as i'm new in elk. and where do i have to change in configuration file.

---

<div class="post-metadata">

**Author:** ![Aryan90](https://avatars.discourse-cdn.com/v4/letter/a/e68b1a/32.png) [@Aryan90](https://discuss.elastic.co/u/Aryan90)\
**Post date:** [May 22, 2019, 6:29pm UTC](https://discuss.elastic.co/t/please-help/181457/8 "2019-05-22T18:29:09Z")

</div>

Version 7

[root@elasticsearch elasticsearch]# systemctl status elasticsearch -l  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Wed 2019-05-22 19:52:17 EDT; 6min ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 7125 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 7125 (code=exited, status=1/FAILURE)

May 22 19:52:17 elasticsearch.local elasticsearch[7125]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150)  
May 22 19:52:17 elasticsearch.local elasticsearch[7125]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)  
May 22 19:52:17 elasticsearch.local elasticsearch[7125]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)  
May 22 19:52:17 elasticsearch.local elasticsearch[7125]: at org.elasticsearch.cli.Command.main(Command.java:90)  
May 22 19:52:17 elasticsearch.local elasticsearch[7125]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115)  
May 22 19:52:17 elasticsearch.local elasticsearch[7125]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)  
May 22 19:52:17 elasticsearch.local elasticsearch[7125]: Refer to the log for complete error details.  
May 22 19:52:17 elasticsearch.local systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
May 22 19:52:17 elasticsearch.local systemd[1]: Unit elasticsearch.service entered failed state.  
May 22 19:52:17 elasticsearch.local systemd[1]: elasticsearch.service failed.

---

<div class="post-metadata">

**Author:** ![elk11](https://avatars.discourse-cdn.com/v4/letter/e/45deac/32.png) [@elk11](https://discuss.elastic.co/u/elk11)\
**Post date:** [May 22, 2019, 6:31pm UTC](https://discuss.elastic.co/t/please-help/181457/9 "2019-05-22T18:31:24Z")

</div>

> I'm still not getting as i'm new in elk. and where do i have to change in configuration file.

If you are asking about code formatting, The code formatting on this forum has nothing to do with elasticsearch config file.

It's just that when you are copy pasting log/code/config files, Select the content and press \</\>

---

<div class="post-metadata">

**Author:** ![Aryan90](https://avatars.discourse-cdn.com/v4/letter/a/e68b1a/32.png) [@Aryan90](https://discuss.elastic.co/u/Aryan90)\
**Post date:** [May 22, 2019, 6:32pm UTC](https://discuss.elastic.co/t/please-help/181457/10 "2019-05-22T18:32:45Z")

</div>

```
 ● elasticsearch.service - Elasticsearch

```

Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Wed 2019-05-22 19:59:41 EDT; 7s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 7226 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 7226 (code=exited, status=1/FAILURE)

May 22 19:59:41 elasticsearch.local elasticsearch[7226]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150)  
May 22 19:59:41 elasticsearch.local elasticsearch[7226]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)  
May 22 19:59:41 elasticsearch.local elasticsearch[7226]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)  
May 22 19:59:41 elasticsearch.local elasticsearch[7226]: at org.elasticsearch.cli.Command.main(Command.java:90)  
May 22 19:59:41 elasticsearch.local elasticsearch[7226]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115)  
May 22 19:59:41 elasticsearch.local elasticsearch[7226]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)  
May 22 19:59:41 elasticsearch.local elasticsearch[7226]: Refer to the log for complete error details.  
May 22 19:59:41 elasticsearch.local systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
May 22 19:59:41 elasticsearch.local systemd[1]: Unit elasticsearch.service entered failed state.  
May 22 19:59:41 elasticsearch.local systemd[1]: elasticsearch.service failed.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 19, 2019, 6:35pm UTC](https://discuss.elastic.co/t/please-help/181457/12 "2019-06-19T18:35:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
