# Plugin installation issue, probably related to YAML

**URL:** https://discuss.elastic.co/t/plugin-installation-issue-probably-related-to-yaml/349404
**Category:** Elasticsearch
**Created:** [December 15, 2023, 12:32am UTC](https://discuss.elastic.co/t/plugin-installation-issue-probably-related-to-yaml/349404 "2023-12-15T00:32:22Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![jediD83](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jedid83/32/130029_2.png) [@jediD83](https://discuss.elastic.co/u/jediD83)
#### Post date: [December 15, 2023, 12:32am UTC](https://discuss.elastic.co/t/plugin-installation-issue-probably-related-to-yaml/349404/1 "2023-12-15T00:32:22Z")

</div>

Good day. The installation of the Elasticsearch's plugin for Zammad should be straightforward. After `apt install elasticsearch` using [Set up Elasticsearch](https://docs.zammad.org/en/latest/install/elasticsearch.html#configure-zammad-with-elasticsearch) guide, its just

`sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment`

And yet, I got this long error instead.

```auto
Exception in thread "main" SettingsException[Failed to load settings from [elasticsearch.yml]]; nested: MarkedYAMLException[while scanning a simple key
 in 'reader', line 118, column 1:
    $ zammad run rails r "Setting.se ... 
    ^
could not find expected ':'
 in 'reader', line 120, column 1:
    # Build the search index
    ^

 at [Source: (sun.nio.ch.ChannelInputStream); line: 115, column: 42]]; nested: ScannerException[while scanning a simple key
 in 'reader', line 118, column 1:
    $ zammad run rails r "Setting.se ... 
    ^
could not find expected ':'
 in 'reader', line 120, column 1:
    # Build the search index
    ^
];
	at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1189)
	at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1160)
	at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:75)
	at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:91)
	at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:82)
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:77)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)
	at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:95)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)
	at org.elasticsearch.cli.Command.main(Command.java:77)
	at org.elasticsearch.plugins.cli.PluginCli.main(PluginCli.java:36)
Caused by: com.fasterxml.jackson.dataformat.yaml.snakeyaml.error.MarkedYAMLException: while scanning a simple key
 in 'reader', line 118, column 1:
    $ zammad run rails r "Setting.se ... 
    ^
could not find expected ':'
 in 'reader', line 120, column 1:
    # Build the search index
    ^

 at [Source: (sun.nio.ch.ChannelInputStream); line: 115, column: 42]
	at com.fasterxml.jackson.dataformat.yaml.snakeyaml.error.MarkedYAMLException.from(MarkedYAMLException.java:28)
	at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:422)
	at org.elasticsearch.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:73)
	at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:706)
	at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:675)
	at org.elasticsearch.common.settings.Settings.access$400(Settings.java:75)
	at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1185)
	... 10 more
Caused by: while scanning a simple key
 in 'reader', line 118, column 1:
    $ zammad run rails r "Setting.se ... 
    ^
could not find expected ':'
 in 'reader', line 120, column 1:
    # Build the search index
    ^

	at org.yaml.snakeyaml.scanner.ScannerImpl.stalePossibleSimpleKeys(ScannerImpl.java:527)
	at org.yaml.snakeyaml.scanner.ScannerImpl.needMoreTokens(ScannerImpl.java:332)
	at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:262)
	at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:662)
	at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:185)
	at org.yaml.snakeyaml.parser.ParserImpl.getEvent(ParserImpl.java:195)
	at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:418)
	... 15 more

```

I read that since version 8.2.0, [errors with YAML parser](https://discuss.elastic.co/t/update-to-8-2-2-showing-error-in-keystore-init/307076/5) become an issue. However, there is no error number/label for me to check, and I had yet to find the solution related to my case.

Was I suppose to bring this issue to the GitHub's Elasticsearch, here, or Zammad? Was there a node-YAML apt I'm suppose to install?

Thank in advance for anyone who help.

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [December 15, 2023, 8:33am UTC](https://discuss.elastic.co/t/plugin-installation-issue-probably-related-to-yaml/349404/2 "2023-12-15T08:33:28Z")

</div>

Welcome!

What is your elastic version? Asking because in the recent versions, the ingest attachment plugin is a module (available with the distribution) and not a plugin anymore (which needs to be installed).

---

<div class="post-metadata">

### Author: ![jediD83](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jedid83/32/130029_2.png) [@jediD83](https://discuss.elastic.co/u/jediD83)
#### Post date: [December 15, 2023, 1:18pm UTC](https://discuss.elastic.co/t/plugin-installation-issue-probably-related-to-yaml/349404/3 "2023-12-15T13:18:25Z")

</div>

I believe it is this one by using this command `curl -XGET 'http://localhost:9200' `

```auto
  "version" : {
    "number" : "7.17.15",
    "build_flavor" : "default",
    "build_type" : "deb",
    "build_hash" : "0b8ecfb4378335f4689c4223d1f1115f16bef3ba",
    "build_date" : "2023-11-10T22:03:46.987399016Z",
    "build_snapshot" : false,
    "lucene_version" : "8.11.1",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  },

```

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [December 15, 2023, 2:29pm UTC](https://discuss.elastic.co/t/plugin-installation-issue-probably-related-to-yaml/349404/4 "2023-12-15T14:29:34Z")

</div>

What is your `elasticsearch.yml` file?

And what is Zammad?

---

<div class="post-metadata">

### Author: ![jediD83](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jedid83/32/130029_2.png) [@jediD83](https://discuss.elastic.co/u/jediD83)
#### Post date: [December 15, 2023, 10:38pm UTC](https://discuss.elastic.co/t/plugin-installation-issue-probably-related-to-yaml/349404/5 "2023-12-15T22:38:05Z")

</div>

Zammad is simply a web based open source helpdesk system.

I got the plugin resolved by rereading the [Zammad's setup Elasticsearch](https://docs.zammad.org/en/latest/install/elasticsearch.html#step-2-suggested-configuration). Look like my 2 mistakes were

1. Since its version 7 and not 8, I was using HTTPS instead of HTTP.
2. There were added texts that should not be in the yml file, because they are commands. Its the long error code I had initially posted `$ zammad...`, etc. (I should had realized earlier with the $.)

Thank for trying to help out dadoonet. The problem is solved.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 12, 2024, 10:38pm UTC](https://discuss.elastic.co/t/plugin-installation-issue-probably-related-to-yaml/349404/6 "2024-01-12T22:38:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
