# Plugin logstash-output-lumberjack not available for Vers. 5

**URL:** <https://discuss.elastic.co/t/plugin-logstash-output-lumberjack-not-available-for-vers-5/91113>\
**Category:** Logstash\
**Created:** [June 28, 2017, 2:01pm UTC](https://discuss.elastic.co/t/plugin-logstash-output-lumberjack-not-available-for-vers-5/91113 "2017-06-28T14:01:42Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![lordofthings](https://avatars.discourse-cdn.com/v4/letter/l/858c86/32.png) [@lordofthings](https://discuss.elastic.co/u/lordofthings)\
**Post date:** [June 28, 2017, 2:01pm UTC](https://discuss.elastic.co/t/plugin-logstash-output-lumberjack-not-available-for-vers-5/91113/1 "2017-06-28T14:01:42Z")

</div>

Hi all,

The plugin logstash-output-lumberjack is still not available for Logstash 5.x  
Does anybody now what happen with it and if it will be available near future?

This project is still active on github ([https://github.com/logstash-plugins/logstash-output-lumberjack](https://github.com/logstash-plugins/logstash-output-lumberjack)) but the last build version is 10 month old. The last version 3.1.3 is still failing.

At elastic repository this plugin can't be found.

```
 :/usr/share/logstash# DEBUG=1 bin/logstash-plugin install logstash-output-lumberjack
DEBUG: exec /usr/share/logstash/vendor/jruby/bin/jruby /usr/share/logstash/lib/pluginmanager/main.rb install logstash-output-lumberjack
Picked up _JAVA_OPTIONS: -Dhttps.proxyHost=xxxxxxxxxxx -Dhttps.proxyPort=3128
Looking if package named: logstash-output-lumberjack exists at https://artifacts.elastic.co/downloads/logstash-plugins/logstash-output-lumberjack/logstash-output-lumberjack-5.3.3.zip
Errno::ECONNREFUSED: Connection refused - Connection refused
          initialize at org/jruby/ext/socket/RubyTCPSocket.java:126
                open at org/jruby/RubyIO.java:1197
             connect at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:763
             timeout at org/jruby/ext/timeout/Timeout.java:98
             connect at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:763
            do_start at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:756
               start at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:745
               start at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:557
               start at /usr/share/logstash/lib/pluginmanager/utils/http_client.rb:13
  remote_file_exist? at /usr/share/logstash/lib/pluginmanager/utils/http_client.rb:23
   get_installer_for at /usr/share/logstash/lib/pluginmanager/pack_fetch_strategy/repository.rb:32
              create at /usr/share/logstash/lib/pluginmanager/install_strategy_factory.rb:15
                each at org/jruby/RubyArray.java:1613
              create at /usr/share/logstash/lib/pluginmanager/install_strategy_factory.rb:14
             execute at /usr/share/logstash/lib/pluginmanager/install.rb:30
                 run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
             execute at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11
                 run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
                 run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132
              (root) at /usr/share/logstash/lib/pluginmanager/main.rb:46

```

greetings

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [June 28, 2017, 2:12pm UTC](https://discuss.elastic.co/t/plugin-logstash-output-lumberjack-not-available-for-vers-5/91113/2 "2017-06-28T14:12:25Z")

</div>

> At elastic repository this plugin can't be found.

No, that error message indicates that the plugin manager's HTTP client is unable to connect to [artifacts.elastic.co:443](http://artifacts.elastic.co:443). It has nothing to do with the lumberjack output plugin.

---

<div class="post-metadata">

**Author:** ![lordofthings](https://avatars.discourse-cdn.com/v4/letter/l/858c86/32.png) [@lordofthings](https://discuss.elastic.co/u/lordofthings)\
**Post date:** [June 29, 2017, 10:08am UTC](https://discuss.elastic.co/t/plugin-logstash-output-lumberjack-not-available-for-vers-5/91113/3 "2017-06-29T10:08:10Z")

</div>

The file [https://artifacts.elastic.co/downloads/logstash-plugins/logstash-output-lumberjack/logstash-output-lumberjack-5.3.3.zip](https://artifacts.elastic.co/downloads/logstash-plugins/logstash-output-lumberjack/logstash-output-lumberjack-5.3.3.zip) doesn't exist.

The logstash-plugin could make the plugin it self with gems., but it think it would be much easer if the ready zip file where there for download 🙂

thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 27, 2017, 10:08am UTC](https://discuss.elastic.co/t/plugin-logstash-output-lumberjack-not-available-for-vers-5/91113/4 "2017-07-27T10:08:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
