# Port 80 is already in use. Another instance of Kibana may be running

**URL:** <https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939>\
**Category:** Kibana\
**Tags:** elastic-stack-monitoring, elastic-stack-security, elastic-stack-alerting\
**Created:** [September 27, 2023, 1:20am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939 "2023-09-27T01:20:42Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nghia\_D\_ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nghia_d_ng/32/123483_2.png) [@Nghia\_D\_ng](https://discuss.elastic.co/u/Nghia_D_ng)\
**Post date:** [September 27, 2023, 1:20am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/1 "2023-09-27T01:20:42Z")

</div>

Hi team,

I'm having problems with kibana  
Currently I have kibana configured with port 80 and displaying the web interface normally. But when I change to kibana's default port, I get an error and no longer display the web interface.  
I also have nginx port 80 installed on this server, but I checked and there was no conflict. Maybe it's because some kibana process is running on a node that I haven't found yet.

Help me please!

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/2/9/29709ad7dab6d6d3a50bae66aedf13955549f5c3.jpeg)  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/d/fd0d65431cbefe742fc5dea842e82793e6bfb789.jpeg)

---

<div class="post-metadata">

**Author:** ![ashishtiwari1993](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ashishtiwari1993/32/135241_2.png) [@ashishtiwari1993](https://discuss.elastic.co/u/ashishtiwari1993)\
**Post date:** [September 27, 2023, 5:42am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/2 "2023-09-27T05:42:45Z")

</div>

HI @Nghia_D_ng,

Not sure which process has bind this port. Probably you can check with below command

```sh
sudo netstat -tupln | grep LISTEN

```

It will list all ports which is in use.

---

<div class="post-metadata">

**Author:** ![Nghia\_D\_ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nghia_d_ng/32/123483_2.png) [@Nghia\_D\_ng](https://discuss.elastic.co/u/Nghia_D_ng)\
**Post date:** [September 27, 2023, 6:03am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/3 "2023-09-27T06:03:47Z")

</div>

Hi ashishtiwari1993,

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/9/793ce47a6a5b72325c1a06c696864244953cd5ab.png)

---

<div class="post-metadata">

**Author:** ![Nghia\_D\_ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nghia_d_ng/32/123483_2.png) [@Nghia\_D\_ng](https://discuss.elastic.co/u/Nghia_D_ng)\
**Post date:** [September 27, 2023, 6:04am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/4 "2023-09-27T06:04:25Z")

</div>

I've tried checking everything but to no avail  
Maybe due to using node process

---

<div class="post-metadata">

**Author:** ![Nghia\_D\_ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nghia_d_ng/32/123483_2.png) [@Nghia\_D\_ng](https://discuss.elastic.co/u/Nghia_D_ng)\
**Post date:** [September 29, 2023, 7:05am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/5 "2023-09-29T07:05:27Z")

</div>

Hi ashishtiwari1993,

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/2/a/2a373cc8357dd68c8ce54447e5e2b131d9a3d423.jpeg)  
Please help me!

---

<div class="post-metadata">

**Author:** ![Nghia\_D\_ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nghia_d_ng/32/123483_2.png) [@Nghia\_D\_ng](https://discuss.elastic.co/u/Nghia_D_ng)\
**Post date:** [September 29, 2023, 7:16am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/6 "2023-09-29T07:16:45Z")

</div>

Hi @ashishtiwari1993 ,  
Please help me!

---

<div class="post-metadata">

**Author:** ![ashishtiwari1993](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ashishtiwari1993/32/135241_2.png) [@ashishtiwari1993](https://discuss.elastic.co/u/ashishtiwari1993)\
**Post date:** [September 29, 2023, 12:43pm UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/7 "2023-09-29T12:43:36Z")

</div>

Hi @Nghia_D_ng,

I am not sure about which process has occupied your port. Could you try to re install the kibana? Just uninstall it and check still that 5601 port is blocked or not.

---

<div class="post-metadata">

**Author:** ![Nghia\_D\_ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nghia_d_ng/32/123483_2.png) [@Nghia\_D\_ng](https://discuss.elastic.co/u/Nghia_D_ng)\
**Post date:** [October 2, 2023, 12:58am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/8 "2023-10-02T00:58:39Z")

</div>

Hi @ashishtiwari1993 ,

\<Sep 27 17:14:31 Kibana kibana[1251275]: {"type":"log","@timestamp":"2023-09-27T10:14:31Z","tags"🙁"error","plugins","reporting","validations"],"pid":1251275,"message":"The Reporting plugin encountered issues launching Chromium in a self-test. You may have trouble generating reports."}\>

\<Sep 27 17:14:31 Kibana kibana[1251275]: {"type":"log","@timestamp":"2023-09-27T10:14:31Z","tags"🙁"error","plugins","reporting","validations"],"pid":1251275,"message":"ErrorEvent {\n target:\n WebSocket {\n \_events:\n [Object: null prototype] { open: [Function], error: [Function] },\n \_eventsCount: 2,\n \_maxListeners: undefined,\n readyState: 3,\n protocol: '',\n \_binaryType: 'nodebuffer',\n \_closeFrameReceived: false,\n \_closeFrameSent: false,\n \_closeMessage: '',\n \_closeTimer: null,\n \_closeCode: 1006,\n \_extensions: {},\n \_receiver: null,\n \_sender: null,\n \_socket: null,\n \_isServer: false,\n \_redirects: 0,\n url:\n 'ws://127.0.0.1:45265/devtools/browser/3f83980b-db25-4b6b-a162-1aacefb57be4',\n \_req: null },\n type: 'error',\n message :'socket hang up',\n error:\n { Error: socket hang up\n at createHangUpError (\_http\_client.js:332:15)\n at Socket.socketOnEnd (\_http\_client.js:435:23)\n at Socket.emit (events.js:203:15)\n at endReadableNT (\_stream\_readable.js:1145:12)\n at process.\_tickCallback (internal/process/next\_tick.js:63:19) at endReadableNT (\_stream\_readable.js:1145:12)\n at process.\_tickCallback (internal/process/next\_tick.js:63:19) code: 'ECONNRESET' } }"}\>

\<Sep 27 17:14:31 Kibana kibana[1251275]: {"type":"log","@timestamp":"2023-09-27T10:14:31Z","tags"🙁"error","plugins","reporting","validations"],"pid":1251275,"message":"Error: Could not close browser client handle!\n at browserFactory.test.then.browser (/u01/kibana-7.9.0-linux-x86\_64/x-pack/plugins/reporting/server/lib/validate/validate\_browser.js:26:15)\n at process.\_tickCallback (internal\>\>

\<Sep 27 17:14:31 Kibana kibana[1251275]: {"type":"log","@timestamp":"2023-09-27T10:14:31Z","tags"🙁"warning","plugins","reporting","validations"],"pid":1251275,"message":"Reporting plugin self-check generated a warning: Error: Could not close browser client handle!"}\>

---

<div class="post-metadata">

**Author:** ![ashishtiwari1993](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ashishtiwari1993/32/135241_2.png) [@ashishtiwari1993](https://discuss.elastic.co/u/ashishtiwari1993)\
**Post date:** [October 3, 2023, 1:49pm UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/9 "2023-10-03T13:49:34Z")

</div>

Hi @Nghia_D_ng,

You can troubleshoot this by following [this](https://www.elastic.co/guide/en/kibana/current/reporting-troubleshooting.html) step. As kibana is using chrome for report generation.

Also have a look on [this](https://github.com/elastic/kibana/issues/53829) issue. You can one of the suggested solution.

---

<div class="post-metadata">

**Author:** ![Nghia\_D\_ng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nghia_d_ng/32/123483_2.png) [@Nghia\_D\_ng](https://discuss.elastic.co/u/Nghia_D_ng)\
**Post date:** [October 4, 2023, 1:29am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/10 "2023-10-04T01:29:00Z")

</div>

Hi @ashishtiwari1993 ,

I have also researched your suggestion  
This still doesn't seem to solve my problem  
Thank you, if you have further assistance please message me

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 4, 2023, 4:01am UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/11 "2023-10-04T04:01:48Z")

</div>

My suggestion is to get Kibana / Elasticsearch without the nginx proxy first and then only after all that works introduce the proxy.

Reduce the variables and complexities.

---

<div class="post-metadata">

**Author:** ![AlekseyD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alekseyd/32/126032_2.png) [@AlekseyD](https://discuss.elastic.co/u/AlekseyD)\
**Post date:** [October 4, 2023, 12:35pm UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/12 "2023-10-04T12:35:11Z")

</div>

@Nghia_D_ng Hi! Have you tried checking the list of processes on the host?

```auto
ps aux | grep kibana

```

Or try list port listeners like this

```auto
lsof -i :80 | grep LISTEN

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 1, 2023, 12:35pm UTC](https://discuss.elastic.co/t/port-80-is-already-in-use-another-instance-of-kibana-may-be-running/343939/13 "2023-11-01T12:35:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
