# POSTGRESQL 9.6 Y ELASTICSEARCH 8.7.0

**URL:** <https://discuss.elastic.co/t/postgresql-9-6-y-elasticsearch-8-7-0/333711>\
**Category:** Elasticsearch\
**Created:** [May 18, 2023, 4:30am UTC](https://discuss.elastic.co/t/postgresql-9-6-y-elasticsearch-8-7-0/333711 "2023-05-18T04:30:59Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Giancarlo\_Huapaya\_Ra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/giancarlo_huapaya_ra/32/120262_2.png) [@Giancarlo\_Huapaya\_Ra](https://discuss.elastic.co/u/Giancarlo_Huapaya_Ra)\
**Post date:** [May 18, 2023, 4:30am UTC](https://discuss.elastic.co/t/postgresql-9-6-y-elasticsearch-8-7-0/333711/1 "2023-05-18T04:30:59Z")

</div>

Hello everyone,

I have a problem with the logs that I receive from postgresql version 9.6 to my elasticseach version 8.7.0.

I have configured as instructed but I get the error shown in the image:

![image](https://us1.discourse-cdn.com/elastic/original/3X/0/3/03f02d64866979b80eb267040aad15e9bc2fba8c.png)

I have another server with Postgresql version 9.5 but I don't have the same error, please could you help me to solve this problem.

Thank you in advance.

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [May 18, 2023, 9:00am UTC](https://discuss.elastic.co/t/postgresql-9-6-y-elasticsearch-8-7-0/333711/2 "2023-05-18T09:00:30Z")

</div>

Hi Giancarlo,

How are you ingesting the logs into Elasticsearch? Are you using Logstash? From the error it looks like the grok pattern doesn't match the log entry coming in.

---

<div class="post-metadata">

**Author:** ![Giancarlo\_Huapaya\_Ra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/giancarlo_huapaya_ra/32/120262_2.png) [@Giancarlo\_Huapaya\_Ra](https://discuss.elastic.co/u/Giancarlo_Huapaya_Ra)\
**Post date:** [May 22, 2023, 1:54pm UTC](https://discuss.elastic.co/t/postgresql-9-6-y-elasticsearch-8-7-0/333711/3 "2023-05-22T13:54:15Z")

</div>

Hello, the error was because log\_line\_prefix was wrongly configured to receive the logs, I modified it and the problem was solved.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 19, 2023, 1:55pm UTC](https://discuss.elastic.co/t/postgresql-9-6-y-elasticsearch-8-7-0/333711/4 "2023-06-19T13:55:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
