# Prime shard closed but cluster was green, but bulk operations failed

**URL:** <https://discuss.elastic.co/t/prime-shard-closed-but-cluster-was-green-but-bulk-operations-failed/34837>\
**Category:** Elasticsearch\
**Created:** [November 17, 2015, 6:43pm UTC](https://discuss.elastic.co/t/prime-shard-closed-but-cluster-was-green-but-bulk-operations-failed/34837 "2015-11-17T18:43:39Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Slava\_G](https://avatars.discourse-cdn.com/v4/letter/s/e9c0ed/32.png) [@Slava\_G](https://discuss.elastic.co/u/Slava_G)\
**Post date:** [November 17, 2015, 6:43pm UTC](https://discuss.elastic.co/t/prime-shard-closed-but-cluster-was-green-but-bulk-operations-failed/34837/1 "2015-11-17T18:43:39Z")

</div>

Hi,  
I was in the middle of massive delete of the documents (routing was always to the same shard) when I started to get this exception on the bulk operation :  
_`RemoteTransportException[[Jackdaw][inet[/10.0.XX.YY:9300]][indices:data/write/bulk[s]]]; nested: EngineClosedException[[myindex][12] CurrentState[CLOSED] ];`_

Where cluster was green, replica shard was started and running, and prime shared was marked as started but without any information on what is going on it.  
Search on documents placed on that shard was working fine.  
What could be an issue here and how can I start this prime shard again.

Thanks

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 18, 2015, 10:11am UTC](https://discuss.elastic.co/t/prime-shard-closed-but-cluster-was-green-but-bulk-operations-failed/34837/2 "2015-11-18T10:11:13Z")

</div>

Is the index open?

---

<div class="post-metadata">

**Author:** ![Slava\_G](https://avatars.discourse-cdn.com/v4/letter/s/e9c0ed/32.png) [@Slava\_G](https://discuss.elastic.co/u/Slava_G)\
**Post date:** [November 18, 2015, 11:05am UTC](https://discuss.elastic.co/t/prime-shard-closed-but-cluster-was-green-but-bulk-operations-failed/34837/3 "2015-11-18T11:05:35Z")

</div>

Yes, index is open.

---

<div class="post-metadata">

**Author:** ![Guillermo\_Arias\_del\_](https://avatars.discourse-cdn.com/v4/letter/g/cab0a1/32.png) [@Guillermo\_Arias\_del\_](https://discuss.elastic.co/u/Guillermo_Arias_del_)\
**Post date:** [January 14, 2016, 10:56am UTC](https://discuss.elastic.co/t/prime-shard-closed-but-cluster-was-green-but-bulk-operations-failed/34837/4 "2016-01-14T10:56:50Z")

</div>

The same here, shards get closed without showing anything special, the cluster is green but I cannot index documents. How can I know that something is amiss? What should I do now? Restart the node?

---

<div class="post-metadata">

**Author:** ![Slava\_G](https://avatars.discourse-cdn.com/v4/letter/s/e9c0ed/32.png) [@Slava\_G](https://discuss.elastic.co/u/Slava_G)\
**Post date:** [January 26, 2016, 8:40am UTC](https://discuss.elastic.co/t/prime-shard-closed-but-cluster-was-green-but-bulk-operations-failed/34837/5 "2016-01-26T08:40:30Z")

</div>

In my case restarting the node solved the issue. But this issue is happening from time to time.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:21pm UTC](https://discuss.elastic.co/t/prime-shard-closed-but-cluster-was-green-but-bulk-operations-failed/34837/6 "2017-07-05T23:21:41Z")

</div>


